QNAP QSW-M2108 as a router for ISP connection

I am looking for a way of use this switch as a router, as well. It has an OpenWRT derived operating system but i think it misses some of the requred parts.
Basically, I added a stanza in /etc/config/network like this

config interface 'wan'
	option proto 'pppoe'
	option username 'XXXXXXX'
	option password 'YYYYYY'
	option peerdns '1'
	option ipv6 'auto'
	option keepalive '6 10'
	option ifname 'eth0.835'
	option defaultroute '1'

and then issued service network restart. At this point I see the ppp process will all parameteres trying to connect, but it does not complete the connection.

I tough that I had to specify the port to be used for the connection, so I added these two stanzas since the only way I found for specifying the ports is via the switch and switch_vlan:

config switch
	option name	'eth0'
	option reset	'1'
	option enable_vlan '1'

config switch_vlan
	option device	'eth0'
	option vlan	'835'
	option ports	'4t'

but this is still not working. In fact, I tried to plug the ISP cable in every ports without pppd connecting correctly.

I think that these new stanzas are completely ignored. From what I understood, this configuration is loaded by uci but it should be later used by other parts of the operating system. I think these parts are missing here.

So, the questions are: how may I check if ppp is using the correct port with the correct VLAN ID? Is there any command I may use in order to check the available switches and their parameter? The swconfig command is missing here. May I download it from somewhere for the armv7l architecture?

Thank you very much,

If you look at the top of your browser window, does it say QNAP support or OpenWrt?
Assuming it's the later, why are you asking us this question, again?

Hello @slh,
I am just spending some time on the only OpenWRT based system I own. I need some help and I thought that here I could be helped.
I understand this is not a support forum for the machine I work on, but it should be quite similar, and someone might reply with valuable information.

I switched from "Hardware Questions and Recommendations" to "Installing and Using OpenWrt" because the second question is more about swconfig and its successor ip command, and I think here my question would be more appropriate.

Thank you,

Except that after the chipset vendor and then the manufacturer are through with it, all bets are off and there is little resemblance to a normal OpenWrt system left (even more so on a non-router, with its own peculiar requirements (and things the vendor might not need for switch purposes, a firewall comes to mind)).

Really, we can't help you with that OEM system - and we don't want to[0] either.

[0] …dive into the changes some clueless chipset vendor/ OEM manufacturer has done, especially as source for many of these changes tends to be missing in the first place, so even if we did want to, in many cases we couldn't. It doesn't exactly help that OpenWrt doesn't support any Marvell Prestera based devices so far.

@slh, thank you very much for your last reply. Sadly I fully understand only some of the implications, but I understand this is complicated.
I'll stick with my current router for ISP connection, altough I was hoping to use the QNAP in order to reach the 2.5gbit/s my ISP offer.

Disclaimer: I have no experience with Marvell SOCs, nor did I look for a spec sheet/ diagrams or marketing blurbs, but...

A switch is a switch, because it has a massively parallel switch fabric, to offload the traffic into the hardware. The CPU has mostly cosmetic purposes (to run the webinterface) and usually only has a narrow band connection to the fabric.

Admittedly, Marvell tends to have rather fast/ well optimized SOCs -and I haven't checked at all if it advertizes software defined switching or L3 features- but PPPoE is a very CPU intensive protocol (ISPs mandating it for >500 MBit/s can be considered evil and clueless), I can't imagine that this switch could get anywhere close to routing/ NAT/ firewall 2.5 GBit/s via PPPoE.

EDIT: Just looking at QNAP's feature description confirms this to be a smart-managed L2 switch, without any L3 features (nor, documented, PPPoE support).