QMI LTE interface doesn't automatically get IP address

I set up a Sierra Wireless MC7354 LTE modem on the ~latest OpenWRT build. I got it to the point where it's connected, but I don't get an IP address automatically.

In order to get an ip address, I have to do ifup wwan0; ifup wwan1; udhcpc -i wwan1. Here's my config. I pieced it together from some old docs, and I wasn't sure if having a non-aliased interface was the right thing to do. The uqmi package is installed, so the qmi proto should work.

From my understanding, proto qmi automates uqmi commands like authentication, setting the apn, etc. I halfway assumed it would also automate dhcp, but I don't think it does. It's almost like I want two proto fields.

/etc/config/network

config interface 'wwan0'
        option ifname 'wwan0'
        option proto 'qmi'
        option device 'cdc-wdm0'
        option apn 'r.ispsn'
        # These settings are to be safe
        option delay 10
        option modes 'all'

config interface 'wwan1'
        option ifname 'wwan1'
        option proto 'qmi'
        option device 'cdc-wdm1'
        option apn 'r.ispsn'
        option delay 10
        option modes 'all'

And a sanity check that I'm connected:

root@OpenWrt:~# uqmi -d /dev/cdc-wdm0 --get-signal-info
{
        "type": "hdr",
        "rssi": -125,
        "ecio": 5,
        "io": -106,
        "type": "lte",
        "rssi": -84,
        "rsrq": -15,
        "rsrp": -109,
        "snr": -18
}
root@OpenWrt:~# uqmi -d /dev/cdc-wdm0 --get-data-status
"connected"

I think I fixed it. It turns out device needs to be an actual path, e.g. /dev/cdc-wdm0.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.