QCN9074+DR6018-S combination difficulties with setting up

Good afternoon to everyone, I've been reading forums and manuals for the 3rd week, I can't understand what the problem is. Please give me some advice for a solution.

I have a bunch of QCN9074+DR6018-S via pcie slot, 6018 working board, the problem is(I Think) in the QCN9074 module - it does not work.

From the point of view of the firmware, I have this situation now

Here are the details that may help to solve:

  1. Pci sees the device, but openwrt doesn't want to update for some reason (at first I thought the problem was in the drivers and their recognition) Service does not allow me to upload a screenshot, so I will have to copy paste(sorry):

root@SuperWireless:~# opkg update

Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ipq/ipq60xx/packages/base/Packages.gz.
wget: bad address 'downloads.openwrt.org'
Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ipq/ipq60xx/packages/nss/Packages.gz.
wget: bad address 'downloads.openwrt.org'
Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ipq/ipq60xx/packages/sigma_dut_open/Packages.gz.

root@SuperWireless:~lspci

00:00.0 Class 0604: 17cb:1003
01:00.0 Class 0280: 17cb:1104

root@SuperWireless:~# lsusb

Bus 001 Device 001: ID 1d6b:0002
Bus 002 Device 001: ID 1d6b:0003
Bus 003 Device 001: ID 1d6b:0002
Bus 004 Device 001: ID 1d6b:0003

2)cat etc/config/network

root@SuperWireless:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdf3:7904:bf58::/48'

config switch
        option name 'switch0'

config interface 'lan'
        option ifname 'eth0 eth1 eth2 eth3 eth4'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option multicast_querier '0'
        option igmp_snooping '0'
        option ipaddr '192.168.1.2'

config interface 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option proto 'dhcpv6'

3)Here is cat /etc/config/wireless

root@SuperWireless:~# cat /etc/config/wireless

config wifi-device 'wifi0'
        option type 'qcawificfg80211'
        option hwmode '11axa'
        option country '840'
        option htmode 'HT20'
        option HQrate '0'
        option txpower '3'
        option txantenna 'chain2 chain1'
        option txchainmask '3'
        option rxantenna 'chain2 chain1'
        option rxchainmask '3'
        option channel '153'

config wifi-iface
        option device 'wifi0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'
        option shortgi '1'
        option wds '1'
        option disabled '1'

config wifi-device 'wifi1'
        option type 'qcawificfg80211'
        option hwmode '11axg'
        option country '840'
        option htmode 'HT20'
        option HQrate '0'
        option txpower '3'
        option txantenna 'chain2 chain1'
        option txchainmask '3'
        option rxantenna 'chain2 chain1'
        option rxchainmask '3'
        option channel '5'

config wifi-iface
        option device 'wifi1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'
        option shortgi '1'
        option wds '1'
        option disabled '1'

config wifi-device 'wifi2'
        option type 'qcawificfg80211'
        option hwmode '11axa'
        option country '840'
        option txantenna 'chain4 chain3 chain2 chain1'
        option txchainmask '15'
        option rxantenna 'chain4 chain3 chain2 chain1'
        option rxchainmask '15'
        option htmode 'HT160'
        option band '3'
        option txpower '20'
        option channel '105'
        option scanlist 'enable'

config wifi-iface
        option device 'wifi2'
        option network 'lan'
        option shortgi '1'
        option key '12345678'
        option mode 'ap'
        option ssid '6 test'
        option encryption 'ccmp'
        option sae '1'
        list sae_password 'qwerty12345'
        option sae_pwe '1'
        option sae_require_mfp '1'
        option doth '1'
  1. and cat /etc/config/dhcp
    root@SuperWireless:~# cat /etc/config/dhcp
config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option force '1'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
  1. and cat /etc/config/firewall

root@SuperWireless:~# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option disabled '0'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fe80::/10'
        option src_port '547'
        option dest_ip 'fe80::/10'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config rule
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include 'map'
        option type 'script'
        option path '/etc/firewall.d/map_firewall'
        option family 'any'
        option reload '1'

config include 'miniupnpd'
        option type 'script'
        option path '/usr/share/miniupnpd/firewall.include'
        option family 'any'
        option reload '1'

config include 'qcanssecm'
        option type 'script'
        option path '/etc/firewall.d/qca-nss-ecm'
        option family 'any'
        option reload '1'

If you need any additional data, let me know, I will be happy to provide them.

It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

Okay, whats the device first off?