QCA9884 2,4GHz limited to 17dBm

Hello everybody
I've a DAP-2680 with lastest snapshot installed and

root@OpenWrt:~# opkg list-installed | grep ath10
ath10k-board-qca9984 - 20220509-1
ath10k-firmware-qca9984 - 20220509-1
kmod-ath10k-ct - 5.10.115+2022-05-13-f808496f-1

packages installed

Everything working fine except 2,4GHz transmit power is always limited to 17dBm even if I set it to 27dBm

What can I do to get the 20dBm are allowed here in my country? :frowning:
Thank you

SSH in to the router and run iw list

Post the results in preformatted text, by using the icon highlighted in red...

Screenshot 2022-05-20 011120

The Frequencies section will show what is supported.

any reason why you've chosen the channel 13 ?
what if you chose channel 1 ?

root@OpenWrt:~# iw list
Wiphy phy1
        wiphy index: 1
        max # scan SSIDs: 4
        max scan IEs length: 2257 bytes
        max # sched scan SSIDs: 0
        max # match sets: 0
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Device supports AP-side u-APSD.
        Device supports T-DLS.
        Available Antennas: TX 0x7 RX 0x7
        Configured Antennas: TX 0x7 RX 0x7
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * AP/VLAN
                 * monitor
                 * mesh point
                 * P2P-client
                 * P2P-GO
                 * outside context of a BSS
        Band 1:
                Capabilities: 0x11ef
                        RX LDPC
                        HT20/HT40
                        SM Power Save disabled
                        RX HT20 SGI
                        RX HT40 SGI
                        TX STBC
                        RX STBC 1-stream
                        Max AMSDU length: 3839 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 8 usec (0x06)
                HT TX/RX MCS rate indexes supported: 0-23
                Frequencies:
                        * 2412 MHz [1] (27.0 dBm)
                        * 2417 MHz [2] (27.0 dBm)
                        * 2422 MHz [3] (27.0 dBm)
                        * 2427 MHz [4] (27.0 dBm)
                        * 2432 MHz [5] (27.0 dBm)
                        * 2437 MHz [6] (27.0 dBm)
                        * 2442 MHz [7] (27.0 dBm)
                        * 2447 MHz [8] (27.0 dBm)
                        * 2452 MHz [9] (27.0 dBm)
                        * 2457 MHz [10] (27.0 dBm)
                        * 2462 MHz [11] (27.0 dBm)
                        * 2467 MHz [12] (27.0 dBm)
                        * 2472 MHz [13] (27.0 dBm)
                        * 2484 MHz [14] (disabled)
        valid interface combinations:
                 * #{ managed } <= 2048, #{ AP, mesh point } <= 8, #{ P2P-client, P2P-GO } <= 1, #{ IBSS } <= 1,
                   total <= 2048, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz }

        HT Capability overrides:
                 * MCS: ff ff ff ff ff ff ff ff ff ff
                 * maximum A-MSDU length
                 * supported channel width
                 * short GI for 40 MHz
                 * max A-MPDU length exponent
                 * min MPDU start spacing
        max # scan plans: 1
        max scan plan interval: -1
        max scan plan iterations: 0
        Supported extended features:
                * [ RRM ]: RRM
                * [ FILS_STA ]: STA FILS (Fast Initial Link Setup)
                * [ CQM_RSSI_LIST ]: multiple CQM_RSSI_THOLD records
                * [ CONTROL_PORT_OVER_NL80211 ]: control port over nl80211
                * [ TXQS ]: FQ-CoDel-enabled intermediate TXQs
                * [ AIRTIME_FAIRNESS ]: airtime fairness scheduling
                * [ SCAN_RANDOM_SN ]: use random sequence numbers in scans
                * [ SCAN_MIN_PREQ_CONTENT ]: use probe request with only rate IEs in scans
                * [ CAN_REPLACE_PTK0 ]: can safely replace PTK 0 when rekeying
                * [ CONTROL_PORT_NO_PREAUTH ]: disable pre-auth over nl80211 control port support
                * [ DEL_IBSS_STA ]: deletion of IBSS station support
                * [ MULTICAST_REGISTRATIONS ]: mgmt frame registration for multicast
                * [ SCAN_FREQ_KHZ ]: scan on kHz frequency support
                * [ CONTROL_PORT_OVER_NL80211_TX_STATUS ]: tx status for nl80211 control port support
Wiphy phy0
        wiphy index: 0
        max # scan SSIDs: 16
        max scan IEs length: 199 bytes
        max # sched scan SSIDs: 0
        max # match sets: 0
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Device supports AP-side u-APSD.
        Available Antennas: TX 0x7 RX 0x7
        Configured Antennas: TX 0x7 RX 0x7
        Supported interface modes:
                 * managed
                 * AP
                 * AP/VLAN
                 * monitor
                 * mesh point
        Band 2:
                Capabilities: 0x19ef
                        RX LDPC
                        HT20/HT40
                        SM Power Save disabled
                        RX HT20 SGI
                        RX HT40 SGI
                        TX STBC
                        RX STBC 1-stream
                        Max AMSDU length: 7935 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 8 usec (0x06)
                HT TX/RX MCS rate indexes supported: 0-23
                VHT Capabilities (0x339a79fa):
                        Max MPDU length: 11454
                        Supported Channel Width: 160 MHz, 80+80 MHz
                        RX LDPC
                        short GI (80 MHz)
                        short GI (160/80+80 MHz)
                        TX STBC
                        SU Beamformer
                        SU Beamformee
                        MU Beamformer
                        MU Beamformee
                        RX antenna pattern consistency
                        TX antenna pattern consistency
                VHT RX MCS set:
                        1 streams: MCS 0-9
                        2 streams: MCS 0-9
                        3 streams: MCS 0-9
                        4 streams: not supported
                        5 streams: not supported
                        6 streams: not supported
                        7 streams: not supported
                        8 streams: not supported
                VHT RX highest supported: 1560 Mbps
                VHT TX MCS set:
                        1 streams: MCS 0-9
                        2 streams: MCS 0-9
                        3 streams: MCS 0-9
                        4 streams: not supported
                        5 streams: not supported
                        6 streams: not supported
                        7 streams: not supported
                        8 streams: not supported
                VHT TX highest supported: 1560 Mbps
                Frequencies:
                        * 5180 MHz [36] (23.0 dBm)
                        * 5200 MHz [40] (23.0 dBm)
                        * 5220 MHz [44] (23.0 dBm)
                        * 5240 MHz [48] (23.0 dBm)
                        * 5260 MHz [52] (23.0 dBm) (radar detection)
                        * 5280 MHz [56] (23.0 dBm) (radar detection)
                        * 5300 MHz [60] (23.0 dBm) (radar detection)
                        * 5320 MHz [64] (23.0 dBm) (radar detection)
                        * 5500 MHz [100] (disabled)
                        * 5520 MHz [104] (disabled)
                        * 5540 MHz [108] (disabled)
                        * 5560 MHz [112] (disabled)
                        * 5580 MHz [116] (disabled)
                        * 5600 MHz [120] (disabled)
                        * 5620 MHz [124] (disabled)
                        * 5640 MHz [128] (disabled)
                        * 5660 MHz [132] (disabled)
                        * 5680 MHz [136] (disabled)
                        * 5700 MHz [140] (disabled)
                        * 5720 MHz [144] (disabled)
                        * 5745 MHz [149] (30.0 dBm)
                        * 5765 MHz [153] (30.0 dBm)
                        * 5785 MHz [157] (30.0 dBm)
                        * 5805 MHz [161] (30.0 dBm)
                        * 5825 MHz [165] (30.0 dBm)
                        * 5845 MHz [169] (disabled)
                        * 5865 MHz [173] (disabled)
        valid interface combinations:
                 * #{ managed } <= 1, #{ AP, mesh point } <= 16,
                   total <= 16, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz, 80 MHz, 80+80 MHz, 160 MHz }

        HT Capability overrides:
                 * MCS: ff ff ff ff ff ff ff ff ff ff
                 * maximum A-MSDU length
                 * supported channel width
                 * short GI for 40 MHz
                 * max A-MPDU length exponent
                 * min MPDU start spacing
        max # scan plans: 1
        max scan plan interval: -1
        max scan plan iterations: 0
        Maximum associated stations in AP mode: 0
        Supported extended features:
                * [ VHT_IBSS ]: VHT-IBSS
                * [ RRM ]: RRM
                * [ SET_SCAN_DWELL ]: scan dwell setting
                * [ FILS_STA ]: STA FILS (Fast Initial Link Setup)
                * [ CQM_RSSI_LIST ]: multiple CQM_RSSI_THOLD records
                * [ CONTROL_PORT_OVER_NL80211 ]: control port over nl80211
                * [ ACK_SIGNAL_SUPPORT ]: ack signal level support
                * [ TXQS ]: FQ-CoDel-enabled intermediate TXQs
                * [ AIRTIME_FAIRNESS ]: airtime fairness scheduling
                * [ AQL ]: Airtime Queue Limits (AQL)
                * [ ENABLE_FTM_RESPONDER ]: enable FTM (Fine Time Measurement) responder
                * [ STA_TX_PWR ]: TX power control per station
                * [ CONTROL_PORT_NO_PREAUTH ]: disable pre-auth over nl80211 control port support
                * [ SCAN_FREQ_KHZ ]: scan on kHz frequency support
                * [ CONTROL_PORT_OVER_NL80211_TX_STATUS ]: tx status for nl80211 control port support

I chose channel 13 cause is the one with less interferences, but choosing another channel don't change the behavior:

I would use one of the non-overlapping channels = 1, 6, or 11.

Run cat /etc/config/wireless

Redact passwords in the option key sections.

Post in preformatted text.

Then run ubus call system board and post.

In countries which allow channels 1-13, you can actually use channels 1,5,9,13 as non-overlapping channels. TX power limit to 17dBm is probably due to the regulatory compliance. In most countries, total EIRP TX power is limited. So, when two antennas are transmitting simultaneously, the 20dBm output power is reduced to 17dBm (i.e., half) to compensate for that, and total TX power is still at 20dBm.

1 Like

You can, but there is a small amount of overlap using 1-5-9-13.

Additionally, anyone nearby running 1-6-11 can cause adjacent channel interference with 1-5-9-13 APs.

That's true, however OFDM channels mostly in use today are a bit narrower than pre-OFDM, and fit within their 20MHz channel entirely.

2 Likes

Not sure how things are in Venezuela.

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/ahb/18100000.wmac'
        option band '2g'
        option htmode 'HT20'
        option cell_density '0'
        option country 'VE'
        option txpower '27'
        option channel '6'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:00.0'
        option channel '36'
        option band '5g'
        option htmode 'VHT80'
        option country 'VE'
        option cell_density '0'
        option txpower '20'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'
root@OpenWrt:~# ubus call system board
{
        "kernel": "5.10.115",
        "hostname": "OpenWrt",
        "system": "Qualcomm Atheros QCA9558 ver 1 rev 0",
        "model": "D-Link DAP-2680 A1",
        "board_name": "dlink,dap-2680-a1",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "SNAPSHOT",
                "revision": "r19683-9b4169df2d",
                "target": "ath79/generic",
                "description": "OpenWrt SNAPSHOT r19683-9b4169df2d"
        }
}

A part from channels: I know non overlapping channels 1-6-11 are better practice but I don't think that's the solution to the power limit.
A part from country: Venezuela is an old trick I tried, cause with some APs setting Venezuela unlocked more channels and increased power limit. I live in Italy in fact. And for 5GHz radio I tried GB as regulatory domain.
Do you have other requests or suggestions? I hope the driver is not limiting power itself... Cause in this case I would not understand why the max power limit is 27dBm if then the driver will limit to 17dBm. And I would like to be able to choose output power by myself possibly and not by the vill of a driver.

Never said it was...looking at the overall config.

I would try the 21.02.3 stable release, and see if you continue to have the problem.

Let's quote Linux CRDA database:

# Source:
# Official Gazette (Gaceta Oficial) concerning Unlicensed transmitter use
# (10 June 2013)
# http://www.conatel.gob.ve/
country VE: DFS-FCC
	(2402 - 2482 @ 40), (30)
	(5170 - 5250 @ 80), (23), AUTO-BW
	(5250 - 5330 @ 80), (23), DFS, AUTO-BW
	(5735 - 5835 @ 80), (30)

Source: https://git.kernel.org/pub/scm/linux/kernel/git/sforshee/wireless-regdb.git/tree/db.txt

Indeed, it is not the regulatory compliance that shall limit the TX power, Venezuela allows 1W transmit power on entire 2.4GHz band and allows channels 1-13. So the only other option is the calibration data. @alefello, could you dump your ART partition, I.E. the calibration data? Then they can be viewed by means of atheepmgr, I can decode them for you.

I've seen that on Ubiquiti Nanobridge M5, which would artificially limit the power on U-NII 3 band, but only for ETSI regions, which had recently updated their maximum output power limit, so I had to override this to use it with ham-radio application.

2 Likes

You wrote QCA9884 in the title, but you installed the QCA9984 firmware. First of all, what chipset does the device have? If you are sure you have the correct firmware installed, the dBm power may be hardware limited. Choose the country as Panama and again if the power is not increasing then there is nothing you can do.

2 Likes

Holly f.ck !! i didn't know that :rofl: i can push my 2.4ghz wifi from 20dBm to 27dBm now with this country code, my neighbours will be sooo happy now :joy: haha

@anon89577378 in the other thread I wrote cause I had the 5GHz radio missing they suggest me to flash the lastest snapshot :smiley:

@Leo-PL I dumped the ART partition. Here you are: https://we.tl/t-ZY4oAZv5FU

@altuntepe The problem is, in the table of hardware here they say QCA9558+QCA9884 but to have it working I had to install qca9984 firmware and board, and in LUCI it says is a qca9984
1

Now, I think I found a bug. I tried to set the country to Panama on 2,4GHz radio. Saved, applied, reboot, and the power was still limited to 17dBm even if I set 27dBm. Then I noticed in the Luci overview the country was reported as Venezuela. But in the drop down menu and in /etc/config/wireless, country was correctly set as Panama. So I changed the country code of 5GHz radio to Panama too. Saved, applied, rebooted and now the country is correctly reported as Panama everywhere and the tx power went to 27dBm.


(I set it back to 20dBm now, I don't want my wifi is received all the block around :smiley: )

1 Like

Ah, yes. The regulatory domain also has a global setting (see iw reg get) and it is logical for wireless interfaces to have them all set the same. I think the issue is resolved :wink:

1 Like

I was on that thread.

I would flash the 21.02.3 stable release squashfs-sysupgrade image...without keeping settings.

Firmware OpenWrt Upgrade URL:
https://downloads.openwrt.org/releases/21.02.3/targets/ath79/generic/openwrt-21.02.3-ath79-generic-dlink_dap-2680-a1-squashfs-sysupgrade.bin

Your call.

@Leo-PL ok, it make sense, but why let the user change them separately if this is ignored? Better to have it changed even in the other radio section when you change one of the two values, right?

@anon89577378 I switched to 21.02.3 stable last night :ok_hand:

I had some problems configuring VLANS too, I think the new DSA method is a bit confusing and hard-working. Other than that, it seems that different combinations produce the same result, but in fact only one of those I tried was really working. I think I'll post my configuration and detailed explanation somewhere when I'll have time.