QCA955x dts ethernet PHYs? Porting OpenWrt to ASUS RT-AC55U

Hi all. I've been trying to port OpenWRT to this router and I can't wrap my head around ethernet configuration. Here's vendor bootlog https://pastebin.com/3hQ5EG9J
Here's the dts: https://pastebin.com/9auPYq9p
I hope that you guys can point me in the right direction.
Best regards

Still stuck here and can't get ethernet to work

Hello, I ran into a similar problem recently with a completely different device... and it might help?
I installed the mii-tool to try to look for connected PHY's.

mii-tool -vv -p 1 eth0
mii-tool -vv -p 2 eth0
mii-tool -vv -p 63 eth0
mii-tool -vv -p 64 eth0

Then I added the ones (above 4) that appeared into the config file. I added loads of ethernet ports using the same PHY id ... compiled it ... Then ran a program which reads the switch status and looked for any changed that way. For me that was swconfig but I don't know which program you would use?
From that, I knew which ethernet port (id) number used which phy.
Unfortunately I can not help with the dts config, I just looked at all the other dts files - but I would probably remove the fixed-link section.

is there external ethernet switch or no?

may require opening the device to look at the board

FCC ID helps to look at FCC pictures

from vendor bootlog

ag71xx ag71xx.0: eth0: connected to PHY at ag71xx-mdio.0:00 [uid=004dd036, driver=Atheros AR8216/AR8236/AR8316]

switch control interface at mdio address 0

DTS should be something like this (not exactly)

&mdio0 {
        status = "okay";
        phy0: ethernet-phy@0 {
                reg = <0>;
                phy-mode = "rgmii-id";
                qca,ar8327-initvals = <
                        0x04 0x87600000 /* PORT0 PAD MODE CTRL */
                        0x0c 0x00080080 /* PORT6 PAD MODE CTRL */
                        0x10 0x81000080 /* POWER_ON_STRAP */
                        0x50 0xffb7ffb7 /* LED_CTRL0 */
                        0x54 0xffb7ffb7 /* LED_CTRL1 */
                        0x58 0xffb7ffb7 /* LED_CTRL2 */
                        0x5c 0x03ffff00 /* LED_CTRL3 */
                        0x7c 0x0000007e /* PORT0_STATUS */
                        0x94 0x0000007e /* PORT6 STATUS */
&eth0 {
        status = "okay";
        pll-data = <0xa6000000 0x00000101 0x00001616>;
        phy-handle = <&phy0>;
        fixed-link {
                speed = <1000>;
&eth1 {
	status = "okay";

	pll-data = <0x03000101 0x00000101 0x00001616>;

	fixed-link {
		speed = <1000>;

It all works now, except for actually getting internet from the ethernet ports (I can get it using my phone that connects to the router using wifi and internet source thru WAN port)

VLANs need to be setup

the command

swconfig list

shows all switches (it should be just 1 called switch0)

swconfig dev switch0 show

will display the port status for the switch

you need to map out which physical ports are to which internal ports and then put that info in the file