PureFusion - wrt3200acm, wrt32x, wrt1200ac, wrt1900acs, wrt1900acV1, wrt1900acV2 Builds

It's from openwrt one of their commits causes the broken on perpus

1 Like

This one https://github.com/openwrt/openwrt/commit/eaa9c94c75748265b9260691d5f59c9d3711f7d4

Anyone have any luck building firmware now? I still cant get past the fricken kmods now..

no, same problem here

1 Like

Yo - the latest Kabuli Chan builds " borks " my Unbound Stubby GetDns setup. Can you leave the unbound package out of install image please ? I have no issues when I install unbound from online Openwrt snapshot repository. The error l get with preinstalled unbound package reads " segmentation fault ". This same error exists on Kong's builds which also feature preinstalled unbound package. Thanks and Peace

1 Like

@ RaZi3L

I turned on Before_build.sh and added a git reset --hard HASH (which will reset before that one commit)
there are 2 other ways to tackle this issue. can also revert the commit.. but using git actions.. I am not
sure I can revert cleanly without it opening a editor on me........... Have yet to try that..
if it does.. there is way #2, Just clone it locally, then revert it.. then
git format-patch HEAD~
then add that patch to the patch dir in configs..

but either way.. I think its the stupidest merge I have ever seen anyone add to source.
Most people try to avoid errors and so on, Not openwrt.. bent on creating errors.

I understand what they are trying to do, but what I dont understand is this, Finish the full patch of configs before adding that one commit that is bent on ruining everyone's day...........

they kinda went backwords on this merge.

1 Like

Now reply to your comment.. I wish this forums allowed multi reply backs.. anyhow.
Yes.. I will keep that in mind. right now I was just trying to get past the issue we had above.. and testing things out.. Thank you for your feedback.. I will adjust the config accordingly... When I get the time to
do so.. Still but no big deal.. I will see what I can do on that..

btw, Most likely all the prebuilt unbond packages are failing because we devs think
compiling with the latest greatest GCC makes that big of a different. In fact, it only
introduces more problems 90% of the time.............

OpenWRT always compiles with GCC 8.x.x and cant remember what bin utils they use..
but they always go for stable..
just because something compiles doesnt mean it will work as intended.........

I been down this road many times when I was building Nebula Kernel back in the days under my
LG G3, I learned alot that year............

Not to mention I created a whole Android OS from scratch pretty much.. and learned alot about compiling under many diff ways........... even with Clang.. Took me long time to learn to use the clang to compile.. and Wow that made a big Diff............

So yes this is a road I have been down before.. but dont get me wrong.. The devs out there are awesome for OpenWRT buils.. Specially KONG, I know his work well.. one of the top best there is..
and you know hes from the DD-WRT days...........

I do not know if it is worth doing all that right now, I would wait until monday to see if they answer in the thread, it is not normal so many builds with compilation problems ...

my last 3 builds worked perfectly. by doing that I said above.. and it works.. easy as ABC.. not alot..
Just had to turn on the script then add the git revert --no-edit and HASH commit.

now it works.

to be honest, I only tested the git reset --hard HASH commit way..
the git revert --no-edit HASH commit is a new way im testing now.. but should by all means work.

1 Like

I guess it worked:

Run chmod +x scripts/$BEFORE_BUILD
Removing target/linux/generic/hack-5.4/205-kconfig-exit.patch
Removing target/linux/generic/hack-5.10/205-kconfig-exit.patch
[master 3115873767] Revert "generic: Kconfig: exit on unset symbol"
 Date: Fri Aug 13 08:04:39 2021 -0400
 3 files changed, 23 deletions(-)
 delete mode 100644 target/linux/generic/hack-5.10/205-kconfig-exit.patch
 delete mode 100644 target/linux/generic/hack-5.4/205-kconfig-exit.patch
1 Like

@Eliminater74 , I am not seeing any issue compiling from the OpenWrt master, the issue appears to be occurring because whatever it is that is being built in this thread has created an unset Kconfig. I would suggest the better solution would be to just set the Kconfig by adding a file


that sets the Kconfig being complained about.

@directnupe I do not use stubby, but I am seeing no segfauilt with unbound which I do have in play.

1 Like

yeah but I would still need to know what needs to be placed in the config.. I really have no clue, because when build fails.. my logs do not makeup.. I guess I could ssh into the VM and see for my self that way..
I know you build same devices, what do you use?

PS: guess I could run make kernel_menuconfig w/subtarget and run the configs.. then use that as a patch.

As stated, this is not happening for me on master (and I assume no one else, or there would be some voices), from the above I took is to be something to do with:

/home/kc/wrtpac/source/target$ grep -r DEBUG_VIRTUAL
linux/generic/config-5.4:# CONFIG_DEBUG_VIRTUAL is not set
linux/generic/config-5.10:# CONFIG_DEBUG_VIRTUAL is not set

so maybe from the the generic


but I really do not know as I am not encountering said issue.

Dear Eliminater74,
Hello and thanks for the update about the fix for the UNBOUND issue - here is my tutorial DNS Privacy aka DNS OVER TLS - I just installed PureFusion r17328+10 20210813 aka 2021.08.13-1046 Now first - thanks and kudos for getting the factory image down to size where it will flash with no issues due to being oversized. However, the 5GHZ radio does not come up for me at all. This may be due to the fact that I am attempting to connect using my Android devices. I read somewhere in these forum threads that there may be some issues with Android connecting to router. It may be in the DivestedWRT thread. Anyway, this is the first time I ever had this problem occur on any of your builds. I will look forward towards the next build and see if the 5GHZ radio persists. Peace and I am out

Edit :
I am running latest DivestedWRT right now and 5GHZ runs without issue with Android clients - so I do not know what to make of this. However, thanks for your overall great builds and do please keep up the outstanding work on OpenWRT

Yea I seen that.. but dont get it.. you dont get that problem, but I do.. but we build for same device..
I made no changes to kernel.. either did you I assume. Oops, one change I did make.. thats hardening of the kernel... from patches// that might be the issue......

thanks for your input.. I have used your config.buildinfo and created builds from it.
I truly like your setups.. but problem is, anytime I make a single change, The build will fail..
as long as I dont make any changes it builds just fine...

That part I dont get ..

I get it now.. I updated the patches:
now its corrected:

1 Like

Dear Eliminater74,
Hello and I hope that you are well. By way of feedback on latest build PureFusion r17328+10 20210813
aka 2021.08.13-2224 - I know that you added note that this build probably will not work - and you are / were correct. Wireless is missing completely from Luci - please see attached screenshot below :

So - BTW - I am patient - not being critical in any way negative - just reporting back so that you continue on your journey to perfect your builds. Peace and God Bless - I hope the hiccups are fixed soon because I do enjoy running your builds

Wireless is there.. your running into my old problem. you will have to flash under both partitions to fix it.
Remember when I kept complaining about Wireless being gone. I flashed known working builds from 3rd parties and still it wouldnt work.. kept being blank or not showing up at all.

Also take note that the kernel kept staying the same..

Well I flashed a well known 3rd party working image still No go, so I flashed it under the next partition and then it worked and wireless was back.

My earlier builds being so big is what I think started that issue.. anyhow.. If you have no way to access your router through Direct Wired connection in case wireless is missing. Then do not attempt at what I said above till I personally test first.. But if you can still connect then go ahead and test that.. if still a no go, then flash your last known working copy, might have to reboot it a few times after.

But I really think this is a case of the same thing I went through some days ago. and to fix that is to do what I said above.. its the same thing I had to do.

Remember: Do not ATTEMPT unless you have a Direct Wired connection to router so you can reflash if needed........... (Wait till I test my self first then)

Update to above, Also im just working on Building from new .config

I went off @ anomeome
config.buildinfo and Just went from there..

Hope he doesnt mind. But his build I ran to test and fix my wireless issue
was so good.. That I just figure I start pretty much over using his config...

Its not a 100% copy peepz.. I went off his config, but slowly making my own changes to fit my needs.
but the main layout on how he set it up was way beyond what I originally had.

So if things go well, full Credit to @ anomeome for allowing me to use his config as template.

Thanks for the information as to how to get wireless working. Have you put up new build which fixes this issue yet as you indicated you planned to do ? This new build based on anomeome config - do you leave out preinstalled Unbound package ? I will probably wait until this evening before trying new build as I hope that gives you ample time to address any outstanding issues. Peace

yeah, wireless is giving issues.. even when I had wireless working it wouldnt let me log into it.. said my key was wrong when I know for sure it was right. So yea.. I would lay low on the flashing till I can test a working copy..

EDIT: Think I found the issue that screwed up Wireless:

Wireless turned into modules Rather being built in.. along with other sections..
So yep.. found that.. Testing New Build now.. If it builds without error and I can test it.. I will
state my findings here.... But for now.. Dont flash anything from me till I get things stable on that....

1 Like