PureFusion - wrt3200acm, wrt32x, wrt1200ac, wrt1900acs, wrt1900acV1, wrt1900acV2 Builds

my netdata is working just fine.. you must have made some change that caused the GUI configs to not be installed. As for the "luci-app-tn-logview" that surely depends on "syslog_fc" I tried to bring it over..
but as you can see syslog_fc has no Makefile, and its cmake.. I dont know how to create the Makefile for it. if you can find one that would work with it.. then ;let me know.

Also as you can see I did create a Makefile for the "luci-app-tn-logview" ..
Tana Systems Remove all their Makefile's from all their packages.. Kinda messed up I know. but they do it so that others wont copy their stuff. but in all "syslog_fc" needs a Makefile for it to compile..
find one that closely resembles "syslog_fc" then try that..

nad again, Netdata works for me..

ok. The problem with luci-app-netdata is Firefox, the same happens with luci-app-ttyd. When you switch to Chrome / Chromium they work fine. There is some problem with how firefox reads the SSL certificate (SSL_ERROR_RX_RECORD_TOO_LONG).

On the other hand, could you help me to know how to modify your scripts to be able to incorporate this Netdata chart for displaying SQM statistics into the firmware (https://github.com/Fail-Safe/netdata-chart-sqm)? More info here: SQM Reporting? - #121 by _FailSafe

I honestly dont know how to add more charts to netdata as of yet.. I know it can be done.. I just havent done it yet.. but ill look into it.... as I hope you look into it as well.. if you find anything out let me know.. and ill do the same for you..

I know many Dif charts can be added or removed from netdata.

As for Firefox issue. I dont know how to fix that.. I only use chrome and chrome alike.


I have updated the patches section< testing now, Not sure if I got it right or not.
might take a few times. anyhow, I needed a way to create patches for openwrt and packages and luci alike. So I now have patches directory in root of github repo, with openwrt, packages, luci directory's inside patches dir, and you just add the patch to the correct section and it will be applied before building starts. Yes it still needs some fine tuning..

1 Like

There has been some issues with WIFI not working after building latest Snapshot using kernel 5.10, That I can confirm, Have not tested with kernel 5.4 Yet. But I know with testing kernel activate and you build latest snapshot, it will build No errors, But when RAN, wifi is off.. Not working at all.

I am trying to find the commit that caused it, its main openwrt github, and as you can tell On
latest action scripting, I added a get current commit, so that I can trace down what the deal is.

so for I have limited the range down to:

fstools: update to git HEAD …

dangowrt committed 6 days ago
kernel: bump 5.10 to 5.10.54 …

rsalvaterra authored and dangowrt committed 6 days ago
kernel: bump 5.10 to 5.10.53 …

rsalvaterra authored and dangowrt committed 6 days ago
generic: fix build warning …

blocktrron committed 6 days ago
mediatek: mt7623: import patch to fix msi warning …

PolynomialDivision authored and dangowrt committed 6 days ago
bcm53xx: refresh kernel 5.10 config …

But not sure where.. I think its the kernel Bump.

from this I can gather (IM A NOOB) that this is an awesome package with loads of cool features

Is there an image file I can just download for my WRT1900AC V1.

I cannot build or compose as im not clued up on any of it. But I am having issues with performance, and seems like these builds etc have custom drivers etc for wifi.

Anyway, if someone can please let me know if there is just an image I can slap on the router and see if it works well?

Thanks in advance!

hey @Eliminater79

Maybe they have fixed the bug with the wifi, isn't?

This is the r17263 snapshot:

On the other hand, it is easy to install other netdata chars (as https://github.com/Fail-Safe/netdata-chart-sqm).

you have to see if the following packages are installed:


and then add these files to github:


and finally edit https://github.com/ferboiar/wrt32x/blob/linksys/configs/files/etc/netdata/netdata.conf changing "charts.d" to "yes" & compile

1 Like

Sorry, I have a wrt32x and eliminater a wrt3200acm... but even without having too much idea you can follow the steps from here [ PureFusion - wrt3200acm, wrt32x, wrt1200ac, wrt1900acs, wrt1900acV1, wrt1900acV2 Builds ] - #46 by RaZi3L (some paths could have been changed, but you get the idea). You can compile your own firmware adapted to your needs. I advise you to try it, it is easy

Did you have no wifi on earlier builds? cause I found where the error starts
, its when they bumped the kernel to 5.10.33 then .34..

yes I use snapshot kernel, wifi should be fully working on 5.4.x kernel..
just the 5.10.x kernel its not..

I've been using 5.10 since it was in rc phase, never had issues with wireless on any of my wrt devices (1900ac v1, 3200acm and 32x).


Ditto. Currently running 5.10.53 - nary a hiccup.

I found out the Issues, I tried a few things, first, reverted the 2 kernel bumps for 5.10.53 and 5.10.54, and run compile, final build everything working perfect..

Next test, Turned off the patches Only.. and ran build.. Final build.. everything ran perfect..

So problem must have been with the patches.. it didnt like one of them causing WIFI to pretty much be blank.. Going to test kernel 5.10.56 and see if that might fix all.......... fingers cross

This is the Problem I am having:

Only happens when kernel 5.10.33 and above.. 5.10.32 it works perfect.
Never tested the 5.4.x kernel. but this shouldnt be happening..
I have tested other IMAGES as well.. and same problem with the kernel above 5.10.32...

Any idea anyone? Even tried resetting Router. and still same issue.. and its only
with WIFI everything else working perfect.....

What in the world could be causing this?

I own a WRT32x using Kernel 5.10.54 and i don't have any issues with the Wireless side of things both on 5Ghz and 2.4Ghz. Its a personal build however its DSA with CPU Frequency scaling enabled without the issues your having.

I don't know how to help you either. My last compilation with your template is from August 5 and it works as expected. Why don't you try to generate the firmware with my repo and my wrt32x.config file? Just change the hw from menuconfig:

Firmware Version: OpenWrt SNAPSHOT r17263+9-46a65f927c / LuCI Master git-21.216.73469-39cc16d
Kernel Version: 5.10.54

I imagine you have checked the logs...

send me a link and ill check that out//

Problem SOLVED: https://forum.openwrt.org/t/building-snapshot-linksys-wrt3200acm-wifi-not-working/103274/8?u=eliminater74

1 Like

Made a few changes to the GIT ACTIONS SCRIPTING BUILD:

removed the extra buildlog that is truly not needed if your building with logs enabled anyhow..
because it will have the build.log from there.. 2nd.. the extra make debug about Entering Directory and so on when it encounters first error, removed that because you only have 6 hours to build.. after 6 hours it will auto cancel everything and thats that.. leaving that in there doesnt help with debugging.. because no LOGS are ever uploaded for one to see.. If you want to ompile with debugging enabled you need to set it in config of action script.

  FEEDS_CONF: feeds.conf.default
  DIY_P1_SH: diy-part1.sh
  DIY_P2_SH: diy-part2.sh
  BEFORE_BUILD: before_build.sh
  AFTER_BUILD: after_build.sh
  KERNEL_VERSION: kernel_version.sh
  EXT_INIT_ENV: environment.sh
  USE_FILES: true
  USE_DIYP2: true
  ### ------------------------------------------------------------------ ###
  ## Disabling any of these will still build said section,
  ## Just wont be debugable showing. Enabling them will add,
  ## more time to final completion.
  ### ------------------------------------------------------------------ ###
  KMODS: true
  ACL_LUCI: true
  GITLOGA: true
  GITLOGB: true

  TZ: America/New_York

Otherwise just compile normal. and if it fails you can download logs and find out what error then fix it.. and try again..

I removed the !canceled() from the upload BUILD_LOGS section so that it will upload regardless of cancel or not. Not sure its going to work as I expected but anyhow.. Worth a try.

I am also, slimming down the wrt3200acm.config Trying to remove fully not needed stuff.
and add in the missing stuff that is needed.

So there will be changes to the GITHUB Repo.

Also, if you forked it, you will most likely have to delete the FORK and refork it.
Sorry, I forced push a few times to fix some stuff, Only way for you to get my newest changes is to FORK a new copy...

1 Like

I think you already know, but it seems to me that something has broken when building the kmods:

Error in reading or end of file.

make[6]: *** [scripts/kconfig/Makefile:71: syncconfig] Error 1
make[5]: *** [Makefile:603: syncconfig] Error 2
make[4]: *** [Makefile:712: include/config/auto.conf.cmd] Error 2
make[4]: Leaving directory '/workdir/openwrt/build_dir/target-arm_cortex-a9+vfpv3-d16_musl_eabi/linux-mvebu_cortexa9/linux-5.10.56'
make[3]: *** [Makefile:20: /workdir/openwrt/build_dir/target-arm_cortex-a9+vfpv3-d16_musl_eabi/linux-mvebu_cortexa9/linux-5.10.56/.modules] Error 2
make[3]: Leaving directory '/workdir/openwrt/target/linux/mvebu'
make[2]: *** [Makefile:11: compile] Error 2
make[2]: Leaving directory '/workdir/openwrt/target/linux'
time: target/linux/compile#25.38#8.34#30.09
ERROR: target/linux failed to build.
make[1]: *** [target/Makefile:25: target/linux/compile] Error 1
make[1]: Leaving directory '/workdir/openwrt'
make: *** [/workdir/openwrt/include/toplevel.mk:230: target/compile] Error 2
Error: Process completed with exit code 2.