PureFusion - wrt3200acm, wrt32x, wrt1200ac, wrt1900acs, wrt1900acV1, wrt1900acV2 Builds

is there build.log now? I don't see it in the compressed log file that is generated in the "Artifacts" section within "Actions": https://github.com/ferboiar/wrt32x/suites/3506760998/artifacts/83656959

but now, without the build.log file, where can we check that everything has gone well?

I see that the firmware has been compiled finally, but since you say that now the steps are completed, although there are errors, I am not sure where to check that everything has gone well.

you will know if its failed trust me...... ands you can see it under compile if so...

but you will see a RED build when you click on the green build if its failed....
I have already tested this.. so yes you will know when its failed......
just click on the build and see if anything is red and look below for errors and missguides.. then you will

1 Like


I now have Discord channel hooked up,

PureFusion-WRT OpenWRT

Anyone is welcome to stop by...........
I just now opened it, so dont expect to much.......... I am still on Telegram as well.

Hi all, is it normal that if I build the snapshots version for wrt1200 the size of the factory image file is 56 mb? they seem a little too many large

Dont use the current configs for any device other then the wrt3200acm .config..
just make menuconfig under the wrt3200acm.config and change it to your device and save it as that device.. for example:

save it as wrt1200ac.config

The other configs are old and outdated.. Have not updated them yet.

Watch the video below link with the test!
These performances are are only touched with Packet Steering +Software flow offloading enable!

This project is still very much alive. but we hang mainly on Discord, and since the project is well working, except for some minor things. Its not as updated as once was during the early stages.

you can self build for any of the Linksys wrt devices as you wish, or use the pre built wrt3200acm that I build from time 2 time for my own self. and if you need other devices, there are a few people in
my Discord channel that build for other devices and or same devices as I do.


1 Like

Builds for all devices listed are built daily by cron job. they are listed in releases on my
github listed in OP first page. look for TAG of your device to download..

They are AUTO BUILT everyday....


Multicpu port is found in your compilations?
On SNAPSHOT (r18474-87b6e10c71) on wrt1900acs v2 i can't get past 890mbps on the wire side!

Hi mate, I am really struggling to get transmission showing the web page. I have installed all the packages and i am using wrt32x-2022.01.08-1046

I cant find your discord to join but please can you help me get transmission working?

Transmission underlying crypto libraries are the actual culprit here. I've already opened an issue in the openwrt/packages github.


PS. If the web page is not showing at all, did you edit it's config file (/etc/config/transmission) and set enable to '1'?

I will try, and let you know

Full Builds for:

[*] Linksys Caiman (Linksys WRT1200AC)
[*] Linksys Cobra (Linksys WRT1900AC v2)
[*] Linksys Mamba (Linksys WRT1900AC v1)
[*] Linksys Rango (Linksys WRT3200ACM)
[*] Linksys Shelby (Linksys WRT1900ACS v1)  
[*] Linksys Venom (Linksys WRT32X)
[*] Linksys WRT1200AC
[*] Linksys WRT1900AC v1 
[*] Linksys WRT1900AC v2
[*] Linksys WRT1900ACS v1
[*] Linksys WRT1900ACS v2 (Linksys WRT1900ACS v1)
[*] Linksys WRT3200ACM
[*] Linksys WRT32X

Available here: Action_OpenWRT_AutoBuild_Linksys_Devices/releases

Testing Builds are here: Action_OpenWRT_AutoBuild_Linksys_Devices-TEST/releases

Fully Updated each and every day using latest Snapshot Code.

Linksys Devices only:

1 Like

Dear Eliminater,
Hello and I hope that you are both safe and well.
I have been using your builds from day one - you may remember me from the earliest days of your project. I have a question for you -

When will you upgrade to Firewall 4 ?
And if not in the very near future - may I ask why you are holding back as this seems to where OpenWRT is headed ?

Thanks and keep up the good work


Honestly I never looked into that yet. I been so busy with re-writing my action scripts and making things better and easier and more options, that I havent even kept up with all that. I will look into it.
I did try Kernel 5.15, but lost INET after 5 mins, I havent tried since.. going to try again soon.

but as for Firewall 4, I will look into that. I am not sure how much crap I need to go through to change it over.. but I will look into it.. you do know you can talk direct with me and others on Discord as well.
your welcome to join in on our development convo..

Dear Eliminater74,
Yes - to make things easier for you regarding FireWall4 - may I suggest that you look at Tad SkewedZeppelin's work - better known as Divested-WRT: No-nonsense hardened builds for Linksys WRT series

Here the config file for his latest build below ;

Divested-WRT Configuration

Just a suggestion is all

Tad is always up to date - and even has a video which will guide you along for your own builds


1 Like

Problem with ash on last three test builds for FireWall4 - see below

-ash: /etc/profile.d/sysinfo.sh: line 41: syntax error: unexpected "(" (expecting "}")

this error occurs when logging into shell - also stops connection via WINSCP

Hope the error is a simple fix - I installed BASH - was able to get into WINSCP - but the file system was borked after that - all files reverted to original installation status


I know because I tried to edit the line myself; however, I was unsuccessful at getting the annoying message to cease. In any event, you are on the correct line - the bad ips - from there I would imagine that the error message is telling you what is wrong.

Somewhere there is a. - (
And there is needed a. - }

It is a matter of formatting - From Your Latest FireWall4 Test Build
PureFusion r19605+9 2022-05-07 2022.05.07-1135
Seeing is Believing - I at least hope so


This occurred on a fresh install of the factory image - hopefully you will fix it
BTW - there is no /etc/profile.d/sysinfo.sh file in DivestWRT

Did anyone manage to get samba working on a recent build? I'm failing miserably.
Used both default settings and tried the samba configuration instructions from @openwrt.
Both Ubuntu and Win11 PC failed to connect.

did samba work on older builds? a few things have broken recentlly on recent builds, in the process of fixing them now.