PureFusion - wrt3200acm, wrt32x, wrt1200ac, wrt1900acs, wrt1900acV1, wrt1900acV2 Builds

OK - got you - I hope that all goes well also. Peace My Man

Ok here is the problem, Yes, wireless worked.. But, Had issues with it letting me connect.
for some reason it kept asking for my key.. well I have used the same damm key for years.. but for some reason it wont work and keeps asking me for key..
can you plz try and verify.. DO NOT FLASH ON BOTH partitions.. Just one or the other.
keep a fully working one intact..

Would you have any idea why the above problem is happening..
Wireless is working, but keeps telling me my key is wrong when I try and connect.....
Can you give me a bit info on where to look for the issue..

What .config are you using? my latest problem is, wifi not letting me connect. says my key is wrong. when in fact its right/

Added new error control to my Action Script that will allow uploading of LOGS prior to
killing server now.....

So if you see GREEN which normally means build went without a hitch.. DO NOT ASSUME it
worked fully.. gota click on it and see if build failed or not:

I added this:

- name: Compile the firmware
      id: compile
      continue-on-error: true
      if: env.DEBUG_COMPILE == 'false' && env.IGNORE_COMPILE == 'false'
      run: |
        cd openwrt
        echo -e "$(nproc) thread compile"
        let Make_Process=$(nproc)+2
        make -j${Make_Process} || make -j${Make_Process} V=s
        echo $?
        echo "::set-output name=status::success"
        grep '^CONFIG_TARGET.*DEVICE.*=y' .config | sed -r 's/.*DEVICE_(.*)=y/\1/' > DEVICE_NAME
        [ -s DEVICE_NAME ] && echo "DEVICE_NAME=_$(cat DEVICE_NAME)" >> $GITHUB_ENV
        echo "FILE_DATE=_$(date +"%Y%m%d%H%M")" >> $GITHUB_ENV

    - name: If Error
      uses: actions/upload-artifact@main
      if: steps.compile.outcome == 'failure' && env.UPLOAD_BUILD_LOGS == 'true'
        name: OpenWrt_logs${{ env.DEVICE_NAME }}${{ env.FILE_DATE }}
        path: openwrt/logs/

so when you get a failed build it will not cancel rest of the steps. it will continue to error
control step, then gather and upload all the LOGS.. so you can now debug your issues better..
Also you will notice this:

make -j${Make_Process} || make -j${Make_Process} V=s
        echo $?

That will spit much more debugging info out as well. So you might not even have to download the logs.. I wanted to find a way to debug my builds without causing slow downs and so on..
This so far is by far the best way I can come up with.

Remember: My main goal is create a GITHUB Action Script that will build anyones personal perfect
OpenWRT Firmware without having to know any coding. and without having a Linux Computer..

Yes I build Images.. but thats just the bonus for working on this Script.. Plus need the images tested
to know if the script is working....

So plz understand. I am just trying to make it easier for anyone, and I mean anyone to build their own firmware without having much knowledge on it.. Yes, you need basic knowledge.. but if your flashing
custom firmware or any firmware, then you already have the basic knowledge.

The possibilities are limitless..

1 Like

so the problem always was the patches?

my configuration file started with yours but right now it's a personal adaptation of the "divested" one

In any case I have already solved my problem by removing radio2 from my build (removing the kmod-mwifiex-sdio, mwifiex-sdio-firmware, kmod-bluetooth, kmod-btmrvl, kmod-mmc packages) ... It's a frequently discussed issue on the forum:

On the other hand, today i had redone my .config file, but I have seen two little problems

First with diy-part1.sh:

Username for 'https://github.com': ******@*****.com
Password for 'https://******@*****.com@github.com': 
remote: Support for password authentication was removed on August 13, 2021. Please use a personal access token instead.
remote: Please see https://github.blog/2020-12-15-token-authentication-requirements-for-git-operations/ for more information.
fatal: unable to access 'https://github.com/lsydy1021/luci-app-sfe.git/': The requested URL returned error: 403

How I have to set my personal token to login properly and access that repo?

Last with sirpdboy-package.sh
svn: E175002: Unexpected HTTP status 504 'Gateway Timeout' on '/sirpdboy/sirpdboy-package/trunk/luci-app-poweroffdevice'

I think is not very important, but idk if you know it

is there build.log now? I don't see it in the compressed log file that is generated in the "Artifacts" section within "Actions": https://github.com/ferboiar/wrt32x/suites/3506760998/artifacts/83656959

but now, without the build.log file, where can we check that everything has gone well?

I see that the firmware has been compiled finally, but since you say that now the steps are completed, although there are errors, I am not sure where to check that everything has gone well.

you will know if its failed trust me...... ands you can see it under compile if so...

but you will see a RED build when you click on the green build if its failed....
I have already tested this.. so yes you will know when its failed......
just click on the build and see if anything is red and look below for errors and missguides.. then you will

1 Like


I now have Discord channel hooked up,

PureFusion-WRT OpenWRT

Anyone is welcome to stop by...........
I just now opened it, so dont expect to much.......... I am still on Telegram as well.

Hi all, is it normal that if I build the snapshots version for wrt1200 the size of the factory image file is 56 mb? they seem a little too many large

Dont use the current configs for any device other then the wrt3200acm .config..
just make menuconfig under the wrt3200acm.config and change it to your device and save it as that device.. for example:

save it as wrt1200ac.config

The other configs are old and outdated.. Have not updated them yet.

Watch the video below link with the test!
These performances are are only touched with Packet Steering +Software flow offloading enable!

This project is still very much alive. but we hang mainly on Discord, and since the project is well working, except for some minor things. Its not as updated as once was during the early stages.

you can self build for any of the Linksys wrt devices as you wish, or use the pre built wrt3200acm that I build from time 2 time for my own self. and if you need other devices, there are a few people in
my Discord channel that build for other devices and or same devices as I do.


1 Like

Builds for all devices listed are built daily by cron job. they are listed in releases on my
github listed in OP first page. look for TAG of your device to download..

They are AUTO BUILT everyday....


Multicpu port is found in your compilations?
On SNAPSHOT (r18474-87b6e10c71) on wrt1900acs v2 i can't get past 890mbps on the wire side!

Hi mate, I am really struggling to get transmission showing the web page. I have installed all the packages and i am using wrt32x-2022.01.08-1046

I cant find your discord to join but please can you help me get transmission working?

Transmission underlying crypto libraries are the actual culprit here. I've already opened an issue in the openwrt/packages github.


PS. If the web page is not showing at all, did you edit it's config file (/etc/config/transmission) and set enable to '1'?

I will try, and let you know

Full Builds for:

[*] Linksys Caiman (Linksys WRT1200AC)
[*] Linksys Cobra (Linksys WRT1900AC v2)
[*] Linksys Mamba (Linksys WRT1900AC v1)
[*] Linksys Rango (Linksys WRT3200ACM)
[*] Linksys Shelby (Linksys WRT1900ACS v1)  
[*] Linksys Venom (Linksys WRT32X)
[*] Linksys WRT1200AC
[*] Linksys WRT1900AC v1 
[*] Linksys WRT1900AC v2
[*] Linksys WRT1900ACS v1
[*] Linksys WRT1900ACS v2 (Linksys WRT1900ACS v1)
[*] Linksys WRT3200ACM
[*] Linksys WRT32X

Available here: Action_OpenWRT_AutoBuild_Linksys_Devices/releases

Testing Builds are here: Action_OpenWRT_AutoBuild_Linksys_Devices-TEST/releases

Fully Updated each and every day using latest Snapshot Code.

Linksys Devices only:

1 Like

Dear Eliminater,
Hello and I hope that you are both safe and well.
I have been using your builds from day one - you may remember me from the earliest days of your project. I have a question for you -

When will you upgrade to Firewall 4 ?
And if not in the very near future - may I ask why you are holding back as this seems to where OpenWRT is headed ?

Thanks and keep up the good work