Purchased device with OWRT, minimal experience and can't get it to function

Hi all, I bought an Allnet ALL0258N from ebay and it has OpenWRT installed. This is a great project, but I really just want a simple solution. I can run basic terminal commands but I'm not an expert with this kind of work, I've spent way too much time trying to get it to function (it no longer shuts down my gateway's internet connection so that's nice) and now I can't even connect to it. I tried the failsafe mode since I guess the regular reset doesn't work but still can't connect. I'm confident I'm just doing something really basic wrong so sorry for the newb question. Thanks so much for your help.

The default IP configuration for OpenWRT is with DHCP server enabled,
so if your computer is connected to the internet over WiFi and you plug in the ethernet cable to the OpenWRT device at the same time, you might lose connection to the internet, as your computer tries to use ALL0258N (which is not yet connected to the internet).

If you can still connect to ALL0258N, could you post the output of uci show network?
Can you remember which settings you changed? Maybe you have to set IP address manually on the computer.

Thanks for the reply! I have tried every combination of DHCP and several manual IPs over both LAN and WLAN. I'm worried it's in a different mode because I ran failsafe mode reset and all the lights came on and stayed on, which didn't happen in normal mode. I'm not sure what uci is, sorry. Terminal didn't recognize the command, so I'm guessing it's something I need to install from OWRT?

I should sáy I can connect to the allnet itself with standard static IP but no response from or anything.

Have you tried pressing the reset button for 10 seconds while switching the device on?
According the manual, It should provide some recovery interface on where you can reset configuration (which would only apply to the vendor firmware) and maybe also upload a new firmware image, either from Allnet or OpenWRT.

I have tried that reset based on the manual. Unfortunately there is no vendor firmware, only OpenWRT, which is my basic problem haha. Thanks for the recommendation though.

Usually OpenWRT will not overwrite the vendor's bootloader for most devices, so you could always flash it back to either vendor firmware or a fresh OpenWRT, after holding the reset button while power is connected.

I don't know about this particular Allnet device though, the wiki doesn't say anything regarding Flash Layout or anything, the Allnet Website has no firmware images for download. OpenWRT Failsafe Mode should also listen on, but not remain active after power is disconnected.

If there is really no vendor recovery here, you may have to use the serial console, which would involve opening the case, which is probably not the best idea with waterproof outdoor devices.

Sorry, I can still not understand what you are connected to and how. Which is the standard ip address, what do you see from Allnet 258, console, Web UI, ..?

https://openwrt.org/toh/hwdata/allnet/allnet_all0258n -- clearly identifies it as not suitable for future use. With a 350 MHz MIPS core, only an old 2.4 GHz wireless chip, and a single, 100 Mbps Ethernet port, it's barely even functional, if it had a viable version of OpenWrt on it.

It wouldn't surprise me if the version of OpenWrt loaded on the device was outdated, or just non-functional.

That the device isn't accessible in the ways that OpenWrt provides suggests to me that the device itself is non-functional, or that the build of OpenWrt installed is non-functional.

I would return the device to the seller at the seller's expense. If the seller is not cooperative, there is the eBay buyer's protection as recourse.

So initially I did have access, was able to connect and change settings no problem, then I updated a setting and now cannot connect whatsoever. It seems generally to be functional and we have an ALL0358 that works well with no problems and the original firmware. We aren't super high internet users and just need it for a basic connection, high speeds aren't such a concern.

By standard IP I mean the default When connected over lan it displays a connected IP of 192.168.1.X, but I see nothing from the 258 through browser etc.

Generally when OpenWrt boots up, one of the LEDs will flash fast, then slow, and finally stay on steady. If it does that you can be fairly sure it is running OpenWrt. If it does the next thing to try is to boot again and wait exactly until it starts flashing fast, then hit the reset button (press and release) several times, which should enter failsafe mode. If you were successful at activating failsafe mode, the LED should start flashing even faster and keep doing that indefinitely instead of changing to flashing slow.

The wiki says this device may be a re-badged Engenius. Engenius stock firmware and bootloaders are weird.

Thanks for the reply! It's definitely running owrt, as previously I was able to run the program through the browser and it clearly was. However, I tried the reboot just now and it did not have the led blink pattern you mentioned. No idea what that means. When I initialize failsafe mode in the way it's described to do so, three colored leds blink quickly for a second and then all remain on without blinking. Thanks for the help.

Hi I think that this device has a verry old build of OpenWrt. You should send it back to the seller. You don't have enough ram or flash to run a newer build of openwrt and running such a old build of openwrt is not safe as you mite get hacked. With sutch a slow CPU I would be surprised if it can do wifi for more than 2 things at one time. It's not werth wasting your time on.


hey tapper, I think you're right. We picked it up for €1 and were hoping to use it as at least a receiver for a bridge but sometimes it's just not going to work. Thanks for the advice!

sorry but this sounds like a bullshit. 350MHz is not that slow

1 Like

An archer C7 can route about 200Mbps without hardware offloading (in my experience), it's running a 720 Mhz core. So you might expect a 350Mhz core to route say 100Mbps, maybe, if the core is similarly efficient.

It's a 24kc core vs 74kc so it's quite a bit slower unfortunately...

untrue. check coremark results for 24kc vs 74kc https://github.com/juppin/coremark/tree/master/results

I'm not sure what you're trying to prove?

This particular benchmark shows at least ~15% slower performance which is quite a bit given that these SoCs aren't particulary fast to begin with...

AR9341 (Wasp), n/a, MIPS 74Kc, 533 MHz https://github.com/juppin/coremark/blob/master/results/ar9341_tl-wr841v8

1203 i/s

QCA9531 (Honey Bee) MIPS 24Kc 550 MHz (link: Overclocking Router Devices)

2K performance run parameters for coremark.
CoreMark Size : 666
Total ticks : 15859
Total time (secs): 15.859000
Iterations/Sec : 1261.113563
Iterations : 20000
Compiler version : GCC5.4.0
Compiler flags : -O2 -s -static -lrt
Memory location : Please put data memory location here
(e.g. code in flash, data on heap etc)
seedcrc : 0xe9f5
[0]crclist : 0xe714
[0]crcmatrix : 0x1fd7
[0]crcstate : 0x8e3a
[0]crcfinal : 0x382f
Correct operation validated. See readme.txt for run and reporting rules.
CoreMark 1.0 : 1261.113563 / GCC5.4.0 -O2 -s -static -lrt / Heap

1 Like