ProtonVPN is connected but need help with Firewall please

Hi all,
I installed Openvpn and followed the official guide, the VPN connected but my location and IP address still public and as I understand I must allow something in the firewall, I tried to do many settings but could't make it work, hope someone can help me.

They Say

5.1-b With OpenWRT 19.07 (alternative to the above step 5.1-a)

Click on Network in the top bar and then on Firewall to open the firewall configuration page.

Click on the Edit button of the wan (red) zone in the Zones list at the bottom of the page.

Click on the Advanced Settings tab and select the tunX interface (tun0 in the screenshot, which is the most likely if you have a single OpenVPN client/server running)

But I don't have tunX.
Best Regards

If you don't see the VPN device, then the connection is most likely down.
Check the logs to determine the cause.

1 Like

fwiw, study the alternative tutorial/guide linked at the bottom of the wiki page. Definitely worked with ProtonVPN last time I tried it

1 Like

Don't know anything about that provider but in general to resolve DNS leaks you need to use the VPN servers provided by the VPN host.

I am using ProtonVPN without any issues.
Make sure there is an enabled entry in OpenVPN: uci export openvpn
Start OpenVPN: service openvpn enable; service openvpn restart
Verify that you have the interface up: ip -4 addr

1 Like