Protocol 6to4 does not show up in LuCI

Hello, I'm trying to make me a 6to4 tunnel.

I have installed packages 6to4 and luci-proto-ipv6. However, in LuCI's drop-down for interface protocols, I only see the usual DHCP, DHCPv6, Unmanaged and Static.

If I put 6to4 into /etc/config/network manually*, LuCI complains about an unknown protocol. (The guide is probably outdated since the next step is installing radvd which doesn't exist either in 19.07,)

What else do I need?

I'm not sure I've had to do this...but have you tried rebooting?

1 Like

Why do you want to use 6to4 anyway? The anycast relay address is deprecated. And without that I guess 6to4 is only useful between ipv4 hosts, or in controlled environments.

I assume you have native IPv6 if this question came to mind. A lot of ISPs do not yet offer it in some countries.


Actually I don't have native IPv6 at home. I use 6in4 tunnels from Hurricane Electric.

There are similarities between 6to4 and (plain) 6in4, they use the same protocol number (41) and the payloads also both contains IPv6 packets. But 6to4 used an anycast prefix as default gateway to reach IPv6. With 6in4 you need an agreement with a 6in4 tunnel service such as Hurricane Electric.

Due to unsolvable operational problems using the 6to4 anycast prefix, that part of the standard was deprecated in 2015.

Without the anycast prefix 6to4 isn't very useful.

As do I...and I wasn't aware that the LuCI app handled the other...

Perhaps the OP should clarify if they meant to install 6in4.

To answer the actual original question - a reboot or a network restart (not reload) is required for netifd to pick up newly installed protocols (which are then queried by LuCI)

1 Like

Thanks, that fixed it. Meanwhile my question has become doubly redundant because I found I'm behind CGNAT where 6to4 doesn't help, and the server which only reported an IPv6 address last week now has an IPv4.

Even simpler solution: Turn on IPv6 for the VPN tunnel...

P.S. I tend to avoid rebooting; it's been a long time since I found it unavoidable to solve a Linux issue.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.