Proper steps to disable vlans for brlan & wan?

I'm pulling my hair out here. I've tryed simply untagging and disabling vlan functionality, then reassigning to the actual device e.g. eth1.2 > eth1 ;
eth0.1 > eth0
No dice. Suggestions?
I've defaulted to default to start fresh.

root@OpenWrt:~# uname -romi
4.14.131 armv7l unknown GNU/Linux
root@OpenWrt:~# cat /etc/banner
  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 18.06.4, r7808-ef686b7292
 -----------------------------------------------------
Linux OpenWrt 4.14.131 #0 SMP Thu Jun 27 12:18:52 2019 armv7l GNU/Linux

root@OpenWrt:~# cat /etc/config/network 

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd80:7423:a760::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth1.2'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth1.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'


What do you gain by not using vlan tags internally?

I doubt you can completely disable the internal vlan switch but I guess you should be able to change the cpu ports to untagged by changing 5t to 5u and 6t to 6u, and use eth0 and eth1 without vlan.

https://openwrt.org/docs/guide-user/network/vlan/switch

1 Like

What are you trying to do here? You can't have two networks running through the same switch chip without using VLANs.

According to this Tech Data the switch and wan port are truly independent devices. The layout is traversed for my actual setup ootb for whatever reason. Maybe the diagram is wrong? I do understand the use of a "general-due-no-harm" setup for openwrt, but this is not necessary for this unit. The main idea behind it is many packages such as ethool, don't recognize virtual devices to ascertain direct changes or stats.

There is one switch chip with 7 ports. Five of them are the Ethernet ports on the case and two are connected to the CPU as eth0 and eth1. It is necessary to set up VLANs in the switch to independently switch one CPU port to the "WAN" ethernet and the other one to the four "LAN"s.

You could make ports 5 and 6 untagged on their respective VLANs then use untagged eth1 and eth0 going into the switch. There would still be two VLANs in the switch, but invisible to users.

It is more flexible though to leave at least one of the CPU ports tagged because then you can add more VLANs just by adding an additional tag.

7 ports???

Five Ethernet and two CPU. Numbered 0 through 6.

Are you referencing the same layout for the wrt3200acm? I see:
internet port 4
lan ports 0,1,2,3

Right, and also
connection to CPU eth1: port 5
connection to CPU eth0: port 6

The switch is a separate chip in the router with wires to the CPU chip. These switch ports work logically just like Ethernet ports though the type of wiring is different.

1 Like

Thanks for sorting that out.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.