Promox: OpenWrt does not see internal wifi card

Hi,

The problem I have is: as I decided to buy a wifi card (Intel 8265) and then use under a VM on Proxmox. However, openWRT is not able to see it. To check if it is a Proxmox problem, I created another VM and installed Linux and I could connect using Wifi.

Any help would be appeciated,

Eduardo

there's a package called iwlwifi-firmware-iwl8265, did you install it ?
other modules will be required too, like kmod-wlwifi.

1 Like

Be aware that passing through PCIe devices through to the VM isn't default and relatively error prone, also no Intel wireless card will do AP mode (2.4 GHz only, if you're lucky).

1 Like

Hi guys,

So I followed @frollic suggestion and installed both packages and then worked. However, I stumbled with other problems:

  1. My PC has just no ethernet port, therefore it needs to be the wan port. However, if I try to make this change, I can't connect to openWrt using Luci anymore or even ssh. I need to go to Proxmox console and re-edit the file again.

  2. Probably this problem is due to my lack of knowledge of networks, but the goal is to create a subnet and make the computers connected to it to use some sort of VPN. The final layout would be:
    Internet -> Router (10.10.1.1) -> OpenWrt (10.10.2.1), but there was no way for me make the subnet visible to other computers. Is it related with @slh said about no ap mode for Intel cards?

Thanks guys

most probably, yes, did you try 2.4GHz too ?

@frolic
I only tried with 2.4GHz. Funnily, I am able to run RaspAP using the same card. Here are some config file that I think it may be useful

hostapd.conf

driver=nl80211
ctrl_interface=/var/run/hostapd
ctrl_interface_group=0
auth_algs=1
wpa_key_mgmt=WPA-PSK
beacon_int=100
ssid=RaspAP
channel=1
hw_mode=g
ieee80211n=1
wmm_enabled=1
wpa_passphrase=xxxxx
interface=wlan0
wpa=2
wpa_pairwise=CCMP
country_code=AU
ignore_broadcast_ssid=0

/etc/dnsmasq.d/090_wlan0.conf

interface=wlan0
dhcp-range=192.168.2.100,192.168.2.254,255.255.255.0,12h
dhcp-host=xx:xx:xx:xx:xx:xx,192.168.2.100 # WinPC
dhcp-option=6,192.168.1.240

/sys/class/net

Current settings
eth0
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 2a:e4:28:c0:eb:2e brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.254/24 brd 192.168.1.255 scope global noprefixroute eth0
       valid_lft forever preferred_lft forever
    inet6 2405:6e00:e6c:e901:8090:3b85:518a:7bb2/64 scope global dynamic mngtmpaddr noprefixroute
       valid_lft 298sec preferred_lft 118sec
    inet6 fe80::7c65:7b9f:afe0:4d2d/64 scope link
       valid_lft forever preferred_lft forever
wlan0
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether e8:f4:08:b5:8a:5b brd ff:ff:ff:ff:ff:ff
    inet 192.168.2.1/24 brd 192.168.2.255 scope global noprefixroute wlan0
       valid_lft forever preferred_lft forever
    inet6 fe80::b5e4:526e:dece:bfc9/64 scope link
       valid_lft forever preferred_lft forever

Hope this can shed some light.

Thanks,

Eduardo

Does RaspAP use the same kernel version as openwrt ?

run iw list in openwrt, is AP one of the supported interface modes.

I may have overdone it, but here it goes:

   Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * AP/VLAN
                 * monitor
                 * P2P-client
                 * P2P-GO
                 * P2P-device

If this helps:

Linux OpenWrt 5.4.154 #0 SMP Sun Oct 24 09:01:35 2021 x86_64 GNU/Linux

and

Linux RaspAp 4.19.0-18-amd64 #1 SMP Debian 4.19.208-1 (2021-09-29) x86_64 GNU/Linux

AP is supported, so it should work....

but then again, it might be as @slh said, a VM issue.

So I finally made it work.

Here are my config files for those who may have the same issues:

/etc/config/dhcp
config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option ignore '0'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'
/etc/config/network
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd5c:f24b:5cf9::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.4.1'
        option ip6assign '60'
        option device 'wlan0'
        list dns '1.1.1.1'

config interface 'wan'
        option device 'eth0'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.253'
        option gateway '192.168.1.1'
        list dns '1.1.1.1'
/etc/config/wireless
config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:10.0'
        option cell_density '0'
        option country 'AU'
        option hwmode '11g'
        option htmode 'HT20'
        option channel '11'

config wifi-iface 'default_radio'
        option device 'radio0'
        option ssid 'your_ssid'
        option encryption 'psk2'
        option key 'your_password'
        option network 'lan'
        option mode 'ap'
1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.