Problems with wifi when upload starts, on several routers

Hi there, I’m facing a problem,

I have three routers: Xiaomi MiRouter 3G (OpenWrt 19.07),
TP-Link TLWR-850N v1 (OpenWrt 21.02, 19.07, 18.07),
and TP-Link MR3020 (OpenWrt 19.07.7), with identical problems.

And two smartphones, both is Xiaomi Redmi 4X.

When smartphones are connected to the openwrt-router and active uploading starts on max. speed (~50mbit/s, if limit upload speed at ~20-30 Mbit/s all is ok), the Internet on the smartphones disappears until manual wifi network reconnection. The router doesn't respond to ping from the smartphone, the smartphone doesn't respond to ping from the router, but still connected to wifi. At the same moment, a nearby laptop is connected to the same wifi and does not experience any problems, even with active download / upload.
These smartphones works fine with other stock routers. An ASUS laptop connected to openwrt routers works fine too.

The problem is exactly in this openwrt routers - xiaomi smartphones combination, but also i have TLWR-840N v2 (OpenWrt 18.07) - it works fine.
What is it? How to find the cause?
Thanks for answer, and sorry for my english skills.

Are you using all of these routers in your network at the same time, or is only one of them being used?

If all three are being used, how are they connected to each other?

No, routers are in different places, in different networks

ok... so it is probably related to your configuration. If all three routers are showing the same behavior but are in different locations/networks, let's just look at one of them.

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

As example, reflashed 850N router now, to OpenWrt 21.02.1, r16325-88151b8303.
Default configuration, excepting wifi ssid/pass and pppoe connection.
The problem still exists.

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'ffff:ffff:ffff::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'eth0.2'
        option macaddr 'ff:ff:f4:ff:ff:ff'

config interface 'wan'
        option device 'eth0.2'
        option proto 'pppoe'
        option username 'pppoe_username'
        option password 'pasww13213'

config interface 'wan6'
        option device 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 6t'
root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/10300000.wmac'
        option htmode 'HT20'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'test2'
        option encryption 'psk2'
        option key '012345678'
root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'
root@OpenWrt:~# cat /etc/config/firewall
config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option src_ip           fc00::/6
        option dest_ip          fc00::/6
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           fe80::/10
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-IPSec-ESP
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT

config rule
        option name             Allow-ISAKMP
        option src              wan
        option dest             lan
        option dest_port        500
        option proto            udp
        option target           ACCEPT

# allow interoperability with traceroute classic
# note that traceroute uses a fixed port range, and depends on getting
# back ICMP Unreachables.  if we're operating in DROP mode, it won't
# work so we explicitly REJECT packets on these ports.
config rule
        option name             Support-UDP-Traceroute
        option src              wan
        option dest_port        33434:33689
        option proto            udp
        option family           ipv4
        option target           REJECT
        option enabled          false

# include a file with users custom iptables rules
config include
        option path /etc/firewall.user


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option dest             wan
#       option proto    tcp
#       option target   REJECT

# block a specific mac on wan
#config rule
#       option dest             wan
#       option src_mac  00:11:22:33:44:66
#       option target   REJECT

# block incoming ICMP traffic on a zone
#config rule
#       option src              lan
#       option proto    ICMP
#       option target   DROP

# port redirect port coming in on wan to lan
#config redirect
#       option src                      wan
#       option src_dport        80
#       option dest                     lan
#       option dest_ip          192.168.16.235
#       option dest_port        80
#       option proto            tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#       option src              wan
#       option src_dport        22001
#       option dest             lan
#       option dest_port        22
#       option proto            tcp

### FULL CONFIG SECTIONS
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port 80
#       option dest             wan
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp
#       option target   REJECT

#config redirect
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port         1024
#       option src_dport        80
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp

So on this specific configuration, you can replicate the problem?

I don't see any obvious issues with the config. When the phone disconnects and then reconnects to wifi, what does it show for the IP address information?

So on this specific configuration, you can replicate the problem?

Yes.
After phone reconnection ip address is same as before, obtained by dhcp

try adding each of the following to

config wifi-iface 'default_radio0'

try all three - if the issue is resolved, try removing one at a time until the issue comes back

    option disassoc_low_ack '0'
    option max_inactivity '43200'
    option dtim_period '3'

try all three - if the issue is resolved, try removing one at a time until the issue comes back

Nothing changed

Do they still have all the network information -- i.e. IP address, subnet mask, router/gateway, and DNS?

Can the phones ping any devices on the network (such as another computer)?

So, only Xiaomi phones have the issue? seems like it's a problem with Xiaomi phones

Yes.

After internet access disappears - no.

Yes.

But, this phones works perfectly with TP-Link routers on factory firmware, without any problems.

So, openwrt is not the common problem either

Anything at all different in the wireless settings for the TLWR-840N v2

From TLWR-840N:

cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel 'auto'
        option hwmode '11g'
        option path 'platform/qca953x_wmac'
        option htmode 'HT20'
        option country 'BZ'
        option noscan '1'
        option txpower '19'
        option distance '50'
#       option disabled '1'

#config wifi-iface 'wds'
#       option device 'radio0'
#       option ssid 'testssid'
#       option ssid 'Yes'
#       option key 'testtestt'
#       option key 'tsttstststst'
#       option mode 'sta'
#       option encryption 'psk2'
#       option network 'wwan'

config wifi-iface 'access_point'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2'
        option ssid 'sssssidddd'
        option key 'keykeykey'
#       option channel '13'

Tried apply same config to 850N - nothing changed.

that's what I noticed:

wlan hardware:
WR840N v2 - Qualcomm Atheros QCA9533
WR850N v1 - MediaTek MT7628N
Xiaomi Mi3G - MediaTek MT7603EN
MR3020 v3 - MediaTek MT7628NN

Trouble with routers on mediatek chips