Problems with stuck LAN and no WiFi after boot

Hi!
I am trying to revive an old Kingston MLWG2, a nice small portable AP with a huge battery. I followed some guides and managed to flash the 19.07.4 image, official, for it.

After boot, it seems the device is dead. I opened it up and soldered the pins for the serial console, managed to access the device via serial and... it is working!

The lan:

root@OpenWrt:/etc/config# ifconfig 
br-lan    Link encap:Ethernet  HWaddr 00:26:B7:09:E9:32  
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::226:b7ff:fe09:e932/64 Scope:Link
          inet6 addr: fdf0:a4ca:5192::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:17 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:2194 (2.1 KiB)

eth0      Link encap:Ethernet  HWaddr 00:26:B7:09:E9:32  
          inet6 addr: fe80::226:b7ff:fe09:e932/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:31 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1172 (1.1 KiB)  TX bytes:4689 (4.5 KiB)
          Interrupt:5 

eth0.1    Link encap:Ethernet  HWaddr 00:26:B7:09:E9:32  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:17 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:2194 (2.1 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:198 errors:0 dropped:0 overruns:0 frame:0
          TX packets:198 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:13616 (13.2 KiB)  TX bytes:13616 (13.2 KiB)

The wireless:

root@OpenWrt:/etc/config# iw list
Wiphy phy0
        max # scan SSIDs: 4
        max scan IEs length: 2257 bytes
        max # sched scan SSIDs: 0
        max # match sets: 0
        max # scan plans: 1
        max scan plan interval: -1
        max scan plan iterations: 0
        Retry short long limit: 2
        Coverage class: 0 (up to 0m)
        Available Antennas: TX 0 RX 0
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * AP/VLAN
                 * monitor
                 * mesh point
        Band 1:
                Capabilities: 0x17e
                        HT20/HT40
                        SM Power Save disabled
                        RX Greenfield
                        RX HT20 SGI
                        RX HT40 SGI
                        RX STBC 1-stream
                        Max AMSDU length: 3839 bytes
                        No DSSS/CCK HT40
                Maximum RX AMPDU length 32767 bytes (exponent: 0x002)
                Minimum RX AMPDU time spacing: 2 usec (0x04)
                HT TX/RX MCS rate indexes supported: 0-7, 32
                Frequencies:
                        * 2412 MHz [1] (20.0 dBm)
                        * 2417 MHz [2] (20.0 dBm)
                        * 2422 MHz [3] (20.0 dBm)
                        * 2427 MHz [4] (20.0 dBm)
                        * 2432 MHz [5] (20.0 dBm)
                        * 2437 MHz [6] (20.0 dBm)
                        * 2442 MHz [7] (20.0 dBm)
                        * 2447 MHz [8] (20.0 dBm)
                        * 2452 MHz [9] (20.0 dBm)
                        * 2457 MHz [10] (20.0 dBm)
                        * 2462 MHz [11] (20.0 dBm)
                        * 2467 MHz [12] (20.0 dBm) (no IR)
                        * 2472 MHz [13] (20.0 dBm) (no IR)
                        * 2484 MHz [14] (20.0 dBm) (no IR)
        valid interface combinations:
                 * #{ managed, AP, mesh point } <= 8,
                   total <= 8, #channels <= 1
        HT Capability overrides:
                 * MCS: ff ff ff ff ff ff ff ff ff ff
                 * maximum A-MSDU length
                 * supported channel width
                 * short GI for 40 MHz
                 * max A-MPDU length exponent
                 * min MPDU start spacing
        Supported extended features:
                * [ RRM ]: RRM
                * [ CQM_RSSI_LIST ]: multiple CQM_RSSI_THOLD records
                * [ CONTROL_PORT_OVER_NL80211 ]: control port over nl80211

But if i hook up a network cable on the (only) ethernet port and try to ping it (with static IP on the computer) i get no response. Also pinging the computer from OpenWRT gives no response.

And scanning WiFi networks shows absolutely no OpenWRT Access Point?

Now, this is a default boot configuration, here are relevant files:

root@OpenWrt:/etc/config# cat network 

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdf0:a4ca:5192::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device 'lan_eth0_1_dev'
        option name 'eth0.1'
        option macaddr '00:26:b7:09:e9:32'

and:

root@OpenWrt:/etc/config# cat wireless 

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/10180000.wmac'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

What i am missing here? It has to be so obvious i don't see it or something i am not aware of?

Thank you for any inputs you can give me!

Additional info: using wireshark i can confirm that the hardware link is working. When i ping from the openwrt to the pc, i can see the ARP requests (Who has IP 192.168.1.10? Tell 192.168.1.1) but it seems the PC is not responding?? Same think the other way around (openwrt does not reply to PC arp requests?) This never happened to me before... I have iptables disabled on the PC...

(the device was working great with stock firmware...)

option disabled '1'

Wireless card is disabled by default "if an ethernet port is present?" comment or remove that line and reboot or run:

wifi down
wifi up

For the ethernet port i can't see what could be wrong. What static IP are you using on your pc?

Yes! The wireless part is now fixed, thank you!

For the wired part....
The pc IP is 192.168.1.10/24. I can see with wireshark the arp requests both from openwrt and the pc when i try to ping both ways... but nobody ever answer???

For the "wired" part... I created a new interface (TEST) bonded to eth0 and setup a DHCP on it, with a 192.168.2.1/24 subnet. With this setup, by PC can connect and get an IP via DHCP.

Still unable to make it work on the "LAN" interface... I tried to bind the LAN interface to both wlan0 and eth0, but still will not get an IP via DHCP on the PC or even ping if i set a static route...

Any ideas?

I noticed the switch part is missing from the network file. I checked in the 19.07 source and indeed it is setup without a switch command (unfortunately I am not sure in which case this happens but I guess it is for single interface devices or something).

I am sure someone more knowledgeable with the switch commands will help. In the meantime can you paste the output of

uci show network
swconfig list

When you see the name of your switch "assuming the switch name is switch0"

swconfig dev switch0 show

It seems i fixed it...
in my /etc/config/network i was missing a line under the "LAN" interface:

option iface "eth0"

Now it looks like this:

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ifname 'eth0'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.25'

reloaded network and it worked!!!
Weird...
Some erroneous default setting?

1 Like

Yes i was mistified by the absence of the switch section, but i assumed that's because this device has no real "wan" option... something was missing from OpenWRT default setup anyway, because it's a dead device on first setup. With WiFi disabled and eth0 not bridged... hey, either you solder the serial TTY or you are done!

How should i report this upstream?

I guess you should although i don't know where you can. Normally you should compile from source with the change and then send a pull request. I see 2 other devices with the same setup I wonder if they have the same issue.

The file is this one. Indeed the lan interface is define as eth0.1

By the way with wireshark could you see that the packets were vlan tagged or not?

I don't know because i removed the vlan, i did not need it, and did not take a log before.

I have opened a bug in Flyspry at

i hope it will not be discarded. I dont have the time nor the resources at this point to build an image myself and test it. But should be trivial to fix for developers, i hope.

I have also updated the wiki page here:

with updated documentation and references.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.