Problems with IPv6 config with E8450/RT3200, Comcast Xfinity

Hi all, apologies if this isn't the right place -- I've got my belkin rt3200 set up running openwrt just fine, but I am not getting an IPV6 uplink from my cable provider, only ipv4. I did install the newest snapshot without saving configuration or settings, just to see if that would resolve my issues, to no avail. Is there something simple I'm missing that I can adjust to get IPV6 connectivity working?

If you get no IPV6 in the uplink but you get IPV4, probably your ISP is not using IPV6 or has not configured DHCP for it.
Has you asked your provider?
Do you have need of IPV6 address in your wan internet interface?

I'm sure my ISP has IPV6 enabled, as I get IPV6 connectivity when I connect directly to the modem with my computer (type: native IPV6; oddly, I don't seem to have any IPV4, but perhaps I didn't let the test fully run or something; only ipv6 connected from what I could tell in my very short test).

I just am curious how to configure the network (and set my ipv6 dns servers to cloudflare or whatever) in the best way, and I suspect I've got some settings befuddled somewhere.

edit: not sure if it matters, but my wan6 has a restart, but the "stop" is always greyed out in interfaces.

That's unlikely to be an issue specific to this very hardware, but more likely a more generic setup conundrum of your ISP's requirements. It would make more sense to split this question out of this thread and to create a new one, providing more details about the ISP, its requirements and your configuration, as well as some log output (dmesg, logread, ifstatus wan, ifstatus wan6, ifstatus wan_6, …).

Yes it seems more some kind of config problem.
I have activated IPv6 in the wan port (PPoE config) and seems I have received a IPv6 address in that interface (just changed the IPV6 assignment length in advanced settings of the WAN interface from 0 to 64.
Now it seems to have a IPv6 address, but I really don't use it for anything for now.

Thank you for your help! I really appreciate it.

A bit more information from the logs and the like:

I have a native IPv6 config from my ISP (Xfinity / Comcast) when directly linked. They should be giving a /60 and I think that's what I've enabled.

My ifstatus wan6 is:

{
        "up": false,
        "pending": true,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "proto": "dhcpv6",
        "device": "wan",
        "data": {

        }
}

My ifstatus wan is much longer. If there's anything in particular to see in that one I am happy to give respective output.

For logread, the only thing for wan6 are the following lines:

Mon Jan 17 14:11:59 2022 daemon.notice netifd: Interface 'wan6' is enabled
Mon Jan 17 14:11:59 2022 daemon.notice netifd: Interface 'wan6' has link connectivity
Mon Jan 17 14:11:59 2022 daemon.notice netifd: Interface 'wan6' is setting up now

Nothing after that.

For the dmesg, it looks like the only thing that's showing up there is the local IPv6 getting set up.

Please let me know if there's any additional diagnostics or anything I can run.

Thank you all again for your help!

Can you please post your /etc/config/network ? I also have Comcast Xfinity and I am using Belkin RT3200. I get native ipv6 connectivity. My /etc/config/network (part of it):

config device 'wan'
	option name 'wan'
	option mtu '1500'
	option mtu6 '1500'

config device 'br_lan_1'
	option name 'br-lan_1'
	option type 'bridge'
	option mtu '1500'
	option mtu6 '1500'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'

config device 'br_lan_2'
	option name 'br-lan_2'
	option type 'bridge'
	option mtu '1500'
	option mtu6 '1500'
	list ports 'lan4'

config interface 'lan_1'
	option device 'br-lan_1'
	option proto 'static'
	option ipaddr '192.168.214.1'
	option netmask '255.255.255.0'
	option ip6assign '64'
	option ip6hint 'A'
	option ip6ifaceid '::1'
	option delegate '0'
	option disabled '0'
	list ip6class 'local'
	list ip6class 'wan6_1'

config interface 'lan_2'
	option device 'br-lan_2'
	option proto 'static'
	option ipaddr '192.168.224.1'
	option netmask '255.255.255.0'
	option ip6assign '64'
	option ip6hint 'B'
	option ip6class 'wan6_1'
	option ip6ifaceid '::1'
	option delegate '0'
	option disabled '0'

config interface 'wan4'
	option device 'wan'
	option proto 'dhcp'
	option hostname '*'
	option delegate '0'
	option peerdns '0'
	list dns '8.8.8.8'
	list dns '8.8.4.4'
	list dns '1.1.1.1'
	list dns '1.0.0.1'
	option disabled '0'

config interface 'wan6_1'
	option device 'wan'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix '60'
	option peerdns '0'
	list dns '2001:4860:4860::8888'
	list dns '2001:4860:4860::8844'
	list dns '2606:4700:4700::1111'
	list dns '2606:4700:4700::1001'
	option disabled '0'

config interface 'wan_modem'
	option device 'wan'
	option proto 'static'
	option ipaddr '192.168.100.111'
	option netmask '255.255.255.0'
	option delegate '0'
	option disabled '0'

Sure, thank you for helping out!

Here's my /etc/config/network (save for globals, which has a ula_prefix and packet steering, and the loopback interface):

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '64'
        option ip6ifaceid '::1'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'
        option peerdns '0'
        list dns '1.1.1.1'
        list dns '1.0.0.1'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix '60'
        option peerdns '0'
        list dns '2606:4700:4700::1111'
        list dns '2606:4700:4700::1001'

My network is simpler, but otherwise configured essentially the same from what I can tell looking at our two outputs.

I don't see anything in your config that may block IPv6. Do you have "odhcp6c" pkg installed? I think that's the default DHCPv6 client in OpenWRT.

Are you by any chance blocking DHCPv6 and ICMPv6 in your firewall config? This is my firewall config specific to "wan" zone:

In my current SNAPSHOT image, I am using firewall4 (nftables), but IPv6 also worked with firewall3 (iptables) before.

Also I am not sure if your modem is blocking IPv6, but it's highly unlikely that the modem is the culprit. What modem do you have? I am using Arris S33 DOCSIS 3.1 modem.

I took a look, and it seems that odhp6c is installed along with odhcpd-ipv6only on the machine. When I look at the startup on system I see that odhcpd is enabled but I don't see an odhpcd (not sure If it would be expected to see it there).

The only difference between our two firewall rules were the ports on the DHCPv6 bit. Mine just had 546 or any port. Changing to yours didn't seem to bring up ipv6 at all. Interestingly, my firewall rule is called Allow-DHCPv6 and not Allow-DHCPv6-Relay, not sure if that matters at all. Everything else was the same.

My modem is a motorola mb8600, docsis 3.1 1gbps. An interesting aside to me, it claims to have AQM but I don't see anywhere in the modem software where I can enable that (though I do have SQM / AQM enabled on the router side to deal with bufferbloat).

edit: Another aside, I'm not sure I've mentioned it, but on the status > overview there isn't even a greyed out IPv6 upstream there, it's just IPv4 upstream. Is there a way to force the wan6 interface to come up?

What output do you get when you do the following in ssh terminal?

/sbin/ifup wan6

The end-user has no control over most of the firmware settings in a DOCSIS modem (irrespective of DOCSIS version). The ISP controls the modem and this is baked into the DOCSIS standards. There's nothing you or I can do to enable/disable AQM in the modem settings.

However if you have SQM running in your router, it doesn't matter if AQM is enabled/disabled in the DOCSIS modem.

Do you have flow offloading enabled in firewall config? I think currently ipv6 does not work properly over flow offloading. Not sure if the issue is with software flow offloading or hardware flow offloading.

I had an issue with my cable provider where the modem would only supply a DHCP address on startup - the window for the modem supplied IP address was narrow. My work around was to cold start both the Modem and OpenWRT router at the same time. It also worked with a cold start of the modem and a reboot of openwrt.

/sbin/ifup wan6 doesn't produce any output; wan6 ifstatus still shows it down afterwards as well.

Interesting info about the AQM bit! That is good to know! I guess I would like xfinity to have it enabled so I could offload those cpu cycles on the router but without SQM on the router, bufferbloat is pretty bad (so assuming Xfinity isn't enabling it).

I may try the cold boot option, but I've sort of done this during trouble shooting anyhow (they're both plugged into the same power outlet, which I unplugged to transfer somethings - they should all have gotten plugged back in at the same time).

No flow control turned on (as far as I'm aware, it doesn't work with SQM QoS stuff enabled).

So just an interesting aside; I have IPv6 connectivity now, with no configuration changes. I tried to install the newest snapshot today, it failed, so I had to ssh in and remove the files from /sys/fs/pstore, and rebooted. On reboot, IPv6 connectivity was there alongside ipv4. Really not sure why, as before the failed snapshot update it was just ipv4.

Not sure what to make of it, or how long it will last, but I guess happy for now!

I ran into similar issue with Arris SB8200 modem and this solution worked for me.

Had to comment out the source IP and IPv6 started working.

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        # option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

Credits to trendy from this post for the fix IPv6 not working in 19.07 in standard configuration, only disable Firewall rules helped - #20 by trendy

2 Likes

Interesting, thanks for the update on that. I've been keeping up with snapshots and it "just works" now, in the recent updates.

I do have a problem where my wifi ceases to work (wired still fine), so I've got to track that down, but IPv6 seems resolved on newer snapshots for me.