Problems with dumb ap and switch E2000

Hi, i'm trying to get my e2000 working as a dumb ap with lan ports working. I get the part working for dumb ap, but the part where my lan ports are all working like a switch, that's the part I can't get working. I've searched through the forum and found that the problem most definitely lies with the switch0 not present. Because on my RT-AC51U it is present, but I can't get it on my e2000. You can add it manually through ssh, but I don't exactly understand how that needs to be configured (The switch0, not ssh :sweat_smile:) Can someone help me with this? Thanks in advance!

I'm running 19.07.1 on the e2000.

What is the output of uci export network ?

See the picture:

Was it like this by default without any switch section?

What does swconfig list show?

Yes, it is like thuis without switch. Cold installation with dumb ap adjustments. In 5 hours I can give you the swconfig list if you want.

Yes, it would be helpful.

Found: switch0 - eth0.

That was fast.
Check if there are other interfaces or just eth0: ls -l /sys/class/net

lrwxrwxrwx 1 root root 0 Jan 30 01:28 br-lan ->
lrwxrwxrwx 1 root root 0 Jan 1 1970 eth0 -> ..
lrwxrwxrwx 1 root root 0 Jan 1 1970 lo -> ../.
lrwxrwxrwx 1 root root 0 Jan 30 01:28 wlan0 -> .

Alright, since there is no reference switch configuration we are on uncharted territory. To avoid locking yourself outside I suggest you break the lan bridge and create a dedicated wireless interface with it's own IP. Assign it in lan firewall zone and make sure you can login from wifi before making changes in the switch configuration which might lock down the lan ports.

Instructions are here. I suggest you to add only the first paragraph in config/network, restart network service and see if a switch page will appear in Luci under Network. From there it will be easier to configure with visual help and you'll have also the rollback failsafe.

That I will do, when i'm home.

I'm getting an error, Network device is not present.
I dont know what i'm doing wrong :joy:

swconfig dev switch0 show ?

I'm getting that error when making a dedicated wireless interface. Sorry, needed to clarify that earlier.

Paste here the uci export wireless

See here: and:

Could you edit the post and paste the output in a preformatted text box (the </> button) instead of uploading photos? Thanks!

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'bcma0:1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option key '***'
        option ssid '***'
        option encryption 'psk2'
        option network 'lan'

In the "wireless" interface of config/network change the IP to, and remove gateway and dns. The iface wlan0 is not necessary.
In the wifi-iface config change the option network from lan to wireless.
Optionally enable dhcp for the wireless interface.

1 Like

Now the switch is visible. How to continu now?