Problems with 802.1x configuration

etc/config/network:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd3a:4ef0:a761::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth0'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth0'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 0t'

etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/qca956x_wmac'
	option htmode 'HT20'
	option country 'US'
	option legacy_rates '1'
	option disabled '0'
	option channel '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2'
	option key 'ABEDCNAU'
	option ssid 'OpenWrt'

My wpasupplicant.conf

# wpa_supplicant mit EAP-PEAP ##################################
ctrl_interface=/var/run/wpa_supplicant
ap_scan=0
fast_reauth=1
network={
	key_mgmt=WPA-EAP
	eap=PEAP
	anonymous_identity="eduroam@realm"
	identity="username@realm"
	password="userpassword"
	ca_cert="/etc/deutsche-telekom-root-ca-2.pem"
	phase2="auth=MSCHAPV2"
	priority=10 }

Router: TP-Link WR940N (v6 version)
https://openwrt.org/toh/tp-link/tl-wr940n

bump, i cant find my mistake

Start wpa_supplicant without -B and with -dd and wait a bit, see what comes up. Probably not much, because I believe the full debug output is not available in the standard package. (You have to set a build option for it)
open another ssh session
start wpa_cli (or wpa-cli ?) in the other window an type reassociate and also see what comes up.

Btw. you replaced realm with your university domain? Your university requires the anonymous_identity option? You got your username and password right?