Problems setting pppoe on Gl.inet AP-1300

i simply copy the setting of a tplink c7 that was working fine with pppoe on that AP-1300 and it does not work:

# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'xxxxxxxxxx'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option proto 'pppoe'
	option username 'xxxxxxxxxxxxxxxx@tiscali.it'
	option password 'xxxxxxxxxx'
	option ipv6 'auto'
	option device 'eth0.835'

config interface 'wan6'
	option device 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0t 2 3 4 5'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t 1t'
	option vid '835'

`

That would be akin to driving a FIAT with a Ferrari manual in hand. Be happy your device is still reachable at all, you might have messed it up to the point of it needing recovery.

Backup your configuration, run firstboot, reboot and reconfigure your WAN interface with the correct VLAN, preferrably through the GUI.

2 Likes

It's not reachable anymore, I will reflash openwrt. But then I don't know how to config the AP-1300 to work with PPPoE.
From the GUI would it be just adding the PPPoE and the device eth0.835 like here?
grafik
And setting the username and passwd given by my ISP, is that all? I tried it before but did not work, maybe I need to reflash and try it again?

According to the device page, the wan port is connected to eth1.
If you need further help, post the default network configuration after resetting/reflashing the device.

1 Like

As @pavelgl pointed out, your WAN is a different interface on the AP-1300, compared with the C7. So you need to pick/add that one (eth1.835), which sets the correct VLAN, and then add the PPPoE credentials again.

3 Likes

This has an ipq4018 chip where VLANs never really worked properly until the DSA conversion with version 23. So make sure you're running 23.05.2. Start from defaults and note that there is no switch section, which means that you can't just copy from a swconfig device like the Archer A7.

Change the wan proto to pppoe, add your ISP login and password, and change the wan device (assuming it defaults as eth1) to eth1.835

1 Like

Just perform a reset and now I have a fresh new 23.05.2, here're the default network config settings:

# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd47:fd77:5de4::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'


I will try it now, thanks in advance

Ok since the DSA names for the external ports are wan and lan, use wan.835. You can also remove interface wan6, since when a pppoe ISP offers IPv6, it works a different way.

1 Like

it worked with wan.835! Thank you so much!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.