Problems on third radio (radio2) in wrt3200ACM?

Hi,

I have the following configuration attached of my wireless, the third radio (radio2) I only use for 2x ESP8266 devices because I cannot connect to radio1 where I have a 2.4GHz configuration.
The radio2 is working well for a day, and then it is in the state as the printscreen attached.

Firmware version: OpenWrt 19.07.5 r11257-5090152ae3 / LuCI openwrt-19.07 branch git-20.341.57626-51f55b5

Can anyone help?

Thanks,
Flávio Pinho

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless

cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fda6:0500:c6c3::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth1.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth1.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

config interface 'guest'
        option proto 'static'
        option netmask '255.255.255.0'
        option type 'bridge'
        option ipaddr '192.168.2.1'

cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
        option htmode 'VHT80'
        option country 'PT'
        option channel '36'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option key 'xxxxxxxxxxxx'
        option encryption 'psk2'
        option ssid 'XXXXXXXXX-5G'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
        option htmode 'HT20'
        option country 'PT'
        option channel '11'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option key 'xxxxxxxxxxxx
        option encryption 'psk2'
        option ssid 'XXXXXXXXX'

config wifi-device 'radio2'
        option type 'mac80211'
        option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
        option hwmode '11g'
        option country 'PT'
        option channel '6'
        option htmode 'HT20'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option key 'xxxxxxxxxxxx'
        option encryption 'psk2'
        option ssid 'XXXXXXXXX'

config wifi-iface 'wifinet3'
        option ssid 'XXXXXXXXX-5G-GUEST'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'ap'
        option key 'xxxxxxxxxxxx'
        option network 'guest'

config wifi-iface 'wifinet4'
        option ssid 'XXXXXXXXX-GUEST'
        option encryption 'psk2'
        option device 'radio1'
        option mode 'ap'
        option key 'xxxxxxxxxxxx'
        option network 'guest'

When the third antenna is unavailable, I have to reboot to be all right again, but after 18-24h the third antenna is unavailable again.

The above configuration was taken after rebooting the router and not when the third antenna was available.

Before, I tried with this configuration (wmm disabled):

config wifi-iface 'default_radio2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option key 'xxxxxxxxxxxx'
        option encryption 'psk2'
        option ssid 'XXXXXXXXX'
        option wmm '0'

but the ESP8266 (new Magic Home v1.2 version with BOOT pin) hard to connect, I only got it when I removed the wmm again, and rebooted the router according to the configuration sent.

The router uptime is at 17h and so far it has not failed or the third antenna has been unavailable. I don't know if I have any configuration that can be improved.

My two cents:

However, none of this seems to be related to your issue... Only thing I could spot is the "option htmode 'HT20'" line, as this caused issues similar to yours, with "hostapd" reporting "failed to set beacon parameters" until I rebooted (or at least the issue has not happened again since I removed that line).

By the way, disabling WMM to allow ESP8266 devices to connect works for radio 1, but is not necessary on radio 2.

1 Like

Thanks for your helping, I will try your tips.

For now I removed the setting the country for radio 0 and 1.

The other things you mentioned I will try in two steps.

First one:
I will remove the line "option htmode 'HT20'" in radio2.

First two:
I will disable the wmm in radio1.
Should I remove the line "option htmode 'HT20'" in radio1 too?

One thing, How I can define the AES only? Can you share the right configuration for this encryption?

Thanks.

If you can make radio2 work, there is no need to remove WMM on radio1; notice that disabling WMM has an impact on speed, so you want to use a different SSID for the IoT devices, and test that it does not affect other SSIDs on the same radio.

I'm currently using "psk-mixed+aes" as an encryption algorithm.

If you enable radio2, then you want to have all three radios on the same country; otherwise, the drivers will detect two radios with different countries, and will limit the channels and power levels that you can use. Execute "iw reg get" and "iw dev", then post the results here.

Thanks for your help!
I changed the encryption algorithm to 'psk-mixed+aes' in all wifi-iface and removed the Country setting for radio2.

If I have problems on the third radio, I will create another SSID for IoT devices on radio1 with disabling WMM and test if it doesn't affect other SSIDs on the same radio.

Do you know if it is stable to use 160MHz on radio0 for 5GHz? When I stable this situation, I will try this configuration.

Here the results:
iw reg get:

global
country 98: DFS-UNSET
        (2402 - 2472 @ 40), (N/A, 20), (N/A)
        (5170 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR, AUTO-BW
        (5250 - 5330 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
        (5490 - 5725 @ 160), (N/A, 23), (0 ms), DFS
        (5725 - 5730 @ 5), (N/A, 13), (0 ms), DFS
        (5735 - 5835 @ 80), (N/A, 13), (N/A)
        (57240 - 66000 @ 2160), (N/A, 40), (N/A)

phy#2
country US: DFS-FCC
        (2402 - 2472 @ 40), (N/A, 30), (N/A)
        (5170 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
        (5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
        (5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS
        (5735 - 5835 @ 80), (N/A, 30), (N/A)
        (57240 - 71000 @ 2160), (N/A, 40), (N/A)

phy#1
country FR: DFS-ETSI
        (2400 - 2483 @ 40), (N/A, 20), (N/A)
        (5150 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR, AUTO-BW
        (5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
        (5470 - 5725 @ 160), (N/A, 26), (0 ms), DFS
        (5725 - 5875 @ 80), (N/A, 13), (N/A)
        (57000 - 66000 @ 2160), (N/A, 40), (N/A)

phy#0
country FR: DFS-ETSI
        (2400 - 2483 @ 40), (N/A, 20), (N/A)
        (5150 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR, AUTO-BW
        (5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
        (5470 - 5725 @ 160), (N/A, 26), (0 ms), DFS
        (5725 - 5875 @ 80), (N/A, 13), (N/A)
        (57000 - 66000 @ 2160), (N/A, 40), (N/A)

iw dev:

phy#2
        Interface wlan2
                ifindex 28
                wdev 0x200000001
                addr xx:xx:xx:xx:xx:xx
                ssid XXXXXXXXX
                type AP
                channel 6 (2437 MHz), width: 20 MHz, center1: 2437 MHz
                txpower 17.00 dBm
phy#1
        Interface wlan1-1
                ifindex 32
                wdev 0x100000005
                addr xx:xx:xx:xx:xx:xx
                ssid XXXXXXXXX-GUEST
                type AP
                channel 11 (2462 MHz), width: 20 MHz (no HT), center1: 2462 MHz
                txpower 20.00 dBm
        Interface wlan1
                ifindex 31
                wdev 0x100000004
                addr xx:xx:xx:xx:xx:xx
                ssid XXXXXXXXX
                type AP
                channel 11 (2462 MHz), width: 20 MHz (no HT), center1: 2462 MHz
                txpower 20.00 dBm
phy#0
        Interface wlan0-1
                ifindex 35
                wdev 0x7
                addr xx:xx:xx:xx:xx:xx
                ssid XXXXXXXXX-5G-GUEST
                type AP
                channel 36 (5180 MHz), width: 80 MHz, center1: 5210 MHz
                txpower 23.00 dBm
        Interface wlan0
                ifindex 34
                wdev 0x6
                addr xx:xx:xx:xx:xx:xx
                ssid XXXXXXXXX-5G
                type AP
                channel 36 (5180 MHz), width: 80 MHz, center1: 5210 MHz
                txpower 23.00 dBm

@eduperez Do you have any suggestions related the results output?

My radio0 has been configured at 160MHz for ages, and I have not detected any issue. But I could not make it work untill I configured all three radios to the same country.

You cannot change the country on radio0 or radio1, but you can change it on radio1 (see the link on my previous post). Portugal and France share the same regulations, so you can change radio2 to France, have all three on the same country, and not break any law.

I cannot change the country code, after I changed three radios to the same country, I restarted the router and the radio kept the same country code (radio0 and radio1 -> FR and radio2 -> US) when executing the command iw reg get.
I tried iw reg set FR | in another test I tried iw reg set PT .. and did not change the country code.

How did you change the country? Did you read the post I linked?

Yes, I read what you mentioned.
I don't have the file "/etc/modules.d/mwifiex", only the "/etc/modules.d/mwifiex-sdio" with text inside "mwifiex-sdio".
But, I will keep the radio0 at 80 MHz.

The main problem (ESP8266 cannot connect) was solved with your tips.

Thank you!

You have to create the file.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.