Problems installing openwrt on DSL-2740U with broken DSL

Greetings, I have a D-Link DSL-2740U that has broken DSL. I'm trying to install openwrt so I to need access the CFE web recovery server but it refuses to go into it.
I tried the following steps:
-pressing the reset button then turning on the router while keeping the button pressed
-shorting Tx and Rx
-updating it with blank firmware (doesn't accept it)
But nothing worked.

I want to use this router as a wireless repeater because I have no other use for it.

Can anyone tell me if there's another way?
Or if there's an easier to use this router as a repeater.
Thanks in advance :slight_smile:

greetings, I have a D-LINK DSL-2740U router.

I want to install openwrt, so I need to access the CFE recovery but for some reason it just doesn't want to enter it.

I've tried:

• Pressing the reset button then powering on the router while the reset button is still pressed.

• Shorting Tx and Rx

• Updating the router with an empty update file (doesn't update)

I don't know what's wrong but i really need openwrt on it.

Thanks in advance :slight_smile: