Problems getting WAN-port to work as LAN

I curently have 2 Netgear WAX206. One configured as a router, and one as a dumb AP.
In the router I have changed the LAN1-port to function as the WAN-port (and the wan-port to function as a LAN-port).

Now in the dumb AP I'm trying to add the wan-port to the br-lan so it can act as a regular LAN-port. I have deleted the wan-interfaces, and just added WAN to the bridge-interface, but i cannot communicate with the AP when I connect the ethernet-cable to the WAN-port.

Now you might ask; why would I want to do this? The answer is simle. This will allow me to take advantage of the 2.5Gbit ethernet, and use that to link the router and AP, hopefully providing better bandwidth between the two. I only haee a 350mbit fiberoptic connection from my ISP, so I don't need the 2.5Gbit for internet connectivety anyways.
Both devices are running OpenWrt SNAPSHOT r22180-f57a0709e8

My /etc/config/network for the AP is:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'wan'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.3'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'
        list dns '192.168.1.1'
        option delegate '0'

And for my router:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd90:318e:7512::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'wan'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option proto 'dhcp'
        option device 'lan1'

config interface 'wan6'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix '64'
        option device 'lan1'

Any ideas as to what might be wrong?

What troubleshooting have you done so far?

I'd suggest connecting a computer directly to the main router's physical 'WAN' port (recognizing that it intended to be used as a lan port)... use a known good (and preferably short) cable.

  • Does it get a physical link?
  • Does it get an IP address on the lan (192.168.1.0/24)?

Then try connecting the computer to the far end of the cable that normally connects the two routers together so that your computer is again connecting to the physical 'WAN' port of the main router. Same questions as before.

Try those so we can have some initial informatin, and then we'll continue from there.

Also, any particular reason you're using snapshot instead of stable?

I've tried just about everything :sweat_smile:

The physical wan-port on the router does not seem to be the issue.
I can connect my laptop both directly to the WAN-port, and also on the far end over the longer cable. It links up at 1Gbit, gets an IP from the DHCP, and all is good.
This is also confirmed by the fact that when I connect the far end of the cable to any of the regular LAN-ports on the AP, everything works as normal.

When I try to connect the router and AP WAN to WAN, OpenWRT reports that there is a physical link is up 2.5GBit Full duplex (in the web-interface), but i can no longer connect to the AP via http, ssh, and it does not respond to ping anymore.
image

The reason I'm using snapshot is that support for the WAX206 was just added a couple of weeks ago, and is not included in the latest release yet.

Decided to to one more test; When connecting from the WAN-port of the AP, to one of the other LAN-ports on the Router, everything works fine as well. So it seems the problem is only when using the WAN-port of both the Router and the AP.

Have you tried a short, known good cable between the two wan ports -- I wonder if the problem is related to negotiating 2.5G vs 1G?

I have not tried that yet, but it seems to negotiate the link just fine.
It's a bit of a hassle since I had to DIY a wallmount for the AP, but I can always try that at some point.
Any troubleshooting that can be done without it?

do you have any other 2.5G devices you can plug in on either end of that cable?

Sadly, no :frowning:

Did a quick test just to se what the logs says, and when I connect WAN to WAN i can see in the logs of both router and AP:

AP:
[16131.658107] mt7530 mdio-bus:00 wan: Link is Up - 2.5Gbps/Full - flow control rx/tx
[16131.665765] br-lan: port 5(wan) entered blocking state
[16131.670956] br-lan: port 5(wan) entered forwarding state

Router:
[ 6470.451957] mt7530 mdio-bus:00 wan: Link is Up - 2.5Gbps/Full - flow control rx/tx
[ 6470.459621] br-lan: port 4(wan) entered blocking state
[ 6470.464816] br-lan: port 4(wan) entered forwarding state

The device page is quite clear that support for 2.5 Gbs on the WAN port is still under development.

It only works at 1 Gb for now.

The sentence about speed being capped is actually crossed out since it was fixed. But yes, it is still under development.

But it seems odd that this should cause the issue, as the link actually goes up (at 2.5Gbps even).

Some tests to confirm/refute the broken 2.5G (and working at 1G) should be simple:

R1 WAN > R2 LAN (1G link)
R1 LAN > R2 WAN (1G link)
R1 LAN > R2 LAN (1G link)
R1 WAN > R2 WAN (2.5G link) <- should be broken.

The MT7622 does not support 2.5 GbE directly. Compared to something like the E8450, which is only 1 Gb, they added a separate PHY chip between the "WAN" Ethernet jack and the CPU. The problem is in configuring the link between the two chips. Thus the external cable will link up at 2.5 G, but no data can pass to the CPU.

That is exactly what is happening.

I just confirmed that if I connect WAN to WAN and force the speed down to 1gbs using ethtool, the link works just fine.

If I'm reading correctly in the old WAX206 thread, and in some of the openwrt forks on github, there is a fix on the way. I actually thought this was already in place, but I might have misunderstood.