Problems getting IGMP to work stable at a Dumb AP

Problem:
Every morning when freshly starting the set-top-box of my provider (KPN [Dutch provider]), I need to unplug/replug the LAN cable on the box to make it's connection work.
After this it's good for another day (I guess as long as it's DHCP lease takes), but then I need to redo this procedure over again.
You can imagine this is somewhat a nuisance.

When did I start to experience this problems:
Problems started after upgrading the firmware from 19.07 to 21.02 (Fresh install).
I suspect something with the configuration isn't properly configured, but the IGMP documentation in the OpenWRT Wiki hasn't been adapted to the 21.02 firmware yet, so I suspect some changes in behaviour between v21.02 and v19.07.

My configuration is as follows:
My providers modemrouter is the main router, which is resolving DHCP/DNS etc.
From my providers modemrouter a LAN cable is going to the Youhua WR1200JS in LAN port 1.
The Youhua WR1200JS is configured as DumbAP, so the static IP address et all is configured to point to my providers modemrouter.
The DHCP server (IPv4/IPv6) have been disabled, and their respective services have been disabled as well (dnsmasq/odhcp), and also the firewall has been completely disabled inc. service.
My Set-top-box is connected through LAN port 4 on the YouHua WR1200JS

Hopefully somebody is able to help me out and give me some pointers in the right direction.

Many thanks in advance and kind regards,
Jasper

The router should be doing IGMP, not the AP.

1 Like