Problems connecting 2.4 devices

Hello there;

I have two networks at home, both with the same name "potatoey". One of them runs at 2.4Ghz and the other at 5.2GHz.

Most of the time, this presents no problems and it allows the devices to choose the frequency they want without anyone have to think about it.

Once in a while, I try to connect a 2.4-only device. This fails, every time. I created a third network, different name, to connect these devices. It's ugly.

What am I doing wrong?

Linksys WRT1900ACv2
ARMv7 Processor rev 1 (v7l)
OpenWrt 18.06.2 r7676-cddd7b4c77 / LuCI openwrt-18.06 branch (git-19.020.41695-6f6641d)

To clarify, if you change the name of your original 2.4 GHz network it works with those devices?

Yes, if I turn off the 5.2 radio on the router, they connect fine.

Can you post your wireless config file, please?

config wifi-device 'radio0'

option type 'mac80211'

option hwmode '11a'

option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'

option country 'US'

option legacy_rates '1'

option noscan '1'

option htmode 'VHT80'

option channel '36'

option __toggle 'Disable'

config wifi-device 'radio1'

option type 'mac80211'

option hwmode '11g'

option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'

option country 'US'

option legacy_rates '1'

option htmode 'HT40'

option channel '9'

config wifi-iface

option device 'radio0'

option mode 'ap'

option key ':ant::ant::ant::ant::ant::ant::ant:'

option network 'lan'

option encryption 'psk2'

option wps_pushbutton '1'

option ssid 'Confusion'

config wifi-iface

option device 'radio1'

option mode 'ap'

option network 'lan'

option encryption 'psk2'

option ssid 'Confusion'

option key ':ant::ant::ant::ant::ant::ant::ant:'

option wps_pushbutton '1'

Well, there are, literally, bugs in your file!!

Please use the Pre-Formatted text tool to include your code. Edit the message, select the code lines and click the Pre-Formatted text tool </>.

Could you try Channel 6 or Channel 1, with bandwidth of 20 MHz?

Not certain of what you asked me in the previous message. Guessing that you want me to preserve tabs and spacings:

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option country 'US'
	option legacy_rates '1'
	option noscan '1'
	option htmode 'VHT80'
	option channel '36'
	option __toggle 'Disable'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option country 'US'
	option legacy_rates '1'
	option htmode 'HT40'
	option channel '9'

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option key '🐜🐜🐜🐜🐜🦟'
	option network 'lan'
	option encryption 'psk2'
	option wps_pushbutton '1'
	option ssid 'Confusion'

config wifi-iface
	option device 'radio1'
	option mode 'ap'
	option network 'lan'
	option encryption 'psk2'
	option ssid 'Confusion'
	option key '🐜🐜🐜🐜🐜🦟'
	option wps_pushbutton '1'

Original message was processed on iPhone while in bed :wink:

Will do the change of channel/bw shortly.

The one device I just tested with connected on channel 1/ BW 20MHz.