Problems after transferring the sd card to another raspberry

The situation is this: I set up openwrt on my raspberry pi 3b+ and sent the flash drive image to a friend in another country. The device itself worked, but Wi-Fi did not appear. I removed the "wireless" config and sent it to him. We removed the "disabled" parameter from the config and the 5GHz network started working, but as soon as we switch to 2.4GHz in the web interface, the network does not rise, just like the wlan0 port. We tried both Legacy and H modes, 20, 40Hz width, to no avail. What could be the problem?
Flashed image is openwrt-21.02.1-bcm27xx-bcm2710-rpi-3-ext4-factory.img

Did your friend set the correct Country Code?

No country code.

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/3f300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
	option cell_density '0'
	option channel 'auto'
	option hwmode '11g'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid '*****'
	option encryption 'psk-mixed'
	option wpa_disable_eapol_key_retries '1'
	option isolate '1'
	option key '******'

This config works fine in my RPi, but not work on his RPi

Have him set the correct Country Code.

He just wrote to me. I tried both US and DE and my country. Did not help

maybe something with the driver? I’ll make a reservation right away - at first the “wireless” config was not deleted to disable the automatic execution of the Wi-Fi config command. Range 2.4 did not work, after deleting it the same way. As if it does not work 2.4

I'd recommend to remove the complete wireless configuration (rm /etc/config/wireless) and to generate a new default config (wifi config), after rebooting reconfigure your desired settings via luci (set the correct country code for the location), there is nothing really special in your config and setting that up via luci shouldn't be too difficult.

In the first message, I already wrote that the config was deleted as a file. wifi config is done by default. If you connect via 5GHz and change it to Legacy 2.4 or H 2.4 through Luci, it still doesn’t work and rollback occurs.
What is interesting - I have two pis that work without problems on this image, but the same 2 pis that do not work for him

I figured out what the problem is. The web interface creates an invalid config. 11g and VXT80 appear after selecting the 2.4GHz mode. This is a script issue. For it to work, it should be like this:


Tell me how to change the script correctly so that the config changes correctly?