Problems after adding third Access Point

Hello all,

after I have connected a second D-Link DAP 1860 with OpenWRT 22.03.5 as DHCP client, initially via LAN to the network, massive network problems occur after some/short time.
First, the first AP (802.11s WLAN bridge) can no longer be reached (PING, GUI, SSH), there is high packet loss when PING to the gateway.

Setup: Gateway Turris Omnia (TurrisOS), 2x D-Link DAP-1860 (OpenWRT 22.03.5) identically configured as DHCP client like in the OpenWRT Wiki.

My question is now: How do I troubleshoot the most systematically?


Disconnect it again, to start with ?

Are you sure you've disabled the DHCP?

Hello frolic,

thank you for your quick reply.
Currently the device is disconnected. But I would like to operate this third AP for range extension.
Therefore, the question of how I can now find out where the problem lies.
Could it also be possible that the device (New) or the SoC is defective?

It seems almost as if they interfere with each other, but the IPs and MAC addresses are different.

Are you sure you've disabled the DHCP?

Yes, the second one gets a different IP from the Gateway, like expected.

Not what I asked.

There's also

1 Like

Yes odhcpd and dnsmasq are stopped and disabled.

In the wiki you linked, the config is explained as relay. However, I have set up the network as 802.11s mesh.
I followed the instructions in the OpenWRT wiki as well as those of Marc.

I understand the first AP is connected by wifi to the main router, while the second one is connected by a wire? Could the first AP be connecting to the second one, instead of the main router?

Do you have STP enabled? Spanning tree protocol.

You can plugin your laptop via cable to the AP and use IPv6 link local address for ssh and read logs to debug...

Edit. Please ... Paste your network config. Nobody will watch YouTube videos from random dude to know what you may have configured....

Correct, this is the initial configuration that already leads to problems. According to plan, the AP should also run as a pure 802.11s WLAN bridge.
For testing purposes, I could also connect the second AP to the first one.

STP is currently not enabled. I will try.

Nobody will watch YouTube videos from random dude [...]

So Marc's videos are even linked in the OpenWRT Wiki that you've posted, he doesn't seem to be that random, anyway.

Gateway /etc/config/network:

config interface 'loopback'
        option proto 'static'
        option ipaddr ''
        option netmask ''
        option device 'lo'

config globals 'globals'
        option ula_prefix 'fdbe:xxxx:xxxx::/48'

config interface 'lan'
        option proto 'static'
        option ipaddr ''
        option netmask ''
        option ip6assign '60'
        option device 'br-lan'

config interface 'wan'
        option device 'eth2.22'
        option proto 'pppoe'
        option vpi '0'
        option vci '0'
        option username 'xxx'
        option password 'xxx'
        option ipv6 'auto'

config interface 'wan6'
        option device '@wan'
        option proto 'dhcpv6'

config device 'br_lan'
        option name 'br-lan'
        option bridge_empty '1'
        list ports 'lan0'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        option type 'bridge'


config wifi-device 'radio0'
        option type 'mac80211'
        option macaddr 'xxxx'
        option band '5g'
        option channel '40'
        option htmode 'VHT80'
        option beacon_int '80'
        option cell_density '0'
        option country 'DE'
        option txpower '23'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option network 'lan'
        option ssid 'xxxx'
        option encryption 'sae'
        option key 'xxxx'
        option ieee80211r '1'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'
        #option pmk_r1_push '1'
        option mobility_domain '4f57'
        option dtim_period '3'
        option reassociation_deadline '20000'
        option bss_transition '1'
        #option time_advertisement '2'
        #option time_zone 'CET'
        option ieee80211k '1'
        #option rrm_neighbor_report '1'
        #option rrm_bacon_report '1'

config wifi-iface 'mesh5g'
        option device 'radio0'
        option ifname 'mesh0'
        option mode 'mesh'
        option network 'lan'
        option mesh_id 'xxxx-mesh'
        option encryption 'sae'
        option key 'xxxx'
        option dtim_period '2'

And same for 2.4G

Keep in mind that STP is quiet slow. Convergence timer can be around 20 to 30 seconds when links change their state. (As far as I know that's why some people run batman-adv in addition.)

But otherwise the config looks so ok?

All mesh options are done in mesh11sd config.

@bluewavenet how should loop prevention be implemented on a 11s(d) network? Could you give advise?

A pure 802.11s network has its own built in loop protection, but if you connect up alternate links ie cable, then the mesh cannot do anything about it. Disconnect the cable links or disable the mesh.....

Then I will try to set up a batman-adv network and report again afterwards.

So far it has failed because of the bridging of the batman network and the 'lan'.

So are you running batman or not? Batman fails, so you are going to try and set up batman and report back? What you are saying does not make sense.

Also you entirely missed the point of my comment - if you have a cable connection, why do you also need a mesh connection?

No, i don't use batman. Only 802.11s (Mesh).

I do not have a cable connection at the final AP location. I have only connected the AP for fault diagnosis/ by cable.

So you have BOTH 5GHz and 2.5GHz radios configured as mesh? Any particular reason?

I was under the assumption that the data rate then adds up accordingly because the data can be carried over both bands (similar to AVM products). But this does not seem to be the case?

Having two mesh networks can create a loop; if that happens (and you do not use STP), packets start bouncing from node to node, endlessly.

1 Like

I had disabled the 2.4G Mesh und will try. :+1:

You can do this but will have to to configure bonding, but that is another matter all together.
Both bonded channels need to be similar bandwidth for it to work well, so 2.5GHz and 5GHz is not good.

Without bonding, as @eduperez says, you WILL have a loop.

STP will serve only to block one of the mesh networks and even worse, not all mesh nodes will necessarily agree on which mesh to block....