Problem with wireless speed (2.4 GHz N) with two Xiaomi meshed routers MT7620

I have got a problem with the wireless network on MT7620 two Xiaomi routers which my phone with on 2.4 GHz is connecting with a speed of 72 Mbps.
On a router with MediaTek MT7603E 2.4 card, my phone is connecting with a speed of 150 Mbps.
How to achieve a 150 Mbps link speed on routers with MT7620?
The settings are identical, the channel width is 40 MHz, and force 40MHz mode is disabled, but country codes are mixed as CN and US, to achieve maximum Tx/Rx transmit power. Channels are 11, 6 and 1
Is setting country codes on routers can be a problem?
The MT7603E is ZBT Link WG-3526 is a gateway with LTE with 19.07.6, the problematic routers with the MT7620 is Xiaomi Wifi Mi Mini with 19.07.7 and Xiaomi MIR3 with X-WRT.
All routers are connected with mesh on 5 GHz with the same channel and create 2,4 network with FR over DS with the same mobility domain

I set "noscan" to 1 in Wireless interface (in Luci option Force 40MHz mode) on all routers. Now on all routers the link speed is 150 MBps

Just keep in mind you're basically hogging bandwidth and creating extra interference for neighbours on the 2,4 GHz band. If you set HT40 and OpenWrt falls back to HT20 without the 'noscan' setting that means there's too many other APs around to claim 40 MHz.

That is strange but I'm using channels 1, 6, and 11 on three routers.
Are setting 1, 8, 13 should be better (I'm using a 2.4 GHz network especially for the garden, etc.)?
The speed is fine now around 150 Mbit/s on all routers in 1000m square of backyard.
Should I am try to set a one router to 13 channel, could be a connectivity problem source with client devices in country which uses 1-11 channel?

1, 6 and 11 are the only ones that don't overlap (at 22 MHz, so HT20!):

Using 13 will probably cause trouble for clients, yes.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.