Problem with VLAN tagging on DIR-860L (MT7530)

Please test my fix at https://git.openwrt.org/?p=openwrt/staging/jow.git;a=commitdiff;h=0ecf301acb3bc78423056b868d22f8b755b74e31

I only have limited experience with compiling my own firmware, so just to make sure this is the proper way to do it:

  1. I simply clone the master branch of your staging tree and then compile as usual?
  2. Or: I apply this commit to the regular Lede master branch (how?) and then compile that?

Either way should work; to just apply the patch; use a command like:

wget -O - "https://git.openwrt.org/?p=openwrt/staging/jow.git;a=patch;h=0ecf301acb3bc78423056b868d22f8b755b74e31" | git am

To later revert this patch, use git reset --hard origin/master to reset your cloned master branch to its vanilla upstream state.

After applying the branch you can build as usual. Please only flash the resulting image if you're familiar with the recovery procedures and/or if you have TTL serial access.

Perfect. The girlfriend will be back in an hour, so not enough time to go playing around with our internet now :wink: But I will test the patch and report back tomorrow :slight_smile: Thank you very much for your effort trying to fix this issue!

Compiling now. Running on a laptop inside a VM, so it's going to take a while. Will report back once I have tested it.

Thank you very much for your effort. Unfortunately, the issue remains. My home network is using VLANs 1, 2, 4 and 6. My old configuration had a dummy VLAN at 3 and 5 to fix the issue.

I just compiled and flashed from your staging tree, however, when adding VLAN 8 this new VLAN is nonfunctional. Changing it to VLAN 7 (the next in line) instantly fixes this. Changing it back to VLAN 8 breaks it again. And so on, so forth.

If you have any other ideas, I would be more than willing to help in testing. Thanks again! :slight_smile:

Please provide the output of swconfig dev switch0 show in the non functional state.

root@LEDE:~# swconfig dev switch0 show
Global attributes:
	enable_vlan: 1
	mib: Switch MIB counters
PPE_AC_BCNT0: 0
PPE_AC_PCNT0: 0
PPE_AC_BCNT63: 0
PPE_AC_PCNT63: 0
PPE_MTR_CNT0: 0
PPE_MTR_CNT63: 0
GDM1_TX_GBCNT: 0
GDM1_TX_GPCNT: 0
GDM1_TX_SKIPCNT: 0
GDM1_TX_COLCNT: 0
GDM1_RX_GBCNT1: 0
GDM1_RX_GPCNT1: 0
GDM1_RX_OERCNT: 0
GDM1_RX_FERCNT: 0
GDM1_RX_SERCNT: 0
GDM1_RX_LERCNT: 0
GDM1_RX_CERCNT: 0
GDM1_RX_FCCNT: 0
GDM2_TX_GBCNT: 0
GDM2_TX_GPCNT: 0
GDM2_TX_SKIPCNT: 0
GDM2_TX_COLCNT: 0
GDM2_RX_GBCNT: 0
GDM2_RX_GPCNT: 0
GDM2_RX_OERCNT: 0
GDM2_RX_FERCNT: 0
GDM2_RX_SERCNT: 0
GDM2_RX_LERCNT: 0
GDM2_RX_CERCNT: 0
GDM2_RX_FCCNT: 0

Port 0:
	mib: Port 0 MIB counters
TxDrop     : 0
TxCRC      : 0
TxUni      : 94495
TxMulti    : 13
TxBroad    : 5
TxCollision: 0
TxSingleCol: 0
TxMultiCol : 0
TxDefer    : 0
TxLateCol  : 0
TxExcCol   : 0
TxPause    : 0
Tx64Byte   : 1877
Tx65Byte   : 61612
Tx128Byte  : 26595
Tx256Byte  : 1395
Tx512Byte  : 1296
Tx1024Byte : 1738
TxByte     : 12825891
RxDrop     : 0
RxFiltered : 683
RxUni      : 113277
RxMulti    : 861
RxBroad    : 0
RxAlignErr : 0
RxCRC      : 0
RxUnderSize: 0
RxFragment : 0
RxOverSize : 0
RxJabber   : 0
RxPause    : 0
Rx64Byte   : 1837
Rx65Byte   : 32281
Rx128Byte  : 37934
Rx256Byte  : 3357
Rx512Byte  : 1896
Rx1024Byte : 36833
RxByte     : 66000359
RxCtrlDrop : 0
RxIngDrop  : 0
RxARLDrop  : 0

	pvid: 0
	link: port:0 link:up speed:1000baseT full-duplex 
Port 1:
	mib: Port 1 MIB counters
TxDrop     : 0
TxCRC      : 0
TxUni      : 358
TxMulti    : 550
TxBroad    : 239
TxCollision: 0
TxSingleCol: 0
TxMultiCol : 0
TxDefer    : 0
TxLateCol  : 0
TxExcCol   : 0
TxPause    : 0
Tx64Byte   : 231
Tx65Byte   : 371
Tx128Byte  : 389
Tx256Byte  : 91
Tx512Byte  : 20
Tx1024Byte : 45
TxByte     : 221810
RxDrop     : 0
RxFiltered : 8
RxUni      : 482
RxMulti    : 3133
RxBroad    : 14
RxAlignErr : 0
RxCRC      : 0
RxUnderSize: 0
RxFragment : 0
RxOverSize : 0
RxJabber   : 0
RxPause    : 0
Rx64Byte   : 160
Rx65Byte   : 185
Rx128Byte  : 5
Rx256Byte  : 3200
Rx512Byte  : 10
Rx1024Byte : 69
RxByte     : 1640872
RxCtrlDrop : 0
RxIngDrop  : 0
RxARLDrop  : 0

	pvid: 1
	link: port:1 link:up speed:100baseT full-duplex 
Port 2:
	mib: Port 2 MIB counters
TxDrop     : 0
TxCRC      : 0
TxUni      : 30127
TxMulti    : 367
TxBroad    : 230
TxCollision: 0
TxSingleCol: 0
TxMultiCol : 0
TxDefer    : 0
TxLateCol  : 0
TxExcCol   : 0
TxPause    : 0
Tx64Byte   : 950
Tx65Byte   : 441
Tx128Byte  : 290
Tx256Byte  : 786
Tx512Byte  : 271
Tx1024Byte : 27986
TxByte     : 42953082
RxDrop     : 0
RxFiltered : 304
RxUni      : 13191
RxMulti    : 618
RxBroad    : 484
RxAlignErr : 0
RxCRC      : 0
RxUnderSize: 0
RxFragment : 0
RxOverSize : 0
RxJabber   : 0
RxPause    : 2
Rx64Byte   : 11759
Rx65Byte   : 701
Rx128Byte  : 448
Rx256Byte  : 361
Rx512Byte  : 223
Rx1024Byte : 803
RxByte     : 2335486
RxCtrlDrop : 0
RxIngDrop  : 0
RxARLDrop  : 0

	pvid: 7
	link: port:2 link:up speed:1000baseT full-duplex 
Port 3:
	mib: Port 3 MIB counters
TxDrop     : 0
TxCRC      : 0
TxUni      : 31000
TxMulti    : 3650
TxBroad    : 240
TxCollision: 0
TxSingleCol: 0
TxMultiCol : 0
TxDefer    : 0
TxLateCol  : 0
TxExcCol   : 0
TxPause    : 0
Tx64Byte   : 1260
Tx65Byte   : 14184
Tx128Byte  : 15841
Tx256Byte  : 3225
Tx512Byte  : 159
Tx1024Byte : 221
TxByte     : 5331992
RxDrop     : 0
RxFiltered : 34
RxUni      : 31330
RxMulti    : 58
RxBroad    : 19
RxAlignErr : 0
RxCRC      : 0
RxUnderSize: 0
RxFragment : 0
RxOverSize : 0
RxJabber   : 0
RxPause    : 0
Rx64Byte   : 795
Rx65Byte   : 17951
Rx128Byte  : 12346
Rx256Byte  : 178
Rx512Byte  : 92
Rx1024Byte : 45
RxByte     : 3232901
RxCtrlDrop : 0
RxIngDrop  : 0
RxARLDrop  : 0

	pvid: 1
	link: port:3 link:up speed:100baseT full-duplex 
Port 4:
	mib: Port 4 MIB counters
TxDrop     : 0
TxCRC      : 0
TxUni      : 29974
TxMulti    : 3646
TxBroad    : 240
TxCollision: 0
TxSingleCol: 0
TxMultiCol : 0
TxDefer    : 0
TxLateCol  : 0
TxExcCol   : 0
TxPause    : 0
Tx64Byte   : 213
Tx65Byte   : 12768
Tx128Byte  : 17306
Tx256Byte  : 3229
Tx512Byte  : 151
Tx1024Byte : 193
TxByte     : 5279766
RxDrop     : 0
RxFiltered : 16
RxUni      : 30362
RxMulti    : 62
RxBroad    : 19
RxAlignErr : 0
RxCRC      : 0
RxUnderSize: 0
RxFragment : 0
RxOverSize : 0
RxJabber   : 0
RxPause    : 0
Rx64Byte   : 59
Rx65Byte   : 18479
Rx128Byte  : 11570
Rx256Byte  : 187
Rx512Byte  : 105
Rx1024Byte : 43
RxByte     : 3069063
RxCtrlDrop : 0
RxIngDrop  : 0
RxARLDrop  : 0

	pvid: 1
	link: port:4 link:up speed:100baseT full-duplex 
Port 5:
	mib: Port 5 MIB counters
TxDrop     : 0
TxCRC      : 0
TxUni      : 0
TxMulti    : 0
TxBroad    : 0
TxCollision: 0
TxSingleCol: 0
TxMultiCol : 0
TxDefer    : 0
TxLateCol  : 0
TxExcCol   : 0
TxPause    : 0
Tx64Byte   : 0
Tx65Byte   : 0
Tx128Byte  : 0
Tx256Byte  : 0
Tx512Byte  : 0
Tx1024Byte : 0
TxByte     : 0
RxDrop     : 0
RxFiltered : 0
RxUni      : 0
RxMulti    : 0
RxBroad    : 0
RxAlignErr : 0
RxCRC      : 0
RxUnderSize: 0
RxFragment : 0
RxOverSize : 0
RxJabber   : 0
RxPause    : 0
Rx64Byte   : 0
Rx65Byte   : 0
Rx128Byte  : 0
Rx256Byte  : 0
Rx512Byte  : 0
Rx1024Byte : 0
RxByte     : 0
RxCtrlDrop : 0
RxIngDrop  : 0
RxARLDrop  : 0

	pvid: 0
	link: port:5 link:down
Port 6:
	mib: Port 6 MIB counters
TxDrop     : 0
TxCRC      : 0
TxUni      : 187905
TxMulti    : 4565
TxBroad    : 395
TxCollision: 0
TxSingleCol: 0
TxMultiCol : 0
TxDefer    : 0
TxLateCol  : 0
TxExcCol   : 0
TxPause    : 2
Tx64Byte   : 1851
Tx65Byte   : 82101
Tx128Byte  : 61450
Tx256Byte  : 7390
Tx512Byte  : 2317
Tx1024Byte : 37758
TxByte     : 76389996
RxDrop     : 0
RxFiltered : 140
RxUni      : 186053
RxMulti    : 429
RxBroad    : 393
RxAlignErr : 0
RxCRC      : 0
RxUnderSize: 0
RxFragment : 0
RxOverSize : 0
RxJabber   : 0
RxPause    : 141
Rx64Byte   : 4338
Rx65Byte   : 88660
Rx128Byte  : 59647
Rx256Byte  : 2294
Rx512Byte  : 1904
Rx1024Byte : 30173
RxByte     : 63679161
RxCtrlDrop : 0
RxIngDrop  : 0
RxARLDrop  : 0

	pvid: 0
	link: port:6 link:up speed:1000baseT full-duplex 
Port 7:
	mib: Port 7 MIB counters
TxDrop     : 0
TxCRC      : 0
TxUni      : 0
TxMulti    : 0
TxBroad    : 0
TxCollision: 0
TxSingleCol: 0
TxMultiCol : 0
TxDefer    : 0
TxLateCol  : 0
TxExcCol   : 0
TxPause    : 0
Tx64Byte   : 0
Tx65Byte   : 0
Tx128Byte  : 0
Tx256Byte  : 0
Tx512Byte  : 0
Tx1024Byte : 0
TxByte     : 0
RxDrop     : 0
RxFiltered : 0
RxUni      : 0
RxMulti    : 0
RxBroad    : 0
RxAlignErr : 0
RxCRC      : 0
RxUnderSize: 0
RxFragment : 0
RxOverSize : 0
RxJabber   : 0
RxPause    : 0
Rx64Byte   : 0
Rx65Byte   : 0
Rx128Byte  : 0
Rx256Byte  : 0
Rx512Byte  : 0
Rx1024Byte : 0
RxByte     : 0
RxCtrlDrop : 0
RxIngDrop  : 0
RxARLDrop  : 0

	pvid: 0
	link: port:7 link:down
VLAN 1:
	vid: 0
	ports: 1 3 4 6t 
VLAN 2:
	vid: 0
	ports: 6t 
VLAN 4:
	vid: 0
	ports: 0t 6t 
VLAN 6:
	vid: 0
	ports: 0t 6t 
VLAN 8:
	vid: 0
	ports: 2 6t

Maybe this is also useful information, the setup of my switch in the nonfunctional state:

Thanks; can you provide me with the corresponding /etc/config/network as well?

root@LEDE:~# cat /etc/config/network 

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd76:7412:3e5b::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option igmp_snooping '1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option broadcast '192.168.1.255'

config interface 'wan'
	option _orig_ifname 'eth0.2'
	option _orig_bridge 'false'
	option proto 'pppoe'
	option ifname 'eth0.6'
	option username 'SomeUserName'
	option password 'SomePassword'
	option ipv6 'auto'

config interface 'iptv'
	option proto 'dhcp'
	option ifname 'eth0.4'
	option classlessroute '1'
	option vendorid 'IPTV_RG'
	option defaultroute '0'
	option peerdns '0'
	option gateway '0'

config interface 'GuestLan'
	option type 'bridge'
	option igmp_snooping '1'
	option proto 'static'
	option ifname 'eth0.2'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '1 3 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option ports '6t'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '3'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option vid '4'
	option ports '0t 6t'

config switch_vlan
	option device 'switch0'
	option vlan '5'
	option vid '5'

config switch_vlan
	option device 'switch0'
	option vlan '6'
	option vid '6'
	option ports '0t 6t'

config interface 'vpn0'
	option ifname 'tun0'
	option proto 'none'
	option auto '1'

config switch_vlan
	option device 'switch0'
	option vlan '7'
	option ports '2 6t'
	option vid '8'

config interface 'testinterface'
	option proto 'static'
	option ipaddr '192.168.200.1'
	option netmask '255.255.255.0'
	option ifname 'eth0.8'

Despite the failure I think we're half-way there :slight_smile: The port memberships appear to be programmed correctly, just the PVID is not yet correctly set.

To confirm this suspicion, can you reproduce the broken state, but change LAN 3 from untagged to tagged and test if you then get connectivity when using tagged packets on the wire?

Great to hear that we're half-way there, awesome job :slight_smile: I do not fully understand what to test, however.

VLAN 3 is currently my dummy variable, and set to all off. Hence, there is no switching from untagged to tagged, only from off to tagged. Is that what you mean?

Or did you mean switching VLAN 8, which the testinterface is using (Did you mean this with Lan 3?) from untagged to tagged on port 3?

Yes, I mean switching LAN 3 of VLAN 8 from untagged to tagged, then perform a ping test from a wired client hooked to it.

On a Linux laptop you could use something like this to test:

ip link add link eth0 name eth0.8 type vlan id 8
ifconfig eth0 0.0.0.0
ifconfig eth0.8 192.168.200.2/24 up
ping 192.168.200.1

We're definitely on the right track, great job! :slight_smile:

jaap@Ubuntu-Laptop:~$ sudo ip link add link enp2s0 name eth0.8 type vlan id 8
[sudo] password for jaap: 
jaap@Ubuntu-Laptop:~$ sudo ifconfig enp2s0 0.0.0.0
jaap@Ubuntu-Laptop:~$ sudo ifconfig eth0.8 192.168.200.2/24 up
jaap@Ubuntu-Laptop:~$ ping 192.168.200.1
PING 192.168.200.1 (192.168.200.1) 56(84) bytes of data.
64 bytes from 192.168.200.1: icmp_seq=1 ttl=64 time=0.562 ms
64 bytes from 192.168.200.1: icmp_seq=2 ttl=64 time=0.326 ms
64 bytes from 192.168.200.1: icmp_seq=3 ttl=64 time=0.304 ms

I pushed another change which should fix the pvid problem: https://git.openwrt.org/?p=openwrt/staging/jow.git;a=commitdiff;h=268ebc84fc0c7f847a26a71c5641f33b01dc976a

1 Like

Perfect. I will compile a new build and report back once it is done. Thank you very much again :slight_smile:

Splendid! It is working now :slight_smile: Really good job, thank you very much :slight_smile:

Is there any output that you would like to double-check / verify?

One thing that I did notice (both in this version and the previous one) is that IPv6 connectivity is no longer working. I am not sure whether this is related, because my internet does come in as a tagged VLAN on the WAN port:

  1. ifconfig does properly show an IPv6 address associated with the WAN interface
  2. My LAN and GuestLAN interfaces do have an IPv6 address, the testinterface does not (which is expected, since I didn't enable IPv6 DHCP on that interface.
  3. However, LUCI overview shows: IPv6 WAN Status - Not connected
  4. My clients on the LAN network are not getting an IPv6 address.
  5. Googling "what is my ip" now shows my IPv4 address instead of the IPv6 address normally shown.

Maybe this has something to do with the testinterface that I've added to the config on VLAN 8, but it shouldn't, right? Or maybe it is something else in the Master branch causing it, because I came from the Lede 17.01.4 branch before trying out your commits. Maybe I am rambling a bit, just thought it might be useful information to add :slight_smile:

Great to hear! I think your IPv6 connectivity issues are unrelated to the switch fixes, but it wouldn't hurt to take nother look at ifstatus wan, ifstatus wan6, istatus lan as well as your current /etc/config/network and swconfig dev switch0 show output.

ifstatus wan:

root@LEDE:~# ifstatus wan
{
	"up": true,
	"pending": false,
	"available": true,
	"autostart": true,
	"dynamic": false,
	"uptime": 2056,
	"l3_device": "pppoe-wan",
	"proto": "pppoe",
	"device": "eth0.6",
	"updated": [
		"addresses"
	],
	"metric": 0,
	"dns_metric": 0,
	"delegation": true,
	"ipv4-address": [
		{
			"address": "86.88.184.57",
			"mask": 32,
			"ptpaddress": "195.190.228.161"
		}
	],
	"ipv6-address": [
		{
			"address": "fe80::8c74:f9f9:f42b:40a3",
			"mask": 128
		}
	],
	"ipv6-prefix": [
		
	],
	"ipv6-prefix-assignment": [
		
	],
	"route": [
		{
			"target": "0.0.0.0",
			"mask": 0,
			"nexthop": "195.190.228.161",
			"source": "0.0.0.0\/0"
		}
	],
	"dns-server": [
		"195.121.1.34",
		"195.121.1.66"
	],
	"dns-search": [
		
	],
	"inactive": {
		"ipv4-address": [
			
		],
		"ipv6-address": [
			
		],
		"route": [
			
		],
		"dns-server": [
			
		],
		"dns-search": [
			
		]
	},
	"data": {
		
	}
}

ifstatus wan6 is not available, since I don't have a separate wan6 interface. The WAN interface is a PPPoE connection over VLAN 6 to connect to the ISP. It was like that on 17.01.4 as well, and the WAN interface got both a IPv4 and IPv6 address, like the above snippet correctly seems to show.

ifstatus lan:

root@LEDE:~# ifstatus lan
{
	"up": true,
	"pending": false,
	"available": true,
	"autostart": true,
	"dynamic": false,
	"uptime": 2332,
	"l3_device": "br-lan",
	"proto": "static",
	"device": "br-lan",
	"updated": [
		"addresses"
	],
	"metric": 0,
	"dns_metric": 0,
	"delegation": true,
	"ipv4-address": [
		{
			"address": "192.168.1.1",
			"mask": 24
		}
	],
	"ipv6-address": [
		
	],
	"ipv6-prefix": [
		
	],
	"ipv6-prefix-assignment": [
		{
			"address": "fd76:7412:3e5b:10::",
			"mask": 60,
			"local-address": {
				"address": "fd76:7412:3e5b:10::1",
				"mask": 64
			}
		}
	],
	"route": [
		
	],
	"dns-server": [
		
	],
	"dns-search": [
		
	],
	"inactive": {
		"ipv4-address": [
			
		],
		"ipv6-address": [
			
		],
		"route": [
			
		],
		"dns-server": [
			
		],
		"dns-search": [
			
		]
	},
	"data": {
		
	}
}

cat /etc/config/network:

root@LEDE:~# cat /etc/config/network 

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd76:7412:3e5b::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option igmp_snooping '1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option broadcast '192.168.1.255'

config interface 'wan'
	option _orig_ifname 'eth0.2'
	option _orig_bridge 'false'
	option proto 'pppoe'
	option ifname 'eth0.6'
	option username 'SomeUserName'
	option password 'SomePassword'
	option ipv6 'auto'

config interface 'iptv'
	option proto 'dhcp'
	option ifname 'eth0.4'
	option classlessroute '1'
	option vendorid 'IPTV_RG'
	option defaultroute '0'
	option peerdns '0'
	option gateway '0'

config interface 'GuestLan'
	option type 'bridge'
	option igmp_snooping '1'
	option proto 'static'
	option ifname 'eth0.2'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '1 3 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option ports '6t'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '3'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option vid '4'
	option ports '0t 6t'

config switch_vlan
	option device 'switch0'
	option vlan '5'
	option vid '5'

config switch_vlan
	option device 'switch0'
	option vlan '6'
	option vid '6'
	option ports '0t 6t'

config interface 'vpn0'
	option ifname 'tun0'
	option proto 'none'
	option auto '1'

config switch_vlan
	option device 'switch0'
	option vlan '7'
	option vid '8'
	option ports '2 6t'

config interface 'testinterface'
	option proto 'static'
	option ipaddr '192.168.200.1'
	option netmask '255.255.255.0'
	option ifname 'eth0.8'

dev switch0 show:

root@LEDE:~# swconfig dev switch0 show
Global attributes:
	enable_vlan: 1
	mib: Switch MIB counters
PPE_AC_BCNT0: 0
PPE_AC_PCNT0: 0
PPE_AC_BCNT63: 0
PPE_AC_PCNT63: 0
PPE_MTR_CNT0: 0
PPE_MTR_CNT63: 0
GDM1_TX_GBCNT: 0
GDM1_TX_GPCNT: 0
GDM1_TX_SKIPCNT: 0
GDM1_TX_COLCNT: 0
GDM1_RX_GBCNT1: 0
GDM1_RX_GPCNT1: 0
GDM1_RX_OERCNT: 0
GDM1_RX_FERCNT: 0
GDM1_RX_SERCNT: 0
GDM1_RX_LERCNT: 0
GDM1_RX_CERCNT: 0
GDM1_RX_FCCNT: 0
GDM2_TX_GBCNT: 0
GDM2_TX_GPCNT: 0
GDM2_TX_SKIPCNT: 0
GDM2_TX_COLCNT: 0
GDM2_RX_GBCNT: 0
GDM2_RX_GPCNT: 0
GDM2_RX_OERCNT: 0
GDM2_RX_FERCNT: 0
GDM2_RX_SERCNT: 0
GDM2_RX_LERCNT: 0
GDM2_RX_CERCNT: 0
GDM2_RX_FCCNT: 0

Port 0:
	mib: Port 0 MIB counters
TxDrop     : 0
TxCRC      : 0
TxUni      : 2374659
TxMulti    : 40
TxBroad    : 5
TxCollision: 0
TxSingleCol: 0
TxMultiCol : 0
TxDefer    : 0
TxLateCol  : 0
TxExcCol   : 0
TxPause    : 0
Tx64Byte   : 2674
Tx65Byte   : 725180
Tx128Byte  : 38296
Tx256Byte  : 8030
Tx512Byte  : 9456
Tx1024Byte : 1591068
TxByte     : 2479737025
RxDrop     : 11672
RxFiltered : 7
RxUni      : 3047639
RxMulti    : 12779
RxBroad    : 0
RxAlignErr : 0
RxCRC      : 0
RxUnderSize: 0
RxFragment : 0
RxOverSize : 0
RxJabber   : 0
RxPause    : 0
Rx64Byte   : 2623
Rx65Byte   : 844499
Rx128Byte  : 120627
Rx256Byte  : 18586
Rx512Byte  : 6079
Rx1024Byte : 2068004
RxByte     : 3229663545
RxCtrlDrop : 0
RxIngDrop  : 11672
RxARLDrop  : 0

	pvid: 0
	link: port:0 link:up speed:1000baseT full-duplex 
Port 1:
	mib: Port 1 MIB counters
TxDrop     : 0
TxCRC      : 0
TxUni      : 1320741
TxMulti    : 13849
TxBroad    : 789
TxCollision: 0
TxSingleCol: 0
TxMultiCol : 0
TxDefer    : 0
TxLateCol  : 0
TxExcCol   : 0
TxPause    : 61
Tx64Byte   : 410
Tx65Byte   : 4980
Tx128Byte  : 64484
Tx256Byte  : 12398
Tx512Byte  : 2191
Tx1024Byte : 1250977
TxByte     : 1905528017
RxDrop     : 0
RxFiltered : 0
RxUni      : 350351
RxMulti    : 5440
RxBroad    : 18
RxAlignErr : 0
RxCRC      : 0
RxUnderSize: 0
RxFragment : 0
RxOverSize : 0
RxJabber   : 0
RxPause    : 0
Rx64Byte   : 245
Rx65Byte   : 345514
Rx128Byte  : 30
Rx256Byte  : 9071
Rx512Byte  : 107
Rx1024Byte : 842
RxByte     : 29844480
RxCtrlDrop : 0
RxIngDrop  : 0
RxARLDrop  : 0

	pvid: 1
	link: port:1 link:up speed:100baseT full-duplex 
Port 2:
	mib: Port 2 MIB counters
TxDrop     : 0
TxCRC      : 0
TxUni      : 935062
TxMulti    : 0
TxBroad    : 38
TxCollision: 0
TxSingleCol: 0
TxMultiCol : 0
TxDefer    : 0
TxLateCol  : 0
TxExcCol   : 0
TxPause    : 690
Tx64Byte   : 365455
Tx65Byte   : 81103
Tx128Byte  : 601
Tx256Byte  : 536
Tx512Byte  : 810
Tx1024Byte : 487285
TxByte     : 760180267
RxDrop     : 0
RxFiltered : 0
RxUni      : 1036894
RxMulti    : 290
RxBroad    : 252
RxAlignErr : 0
RxCRC      : 0
RxUnderSize: 0
RxFragment : 0
RxOverSize : 0
RxJabber   : 0
RxPause    : 0
Rx64Byte   : 128014
Rx65Byte   : 35051
Rx128Byte  : 1489
Rx256Byte  : 2536
Rx512Byte  : 6460
Rx1024Byte : 863886
RxByte     : 1308800683
RxCtrlDrop : 0
RxIngDrop  : 0
RxARLDrop  : 0

	pvid: 8
	link: port:2 link:up speed:1000baseT full-duplex 
Port 3:
	mib: Port 3 MIB counters
TxDrop     : 0
TxCRC      : 0
TxUni      : 41947
TxMulti    : 19250
TxBroad    : 793
TxCollision: 0
TxSingleCol: 0
TxMultiCol : 0
TxDefer    : 0
TxLateCol  : 0
TxExcCol   : 0
TxPause    : 6
Tx64Byte   : 335
Tx65Byte   : 19221
Tx128Byte  : 23703
Tx256Byte  : 17304
Tx512Byte  : 260
Tx1024Byte : 1173
TxByte     : 13745658
RxDrop     : 0
RxFiltered : 13
RxUni      : 42576
RxMulti    : 64
RxBroad    : 20
RxAlignErr : 0
RxCRC      : 0
RxUnderSize: 0
RxFragment : 0
RxOverSize : 0
RxJabber   : 0
RxPause    : 0
Rx64Byte   : 88
Rx65Byte   : 24083
Rx128Byte  : 18065
Rx256Byte  : 251
Rx512Byte  : 121
Rx1024Byte : 52
RxByte     : 4391535
RxCtrlDrop : 0
RxIngDrop  : 0
RxARLDrop  : 0

	pvid: 1
	link: port:3 link:up speed:100baseT full-duplex 
Port 4:
	mib: Port 4 MIB counters
TxDrop     : 0
TxCRC      : 0
TxUni      : 40118
TxMulti    : 19244
TxBroad    : 785
TxCollision: 0
TxSingleCol: 0
TxMultiCol : 0
TxDefer    : 0
TxLateCol  : 0
TxExcCol   : 0
TxPause    : 4
Tx64Byte   : 326
Tx65Byte   : 17170
Tx128Byte  : 23987
Tx256Byte  : 17292
Tx512Byte  : 227
Tx1024Byte : 1149
TxByte     : 13584950
RxDrop     : 0
RxFiltered : 1
RxUni      : 40706
RxMulti    : 70
RxBroad    : 34
RxAlignErr : 0
RxCRC      : 0
RxUnderSize: 0
RxFragment : 0
RxOverSize : 0
RxJabber   : 0
RxPause    : 0
Rx64Byte   : 104
Rx65Byte   : 24310
Rx128Byte  : 15969
Rx256Byte  : 214
Rx512Byte  : 161
Rx1024Byte : 52
RxByte     : 4123599
RxCtrlDrop : 0
RxIngDrop  : 0
RxARLDrop  : 0

	pvid: 1
	link: port:4 link:up speed:100baseT full-duplex 
Port 5:
	mib: Port 5 MIB counters
TxDrop     : 0
TxCRC      : 0
TxUni      : 0
TxMulti    : 0
TxBroad    : 0
TxCollision: 0
TxSingleCol: 0
TxMultiCol : 0
TxDefer    : 0
TxLateCol  : 0
TxExcCol   : 0
TxPause    : 0
Tx64Byte   : 0
Tx65Byte   : 0
Tx128Byte  : 0
Tx256Byte  : 0
Tx512Byte  : 0
Tx1024Byte : 0
TxByte     : 0
RxDrop     : 0
RxFiltered : 0
RxUni      : 0
RxMulti    : 0
RxBroad    : 0
RxAlignErr : 0
RxCRC      : 0
RxUnderSize: 0
RxFragment : 0
RxOverSize : 0
RxJabber   : 0
RxPause    : 0
Rx64Byte   : 0
Rx65Byte   : 0
Rx128Byte  : 0
Rx256Byte  : 0
Rx512Byte  : 0
Rx1024Byte : 0
RxByte     : 0
RxCtrlDrop : 0
RxIngDrop  : 0
RxARLDrop  : 0

	pvid: 0
	link: port:5 link:down
Port 6:
	mib: Port 6 MIB counters
TxDrop     : 0
TxCRC      : 0
TxUni      : 4506494
TxMulti    : 18624
TxBroad    : 322
TxCollision: 0
TxSingleCol: 0
TxMultiCol : 0
TxDefer    : 0
TxLateCol  : 0
TxExcCol   : 0
TxPause    : 20506
Tx64Byte   : 23149
Tx65Byte   : 1399190
Tx128Byte  : 155900
Tx256Byte  : 30861
Tx512Byte  : 12915
Tx1024Byte : 2923931
TxByte     : 4570303624
RxDrop     : 0
RxFiltered : 65
RxUni      : 4712527
RxMulti    : 13847
RxBroad    : 821
RxAlignErr : 0
RxCRC      : 0
RxUnderSize: 0
RxFragment : 0
RxOverSize : 0
RxJabber   : 0
RxPause    : 5463
Rx64Byte   : 373382
Rx65Byte   : 846313
Rx128Byte  : 148929
Rx256Byte  : 21354
Rx512Byte  : 12953
Rx1024Byte : 3329727
RxByte     : 5163590213
RxCtrlDrop : 0
RxIngDrop  : 0
RxARLDrop  : 0

	pvid: 0
	link: port:6 link:up speed:1000baseT full-duplex 
Port 7:
	mib: Port 7 MIB counters
TxDrop     : 0
TxCRC      : 0
TxUni      : 0
TxMulti    : 0
TxBroad    : 0
TxCollision: 0
TxSingleCol: 0
TxMultiCol : 0
TxDefer    : 0
TxLateCol  : 0
TxExcCol   : 0
TxPause    : 0
Tx64Byte   : 0
Tx65Byte   : 0
Tx128Byte  : 0
Tx256Byte  : 0
Tx512Byte  : 0
Tx1024Byte : 0
TxByte     : 0
RxDrop     : 0
RxFiltered : 0
RxUni      : 0
RxMulti    : 0
RxBroad    : 0
RxAlignErr : 0
RxCRC      : 0
RxUnderSize: 0
RxFragment : 0
RxOverSize : 0
RxJabber   : 0
RxPause    : 0
Rx64Byte   : 0
Rx65Byte   : 0
Rx128Byte  : 0
Rx256Byte  : 0
Rx512Byte  : 0
Rx1024Byte : 0
RxByte     : 0
RxCtrlDrop : 0
RxIngDrop  : 0
RxARLDrop  : 0

	pvid: 0
	link: port:7 link:down
VLAN 1:
	vid: 0
	ports: 1 3 4 6t 
VLAN 2:
	vid: 0
	ports: 6t 
VLAN 4:
	vid: 0
	ports: 0t 6t 
VLAN 6:
	vid: 0
	ports: 0t 6t 
VLAN 8:
	vid: 0
	ports: 2 6t

Edit: "On MT7621, the REG_ESW_VLAN_VTIM reads are undefined, causing swconfig
to always report vid: 0 in swconfig show output."

This still seems to be the case in the above output. It seems to be just a cosmetic issue, rather than a functional one. But that means that the following commit isn't correct at the moment, correct?: https://git.openwrt.org/?p=openwrt/staging/jow.git;a=commit;h=20c9582f00276e52e4b063ad7df16be193025229