Problem with VLAN and DHCP

Hi,
I have MikroTik RouterBOARD 750Gr3 with OpenWrt 24.10.0. I also Asus DSL modem and Huawei GPON. My end goal is too use a vlan trunk for transferring data of this modems using single cable. My configuration is:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdd0:3e80:128e::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan2'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

config device
        option type 'bridge'
        option name 'sw-br'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'lan5'

config interface 'test'
        option proto 'none'
        option device 'sw-br'

config bridge-vlan
        option device 'sw-br'
        option vlan '3'
        option local '0'
        list ports 'lan3'
        list ports 'lan5:t'

config bridge-vlan
        option device 'sw-br'
        option vlan '4'
        option local '0'
        list ports 'lan3'
        list ports 'lan5:t'

I have connect DSL to lan3 and GPON to lan4. I have no problem for accessing DSL modem on lan5 with tagged vlan 3, But in case of GPON, it seems that DHCP service won't assign any ip, But when I connect my device directly to GPON my device will receive ip. Is there any config that I have to do in regards of DHCP? Or the problem is related to GPON?

Any help would be appreciated

GPON is on lan4 (not lan3)

I've changed it, and also set primary vlan, now it's working. I don't know why DSL was working without primary VLAN

My config is:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdd0:3e80:128e::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan2'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

config device
        option type 'bridge'
        option name 'sw-br'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'lan5'

config interface 'test'
        option proto 'none'
        option device 'sw-br'

config bridge-vlan
        option device 'sw-br'
        option vlan '3'
        option local '0'
        list ports 'lan3:u*'
        list ports 'lan5:t'

config bridge-vlan
        option device 'sw-br'
        option vlan '4'
        option local '0'
        list ports 'lan4:u*'
        list ports 'lan5:t'

Put all the ports back into a single bridge. From there, you can setup the bridge vlans accordingly to separate the traffic.

Do you need help achieving this?

Thanks, I've fixed it. I want br-lan have its dhcp enabled, That's why I've made different bridge.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.