Problem with video streaming services and IPv6

Did you do anything special or it simply started working without a problem?
My solution at the moment is disabling ipv6 from the wan interface and relay on the ipv4 and it seems to work a lot better.

I didn't touch anything. Before it started failing after some uptime. Now it has not failed after some weeks of uptime. I don't know if it will fail again or when.

Seems like my case, sometimes it goes like 3 weeks without issue and then my wan interface fails and I lose my ip in the ppoe with the error user_request (or something like that). Let me know if you have problems again.

@daniarla if I speak before... it has happen again.

@trendy here is the information you asked for, I have redacted a lot of things but I'm not too sure if I have forgotten something:

{
        "kernel": "5.15.105",
        "hostname": "router-comedor",
        "system": "ARMv8 Processor rev 4",
        "model": "Xiaomi AX3600",
        "board_name": "xiaomi,ax3600",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "SNAPSHOT",
                "revision": "r22528-0c53801968",
                "target": "ipq807x/generic",
                "description": "OpenWrt SNAPSHOT r22528-0c53801968"
        }
}
package network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd94:d4d1:*::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.100.1'
        option ip6assign '60'
        option ip6ifaceid '::1'
        option ip6hint '00'

config interface 'wan'
        option device 'wan.20'
        option proto 'pppoe'
        option username '****'
        option password '****'
        option peerdns '0'
        option ipv6 '0'
        list dns '127.0.0.1'

config interface 'wan6'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'
        option peerdns '0'
        option device 'pppoe-wan'
        list dns '::1'

config device
        option type '8021q'
        option ifname 'wan'
        option vid '20'
        option name 'wan.20'

config interface 'guest'
        option proto 'static'
        option netmask '255.255.255.0'
        option device 'br-inv'
        option ipaddr '192.168.101.1'
        list ip6class 'wan6'
        option ip6assign '60'
        option ip6hint '10'

config device 'guest_dev'
        option type 'bridge'
        option name 'br-inv'

config interface 'wireguard'
        option proto 'wireguard'
        option private_key '***************************'
        option listen_port '40106'
        option ip6assign '60'
        list addresses '192.168.102.1/24'
        list addresses 'fd94:d4d1:*:10::1/60'
        option ip6hint '20'

config wireguard_wireguard
        option description 'Pixel 4 Miguel'
        option public_key '******************************'
        option private_key '*********************************'
        option route_allowed_ips '1'
        option persistent_keepalive '25'
        list allowed_ips '192.168.102.2/32'

config wireguard_wireguard
        option public_key '************************'
        option private_key '****************************'
        option route_allowed_ips '1'
        option persistent_keepalive '25'
        option description 'Pixel 4 Miguel MyWire'
        list allowed_ips 'fd94:d4d1:*:10::2'
        list allowed_ips '192.168.102.2'

package dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option localservice '1'
        option ednspacket_max '1232'
        option local '/piminet/'
        option domain 'piminet'
        list rebind_domain 'piminet'
        list server '127.0.0.1#5054'
        list server '127.0.0.1#5053'
        option doh_backup_noresolv '-1'
        option noresolv '1'
        list doh_backup_server '8.8.8.8'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option leasetime '12h'
        option dhcpv4 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option dhcpv6 'server'
        option limit '100'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config host
	[a lot of static ip configurations]

config dhcp 'guest'
        option interface 'guest'
        option leasetime '1h'
        option start '100'
        option limit '100'
        option ra 'server'
        option dhcpv6 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

package firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'
        option flow_offloading '1'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        list network 'lan'
        option forward 'ACCEPT'

config zone
        option name 'guest'
        option forward 'REJECT'
        option input 'REJECT'
        list network 'guest'
        option output 'ACCEPT'

config zone
        option name 'wireguard'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        list network 'wireguard'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'
        list network 'wan6'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'Interceptar-DNS'
        list proto 'udp'
        option src 'lan'
        option src_dport '53'
        option dest_port '53'
        option dest_ip '192.168.100.1'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'Home Assistant'
        list proto 'tcp'
        option src 'wan'
        option src_dport '443'
        option dest_ip '192.168.100.5'
        option dest_port '443'

config forwarding
        option src 'guest'
        option dest 'wan'

config rule
        option name 'Guest-DNS'
        option src 'guest'
        option target 'ACCEPT'
        option dest_port '53'

config rule
        option name 'Guest-DHCP'
        option src 'guest'
        option target 'ACCEPT'
        list proto 'udp'
        option dest_port '67'
        option family 'ipv4'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'Acestream'
        option src 'wan'
        option src_dport '8621'
        option dest_ip '192.168.100.55'
        option dest_port '8621'

config forwarding
        option src 'wireguard'
        option dest 'lan'

config forwarding
        option src 'wireguard'
        option dest 'wan'

config redirect
        option dest 'wireguard'
        option target 'DNAT'
        option name 'Wireguard'
        list proto 'udp'
        option src 'wan'
        option src_dport '40106'
        option dest_port '40106'
        option dest_ip '192.168.102.1'

config rule
        option name 'Guest-DHCPv6'
        option family 'ipv6'
        list proto 'udp'
        option src 'guest'
        option dest_port '547'
        option target 'ACCEPT'

config rule
        option name 'HomeAssistant-IPv6'
        option family 'ipv6'
        list proto 'tcp'
        option src 'wan'
        list dest_ip '::*/-64'
        option dest_port '443'
        option target 'ACCEPT'
        option dest 'lan'

config rule
        option name 'Wireguard-IPv6'
        list proto 'udp'
        option src 'wan'
        option dest 'wireguard'
        option target 'ACCEPT'
        option family 'ipv6'
        option dest_port '40106'
        list dest_ip '::*/-72'

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
12: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.100.1/24 brd 192.168.100.255 scope global br-lan
       valid_lft forever preferred_lft forever
14: br-inv: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.101.1/24 brd 192.168.101.255 scope global br-inv
       valid_lft forever preferred_lft forever
16: wireguard: <POINTOPOINT,NOARP,UP,LOWER_UP> mtu 1420 qdisc noqueue state UNKNOWN qlen 1000
    inet 192.168.102.1/24 brd 192.168.102.255 scope global wireguard
       valid_lft forever preferred_lft forever
26: pppoe-wan: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 qdisc fq_codel state UNKNOWN qlen 3
    inet 79.116.13.40 peer 10.0.0.1/32 scope global pppoe-wan
       valid_lft forever preferred_lft forever
default via 10.0.0.1 dev pppoe-wan
10.0.0.1 dev pppoe-wan scope link  src 79.116.13.40
192.168.100.0/24 dev br-lan scope link  src 192.168.100.1
192.168.101.0/24 dev br-inv scope link  src 192.168.101.1
192.168.102.0/24 dev wireguard scope link  src 192.168.102.1
192.168.102.2 dev wireguard scope link
local 79.116.13.40 dev pppoe-wan table local scope host  src 79.116.13.40
local 127.0.0.0/8 dev lo table local scope host  src 127.0.0.1
local 127.0.0.1 dev lo table local scope host  src 127.0.0.1
broadcast 127.255.255.255 dev lo table local scope link  src 127.0.0.1
local 192.168.100.1 dev br-lan table local scope host  src 192.168.100.1
broadcast 192.168.100.255 dev br-lan table local scope link  src 192.168.100.1
local 192.168.101.1 dev br-inv table local scope host  src 192.168.101.1
broadcast 192.168.101.255 dev br-inv table local scope link  src 192.168.101.1
local 192.168.102.1 dev wireguard table local scope host  src 192.168.102.1
broadcast 192.168.102.255 dev wireguard table local scope link  src 192.168.102.1
0:      from all lookup local
32766:  from all lookup main
32767:  from all lookup default
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
3: wan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::2ad1:27ff:fe70:30f0/64 scope link
       valid_lft forever preferred_lft forever
12: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2a0c:5a80:1206:9500::1/60 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fd94:d4d1:*::1/60 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::2ad1:27ff:fe4c:52a0/64 scope link
       valid_lft forever preferred_lft forever
13: wan.20@wan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::2ad1:27ff:fe70:30f0/64 scope link
       valid_lft forever preferred_lft forever
14: br-inv: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2a0c:5a80:1206:9510::1/60 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::2cd1:27ff:fe4c:52a1/64 scope link
       valid_lft forever preferred_lft forever
16: wireguard: <POINTOPOINT,NOARP,UP,LOWER_UP> mtu 1420 state UNKNOWN qlen 1000
    inet6 2a0c:5a80:1206:9520::1/60 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fd94:d4d1:*:20::1/60 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fd94:d4d1:*:10::1/60 scope global
       valid_lft forever preferred_lft forever
19: mesh: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::2ad1:27ff:fe4c:52a1/64 scope link
       valid_lft forever preferred_lft forever
22: ifb4wan: <BROADCAST,NOARP,UP,LOWER_UP> mtu 1500 state UNKNOWN qlen 32
    inet6 fe80::58a6:e0ff:fe70:32cc/64 scope link
       valid_lft forever preferred_lft forever
23: wlan5g: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::28d1:27ff:fe4c:52a1/64 scope link
       valid_lft forever preferred_lft forever
25: wlan5g-inv: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::2cd1:27ff:fe4c:52a1/64 scope link
       valid_lft forever preferred_lft forever
26: pppoe-wan: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 state UNKNOWN qlen 3
    inet6 2a0c:5a80:12ff:ffff::4f74:d28/128 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::4f74:d28/128 scope link
       valid_lft forever preferred_lft forever
27: wlan24g: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::2ad1:27ff:fe4c:52a0/64 scope link
       valid_lft forever preferred_lft forever
28: wlan24g-inv: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::28d1:27ff:fe4c:52a0/64 scope link
       valid_lft forever preferred_lft forever
default from 2a0c:5a80:1206:9500::/56 via fe80::1 dev pppoe-wan  metric 512
default from 2a0c:5a80:12ff:ffff::4f74:d28 via fe80::1 dev pppoe-wan  metric 512
2a0c:5a80:1206:9500::/64 dev br-lan  metric 1024
2a0c:5a80:1206:9510::/64 dev br-inv  metric 1024
2a0c:5a80:1206:9520::/64 dev wireguard  metric 1024
unreachable 2a0c:5a80:1206:9500::/56 dev lo  metric 2147483647
fd94:d4d1:*::/64 dev br-lan  metric 1024
fd94:d4d1:*:10::2 dev wireguard  metric 1024
fd94:d4d1:*:10::/60 dev wireguard  metric 256
fd94:d4d1:*:20::/64 dev wireguard  metric 1024
unreachable fd94:d4d1:*::/48 dev lo  metric 2147483647
fe80::1 dev pppoe-wan  metric 256
fe80::4f74:d28 dev pppoe-wan  metric 256
fe80::/64 dev wan.20  metric 256
fe80::/64 dev br-lan  metric 256
fe80::/64 dev wan  metric 256
fe80::/64 dev ifb4wan  metric 256
fe80::/64 dev wlan5g  metric 256
fe80::/64 dev br-inv  metric 256
fe80::/64 dev wlan5g-inv  metric 256
fe80::/64 dev wlan24g  metric 256
fe80::/64 dev wlan24g-inv  metric 256
fe80::/64 dev mesh  metric 256
local ::1 dev lo table local  metric 0
anycast 2a0c:5a80:1206:9500:: dev br-lan table local  metric 0
local 2a0c:5a80:1206:9500::1 dev br-lan table local  metric 0
anycast 2a0c:5a80:1206:9510:: dev br-inv table local  metric 0
local 2a0c:5a80:1206:9510::1 dev br-inv table local  metric 0
anycast 2a0c:5a80:1206:9520:: dev wireguard table local  metric 0
local 2a0c:5a80:1206:9520::1 dev wireguard table local  metric 0
local 2a0c:5a80:12ff:ffff::4f74:d28 dev pppoe-wan table local  metric 0
anycast fd94:d4d1:*:: dev br-lan table local  metric 0
local fd94:d4d1:*::1 dev br-lan table local  metric 0
anycast fd94:d4d1:*:10:: dev wireguard table local  metric 0
local fd94:d4d1:*:10::1 dev wireguard table local  metric 0
anycast fd94:d4d1:*:20:: dev wireguard table local  metric 0
local fd94:d4d1:*:20::1 dev wireguard table local  metric 0
anycast fe80:: dev ifb4wan table local  metric 0
anycast fe80:: dev wan.20 table local  metric 0
anycast fe80:: dev wan table local  metric 0
anycast fe80:: dev br-lan table local  metric 0
anycast fe80:: dev br-inv table local  metric 0
anycast fe80:: dev wlan5g table local  metric 0
anycast fe80:: dev wlan5g-inv table local  metric 0
anycast fe80:: dev wlan24g table local  metric 0
anycast fe80:: dev wlan24g-inv table local  metric 0
anycast fe80:: dev mesh table local  metric 0
local fe80::4f74:d28 dev pppoe-wan table local  metric 0
local fe80::28d1:27ff:fe4c:52a0 dev wlan24g-inv table local  metric 0
local fe80::28d1:27ff:fe4c:52a1 dev wlan5g table local  metric 0
local fe80::2ad1:27ff:fe4c:52a0 dev br-lan table local  metric 0
local fe80::2ad1:27ff:fe4c:52a0 dev wlan24g table local  metric 0
local fe80::2ad1:27ff:fe4c:52a1 dev mesh table local  metric 0
local fe80::2ad1:27ff:fe70:30f0 dev wan.20 table local  metric 0
local fe80::2ad1:27ff:fe70:30f0 dev wan table local  metric 0
local fe80::2cd1:27ff:fe4c:52a1 dev br-inv table local  metric 0
local fe80::2cd1:27ff:fe4c:52a1 dev wlan5g-inv table local  metric 0
local fe80::58a6:e0ff:fe70:32cc dev ifb4wan table local  metric 0
multicast ff00::/8 dev br-lan table local  metric 256
multicast ff00::/8 dev wan.20 table local  metric 256
multicast ff00::/8 dev wireguard table local  metric 256
multicast ff00::/8 dev wan table local  metric 256
multicast ff00::/8 dev ifb4wan table local  metric 256
multicast ff00::/8 dev wlan5g table local  metric 256
multicast ff00::/8 dev br-inv table local  metric 256
multicast ff00::/8 dev wlan5g-inv table local  metric 256
multicast ff00::/8 dev wlan24g table local  metric 256
multicast ff00::/8 dev wlan24g-inv table local  metric 256
multicast ff00::/8 dev pppoe-wan table local  metric 256
multicast ff00::/8 dev mesh table local  metric 256
0:      from all lookup local
32766:  from all lookup main
4200000000:     from 2a0c:5a80:1206:9500::1/60 iif br-lan lookup unspec unreachable
4200000000:     from 2a0c:5a80:1206:9510::1/60 iif br-inv lookup unspec unreachable
4200000000:     from 2a0c:5a80:1206:9520::1/60 iif wireguard lookup unspec unreachable
lrwxrwxrwx    1 root     root            16 Apr  8 15:52 /etc/resolv.conf -> /tmp/resolv.conf
lrwxrwxrwx    1 root     root            35 Apr 28 00:00 /tmp/resolv.conf -> /tmp/resolv.conf.d/resolv.conf.auto
-rw-r--r--    1 root     root            69 Apr 28 00:00 /tmp/resolv.conf.d/resolv.conf.auto
-rw-r--r--    1 root     root            45 Apr 28 00:00 /tmp/resolv.conf.ppp

/tmp/resolv.conf.d:
-rw-r--r--    1 root     root            69 Apr 28 00:00 resolv.conf.auto
==> /etc/resolv.conf <==
# Interface wan
nameserver 127.0.0.1
# Interface wan6
nameserver ::1

==> /tmp/resolv.conf <==
# Interface wan
nameserver 127.0.0.1
# Interface wan6
nameserver ::1

==> /tmp/resolv.conf.d <==
head: /tmp/resolv.conf.d: I/O error

==> /tmp/resolv.conf.ppp <==
nameserver 100.100.1.1
nameserver 100.90.1.1

==> /tmp/resolv.conf.d/resolv.conf.auto <==
# Interface wan
nameserver 127.0.0.1
# Interface wan6
nameserver ::1

Snapshots are not stable versions.

Better use option device '@wan'

Remove the duplicate entry.

You don't need to specify the localhost as dns on the wan/6 interfaces. Only if you want to advertise a specific nameserver reachable from those interfaces.

I would disable this.

masquerade is not needed in wireguard zone.

Remove this from the wireguard interface.
Also post the configuration from the dns over https, should be uci export https-dns-proxy

1 Like

I have been testing my internet connection and it seems like the problem is 99% that the IPv6 stop working for some reason. I had the same problems that @McGiverGim and I decided to test and disable IPv6 from the wan and I have been having a rock solid connection (besides sometimes having the error in pppoe of unknown error (USER_REQUEST) but that is another problem.)

My problems where not in the streaming services because I don't use them but with a lot of apps and media in the different parts of a lot of webpages didn't load or would take upto 2 mins to do so.

At first it seems that the IPv6 works like it should but then it stops working with no error.

To give more details I only have 1 wan address and the IPv6 comes form the virtual dynamic interface IPv6 interface that OpenWRT creates automatically. IDK if that can be a problem.

How can I get the full logs (apart from looking in the system log in luci) to get the exact error and the issues in the wan interface. Where does the pppoe module log?

I know, but there are no stable version for Xiaomi AX3600.

Ok, I will change it, but I doubt this is the problem.

Ok.

Yes, I want that when I send commands in the router, it uses the DNS over HTTPS proxy.

This will make the router use more CPU, right?

I think I saw that at some tutorial. I will test without it. Thanks!

Yes, this was some testing for IPv6 under wireguard. I can remove it.

Here you have:

package https-dns-proxy

config main 'config'
        option dnsmasq_config_update '*'
        list force_dns_port '53'
        list force_dns_port '853'
        option procd_trigger_wan6 '0'
        option force_dns '0'

config https-dns-proxy
        option resolver_url 'https://cloudflare-dns.com/dns-query'
        option listen_addr '127.0.0.1'
        option listen_port '5054'
        option user 'nobody'
        option group 'nogroup'
        option bootstrap_dns '1.1.1.1,1.0.0.1,2606:4700:4700::1111,2606:4700:4700::1001'

config https-dns-proxy
        option resolver_url 'https://dns.google/dns-query'
        option listen_addr '127.0.0.1'
        option listen_port '5053'
        option user 'nobody'
        option group 'nogroup'
        option bootstrap_dns '8.8.8.8,8.8.4.4,2001:4860:4860::8888,2001:4860:4860::8844'

If it helps, when this happened the last time, I restarted the wan6 interface. The interface was not able to take a new IP (maybe this was expected) so remained with error, but the problem disappeared and all started to work again. Without touching anything more. So to me it seems something wrong between the wan6 interface and the ISP. When the wan6 interface is not working, all the traffic goes over the wan (IPv4) interface and woks.

It does help , because IPv6 has precedence over IPv4 when both are present. Not getting a new IPv6 when you restart wan6 sounds like a good culprit as the connection might be stale but the devices in the lan keep trying to use it. Better discuss your findings with your ISP.

2 Likes

I doubt my ISP has some idea of what is passing, they will ask to install his router to make the tests. As far as I know this does not happen with the ISPs router. But I will try, who knows.

1 Like