Problem with upgrading: no eth1 anymore

Hi,

I got the strong advice from Freifunk here in Wiesbaden/Germany to upgrade my configuration to the latest version of OpenWrt. But now I ran into problems. Can you please give me some tips.

My configuration:

  • a RaspBerry Pi 3 with an USB-LAN-adapter so that I have 2 LAN-connectors
  • a TP-Link wr1043N as a router.

The old software on the RasPi is version 17, but this version works fine. The new version is 22.03.

I made a backup of this SD-card (old), used another SD-card and put the old software on it. Also I stored a copy of the new software somewhere on the newly created card. Booting up the RasPi with the new card I did a sysupgrade. Rebooting and everything seemed to work. But:

  • now I get a lot of messages like: cannot set group dialout for /dev/tty....
  • I have no eth1 anymore.

I did not change the configuration, so I have the /etc/config/network-file as before.

What did I do wrong?

Thanks
AugustQ

PS: currently I'm playing with the RasPi + Router with LAN-cables. In the end it will be used with the router (connected to the RasPi by LAN-cable) plus the RasPi with an USB-LAN-converter. On this converter I will add an Huawei-LTE-stick for internet-connection.
As said before this worked fine here many times. And it works with the version 17.

There have been many changes in configuration options and syntax since version 17, so keeping configuration files is not recommended. Reconfigure the new install from scratch.

Drivers for a USB Ethernet adapter are not included in the builds, you will need to identify the chipset in the adapter and install the kmod separately. The same for LTE modems and any other additional packages.

2 Likes

thanks for your answer.

I will install the software from scratch, no upgrade.

Is there a description on the configuration? Can you please give me a link.

PS: I remember it took some time to configure this ....

Wouldn't you possess that?

Are you asking for a specific config tutorial?

If so, what kind?

my situation now is:
reinstalled the software, set names and key (for Freifunk), installed some packages.

The RasPi can send/receive data from the internet and it is also seen on the Freifunk-net.

Next step: add the router. So I inserted the USB-LAN-converter to the RasPi and connect the Router via a LAN-cable to the RasPi. But there is no eth1 now.

No messages via dmesg about eth1, no message on the console about eth1 entering xxx state,.....

What do I have to change in the network-file?

AugustQ

forgotten:
during the initial boot the USB-LAN-controller was present.

The on-board LAN on a RPi 3 is also a USB-LAN converter using I think a chip that was once Microchip. That driver is included in the build. If your external converter uses a different chip, you will need to install the driver for its chip.

Played with this in the last days and everything is working now.

After the initial installation I had to install these packages: kmod-usb2, usbutils, usb-modeswitch, wwan, nano, kmod-usb-net-dm9601-ether, kmod-usb-net-cdc-ether, kmod-usb-net-huawei-cdc-ncm.

Some are necessary, other only for comfort (like nano). But now everything works fine.

The problem was to do an upgrade from version 17 to version 22 of OpenWrt. In this case a fresh install is the best way to go.

Thanks
AugustQ

PS: one minor glitch: in the map of Freifunk here in Wiesbaden the RasPi appears as offline sometimes, but it is working. This depends on using eth0 (online) or eth1 (is shown offline) for the connection to the FF-net.