Problem with untagged/tagged port on different vlans with TL Archer C59

Hi all,

i'm using a TP-Link Archer C59 with lede installed on it.
What i need is to set up multiple vlans on a port, but when i try to do it i lose the default vlan configuration.


# Default static config
config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'


# Switching rules (vlan 14)
config switch_vlan
	option device 'switch0'
	option vlan '14'
	option ports '0t 1 2 3 4'

# Switching rules (vlan 15)
config switch_vlan             
        option device 'switch0'
        option vlan '15'   
        option ports '0t 1t'

And when i apply it and show switch0:

# swconfig dev switch0 show
Global attributes:
	enable_vlan: 1
Port 0:
	pvid: 0
	link: port:0 link:up speed:1000baseT full-duplex txflow rxflow 
Port 1:
	pvid: 14
	link: port:1 link:up speed:100baseT full-duplex auto


	vid: 0
	ports: 0t 
	vid: 1
	ports: 0t 
	vid: 2
	ports: 0t 
VLAN 14:
	vid: 14
	ports: 0t 1t 2 3 4 
VLAN 15:
	vid: 15
	ports: 0t 1t 

Without the "1t" on vlan 15 the link works well routing traffic on default vlan14, when i try to add port 1 as tagged to vlan15 my untagged traffic is dropped.

Question: why swconfig show the port #1 as tagged on vlan14? I need port #1 to be untagged on vlan 14 and tagged on vlan 15.
I tried to use the "switch_port" directive... same result.

Thanks for help

Another hint: same configuration on a tl wr1043nd is working well...

As far as I know, not all hardware / drivers have support for configuring tagged and untagged traffic on the same port.

I'm trying to verify your theory,

on the page there is "VLAN: yes"
but my needs is a little bit deeper i guess.

I saw too.
I tried:

# ls -l /sys/class/net
lrwxrwxrwx    1 root     root             0 Jan  1  1970 eth0 -> ../../devices/platform/ag71xx.0/net/eth0
lrwxrwxrwx    1 root     root             0 Jan  1  1970 eth1 -> ../../devices/platform/ag71xx.1/net/eth1
lrwxrwxrwx    1 root     root             0 Aug 17 09:07 eth1.12 -> ../../devices/virtual/net/eth1.12
lrwxrwxrwx    1 root     root             0 Aug 17 09:07 eth1.14 -> ../../devices/virtual/net/eth1.14
lrwxrwxrwx    1 root     root             0 Aug 17 09:07 eth1.15 -> ../../devices/virtual/net/eth1.15
lrwxrwxrwx    1 root     root             0 Jan  1  1970 lo -> ../../devices/virtual/net/lo

But i'm not understanding the output.

Do you know a way to see what hardware/driver supports?


According to LEDE documentation ([]=switch#assigning_vlan_ids_on_vlan-enabled_switch_hardware), "Once the port is marked as tagged, it cannot be listed anywhere else as untagged".

Ok, you're right. Another step:
I found a workaround just setting up the default vlan as tagged on VID 0.

It is working but it is a little bit tricky to configure...

Could you elaborate how you set 2 vlans on the same port? I am trying to do that on my WRT32X. I need a VLAN id for my AP that connect to the port to send guest into a separate vlan while keep main user to the default vlan.

You may wish to create a new thread in the future - instead of reviving a 2 year old one.


FYI, I personally find it easier to use the web GUI. See the graphic on the web GUI at Network > Switch for an easy guide.

You can easily toggle VLAN tags there.

I have used this web gui. I don't quit figure out how to make same ports available in both vlans. My external device will send VLAN id alongside the package.

Please make a new thread describing your issue.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.