Problem with transparent bridging of modem to PPPoE on router

I have a Cudy WR2100 router (OpenWRT) and a C4000GL modem, both with the latest updates. ISP is Century Link. Phone line comes into the jack on the modem. eth1 on the modem goes into the WAN port on the router. I can't get transparent bridging to work at all. I suspect this may ultimately be a modem problem, but after HOURS on the phone with multiple different techs, I haven't been able to convince them of anything. They swear it's the router, which conveniently they can't support. I have networking experience but I rarely work with DSL or PPPoE.

The modem works when in PPPoE mode with no other router involved. The router WAN port works at another location with a cable modem (in other words, the physical port is fine). However, when I set the modem to transparent bridging mode in the previously mentioned setup, it completely fails to connect. I set it into transparent bridging with a setting of tagged-201 (as provided by my ISP), I set up the WAN port for PPPoE, and nothing happens.

When I look at the status page in LUCI, RX/TX shows ZERO on the WAN port. This seems weird to me. Even if it's a bad connection, I would expect SOMETHING. This is despite the fact that the green light is blinking on both the modem and router ports.

Couple things I've looked at. First, ISP said to set VPI/VCI settings on the router. But as I've looked at it, I don't think that would apply to a transparent bridge. It seems like that should be done on the modem, and there's no option for it. I think maybe the setting is just baked in and they didn't know what they were talking about. Second, it's not entirely clear to me whether the WAN port on the router needs to be VLAN tagged as 201 if the modem is. I got different answers from the ISP depending on who I talked to. I've tried it for the heck of it and it didn't seem to help, but I'm not entirely sure I did it right. (I've tried untagged on the router WAN port as well.)

Here's my logread. Ignore the date timestamp, I know it's wrong.

Tue Nov  9 21:05:41 2021 authpriv.info dropbear[14582]: Child connection from 192.168.223.198:34734
Tue Nov  9 21:05:45 2021 daemon.warn pppd[14580]: Timeout waiting for PADO packets
Tue Nov  9 21:05:45 2021 daemon.err pppd[14580]: Unable to complete PPPoE Discovery
Tue Nov  9 21:05:45 2021 daemon.info pppd[14580]: Exit.
Tue Nov  9 21:05:45 2021 daemon.notice netifd: Interface 'wan' is now down
Tue Nov  9 21:05:45 2021 kern.info kernel: [ 2636.426832] mt7530 mdio-bus:1f wan: Link is Down
Tue Nov  9 21:05:45 2021 daemon.notice netifd: Interface 'wan6' is disabled
Tue Nov  9 21:05:45 2021 daemon.notice netifd: Interface 'wan' is disabled
Tue Nov  9 21:05:46 2021 kern.info kernel: [ 2636.437057] mt7530 mdio-bus:1f wan: configuring for phy/gmii link mode
Tue Nov  9 21:05:46 2021 kern.info kernel: [ 2636.444089] 8021q: adding VLAN 0 to HW filter on device wan
Tue Nov  9 21:05:46 2021 daemon.notice netifd: Interface 'wan6' is enabled
Tue Nov  9 21:05:46 2021 daemon.notice netifd: Interface 'wan' is enabled
Tue Nov  9 21:05:46 2021 daemon.notice netifd: Interface 'wan' is setting up now
Tue Nov  9 21:05:46 2021 daemon.notice netifd: 8021q 'wan.201' link is down
Tue Nov  9 21:05:46 2021 daemon.notice netifd: Interface 'wan' has link connectivity loss
Tue Nov  9 21:05:46 2021 daemon.notice netifd: Network device 'wan' link is down
Tue Nov  9 21:05:46 2021 daemon.notice netifd: Interface 'wan6' has link connectivity loss
Tue Nov  9 21:05:46 2021 daemon.notice netifd: Interface 'wan' is now down
Tue Nov  9 21:05:46 2021 daemon.notice netifd: Interface 'wan6' is disabled
Tue Nov  9 21:05:46 2021 daemon.notice netifd: Interface 'wan' is disabled
Tue Nov  9 21:05:46 2021 kern.info kernel: [ 2636.615290] mt7530 mdio-bus:1f wan: configuring for phy/gmii link mode
Tue Nov  9 21:05:46 2021 kern.info kernel: [ 2636.624015] 8021q: adding VLAN 0 to HW filter on device wan
Tue Nov  9 21:05:46 2021 daemon.notice netifd: Interface 'wan6' is enabled
Tue Nov  9 21:05:46 2021 daemon.notice netifd: Interface 'wan' is enabled
Tue Nov  9 21:05:48 2021 authpriv.info dropbear[7778]: Exit (root) from <192.168.223.198:34730>: Error reading: Connection reset by peer
Tue Nov  9 21:05:50 2021 kern.info kernel: [ 2640.718585] mt7530 mdio-bus:1f wan: Link is Up - 1Gbps/Full - flow control rx
Tue Nov  9 21:05:50 2021 kern.info kernel: [ 2640.725797] IPv6: ADDRCONF(NETDEV_CHANGE): wan: link becomes ready
Tue Nov  9 21:05:50 2021 daemon.notice netifd: Network device 'wan' link is up
Tue Nov  9 21:05:50 2021 daemon.notice netifd: Interface 'wan6' has link connectivity
Tue Nov  9 21:05:50 2021 daemon.notice netifd: 8021q 'wan.201' link is up
Tue Nov  9 21:05:50 2021 daemon.notice netifd: Interface 'wan' has link connectivity
Tue Nov  9 21:05:50 2021 daemon.notice netifd: Interface 'wan' is setting up now
Tue Nov  9 21:05:50 2021 daemon.err insmod: module is already loaded - slhc
Tue Nov  9 21:05:50 2021 daemon.err insmod: module is already loaded - ppp_generic
Tue Nov  9 21:05:50 2021 daemon.err insmod: module is already loaded - pppox
Tue Nov  9 21:05:50 2021 daemon.err insmod: module is already loaded - pppoe
Tue Nov  9 21:05:50 2021 daemon.info pppd[14974]: Plugin rp-pppoe.so loaded.
Tue Nov  9 21:05:50 2021 daemon.info pppd[14974]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.8
Tue Nov  9 21:05:50 2021 daemon.notice pppd[14974]: pppd 2.4.8 started by root, uid 0
Tue Nov  9 21:06:05 2021 daemon.warn pppd[14974]: Timeout waiting for PADO packets
Tue Nov  9 21:06:05 2021 daemon.err pppd[14974]: Unable to complete PPPoE Discovery
Tue Nov  9 21:06:05 2021 daemon.info pppd[14974]: Exit.
Tue Nov  9 21:06:05 2021 daemon.notice netifd: Interface 'wan' is now down
Tue Nov  9 21:06:05 2021 kern.info kernel: [ 2656.055235] mt7530 mdio-bus:1f wan: Link is Down
Tue Nov  9 21:06:05 2021 daemon.notice netifd: Interface 'wan6' is disabled
Tue Nov  9 21:06:05 2021 daemon.notice netifd: Interface 'wan' is disabled
Tue Nov  9 21:06:05 2021 kern.info kernel: [ 2656.065388] mt7530 mdio-bus:1f wan: configuring for phy/gmii link mode
Tue Nov  9 21:06:05 2021 kern.info kernel: [ 2656.072427] 8021q: adding VLAN 0 to HW filter on device wan
Tue Nov  9 21:06:05 2021 daemon.notice netifd: Interface 'wan6' is enabled
Tue Nov  9 21:06:05 2021 daemon.notice netifd: Interface 'wan' is enabled
Tue Nov  9 21:06:05 2021 daemon.notice netifd: Interface 'wan' is setting up now
Tue Nov  9 21:06:05 2021 daemon.notice netifd: 8021q 'wan.201' link is down
Tue Nov  9 21:06:05 2021 daemon.notice netifd: Interface 'wan' has link connectivity loss
Tue Nov  9 21:06:05 2021 daemon.notice netifd: Network device 'wan' link is down
Tue Nov  9 21:06:05 2021 daemon.notice netifd: Interface 'wan6' has link connectivity loss
Tue Nov  9 21:06:05 2021 daemon.notice netifd: Interface 'wan' is now down
Tue Nov  9 21:06:05 2021 daemon.notice netifd: Interface 'wan6' is disabled
Tue Nov  9 21:06:05 2021 daemon.notice netifd: Interface 'wan' is disabled
Tue Nov  9 21:06:05 2021 kern.info kernel: [ 2656.248045] mt7530 mdio-bus:1f wan: configuring for phy/gmii link mode
Tue Nov  9 21:06:05 2021 kern.info kernel: [ 2656.255182] 8021q: adding VLAN 0 to HW filter on device wan
Tue Nov  9 21:06:05 2021 daemon.notice netifd: Interface 'wan6' is enabled
Tue Nov  9 21:06:05 2021 daemon.notice netifd: Interface 'wan' is enabled
Tue Nov  9 21:06:08 2021 kern.info kernel: [ 2659.342583] mt7530 mdio-bus:1f wan: Link is Up - 1Gbps/Full - flow control rx
Tue Nov  9 21:06:08 2021 kern.info kernel: [ 2659.349791] IPv6: ADDRCONF(NETDEV_CHANGE): wan: link becomes ready
Tue Nov  9 21:06:08 2021 daemon.notice netifd: Network device 'wan' link is up
Tue Nov  9 21:06:08 2021 daemon.notice netifd: Interface 'wan6' has link connectivity
Tue Nov  9 21:06:08 2021 daemon.notice netifd: 8021q 'wan.201' link is up
Tue Nov  9 21:06:08 2021 daemon.notice netifd: Interface 'wan' has link connectivity
Tue Nov  9 21:06:08 2021 daemon.notice netifd: Interface 'wan' is setting up now
Tue Nov  9 21:06:08 2021 daemon.err insmod: module is already loaded - slhc
Tue Nov  9 21:06:08 2021 daemon.err insmod: module is already loaded - ppp_generic
Tue Nov  9 21:06:08 2021 daemon.err insmod: module is already loaded - pppox
Tue Nov  9 21:06:08 2021 daemon.err insmod: module is already loaded - pppoe
Tue Nov  9 21:06:09 2021 daemon.info pppd[15357]: Plugin rp-pppoe.so loaded.
Tue Nov  9 21:06:09 2021 daemon.info pppd[15357]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.8
Tue Nov  9 21:06:09 2021 daemon.notice pppd[15357]: pppd 2.4.8 started by root, uid 0
Tue Nov  9 21:06:24 2021 daemon.warn pppd[15357]: Timeout waiting for PADO packets
Tue Nov  9 21:06:24 2021 daemon.err pppd[15357]: Unable to complete PPPoE Discovery
Tue Nov  9 21:06:24 2021 daemon.info pppd[15357]: Exit.
Tue Nov  9 21:06:24 2021 daemon.notice netifd: Interface 'wan' is now down
Tue Nov  9 21:06:24 2021 kern.info kernel: [ 2674.706919] mt7530 mdio-bus:1f wan: Link is Down
Tue Nov  9 21:06:24 2021 daemon.notice netifd: Interface 'wan6' is disabled
Tue Nov  9 21:06:24 2021 daemon.notice netifd: Interface 'wan' is disabled
Tue Nov  9 21:06:24 2021 kern.info kernel: [ 2674.717202] mt7530 mdio-bus:1f wan: configuring for phy/gmii link mode
Tue Nov  9 21:06:24 2021 kern.info kernel: [ 2674.724259] 8021q: adding VLAN 0 to HW filter on device wan
Tue Nov  9 21:06:24 2021 daemon.notice netifd: Interface 'wan6' is enabled
Tue Nov  9 21:06:24 2021 daemon.notice netifd: Interface 'wan' is enabled
Tue Nov  9 21:06:24 2021 daemon.notice netifd: Interface 'wan' is setting up now
Tue Nov  9 21:06:24 2021 daemon.notice netifd: 8021q 'wan.201' link is down
Tue Nov  9 21:06:24 2021 daemon.notice netifd: Interface 'wan' has link connectivity loss
Tue Nov  9 21:06:24 2021 daemon.notice netifd: Network device 'wan' link is down
Tue Nov  9 21:06:24 2021 daemon.notice netifd: Interface 'wan6' has link connectivity loss
Tue Nov  9 21:06:24 2021 daemon.notice netifd: Interface 'wan' is now down
Tue Nov  9 21:06:24 2021 daemon.notice netifd: Interface 'wan6' is disabled
Tue Nov  9 21:06:24 2021 daemon.notice netifd: Interface 'wan' is disabled
Tue Nov  9 21:06:24 2021 kern.info kernel: [ 2674.912325] mt7530 mdio-bus:1f wan: configuring for phy/gmii link mode
Tue Nov  9 21:06:24 2021 kern.info kernel: [ 2674.920991] 8021q: adding VLAN 0 to HW filter on device wan
Tue Nov  9 21:06:24 2021 daemon.notice netifd: Interface 'wan6' is enabled
Tue Nov  9 21:06:24 2021 daemon.notice netifd: Interface 'wan' is enabled
Tue Nov  9 21:06:29 2021 kern.info kernel: [ 2680.046601] mt7530 mdio-bus:1f wan: Link is Up - 1Gbps/Full - flow control rx
Tue Nov  9 21:06:29 2021 kern.info kernel: [ 2680.053793] IPv6: ADDRCONF(NETDEV_CHANGE): wan: link becomes ready
Tue Nov  9 21:06:29 2021 daemon.notice netifd: Network device 'wan' link is up
Tue Nov  9 21:06:29 2021 daemon.notice netifd: Interface 'wan6' has link connectivity
Tue Nov  9 21:06:29 2021 daemon.notice netifd: 8021q 'wan.201' link is up
Tue Nov  9 21:06:29 2021 daemon.notice netifd: Interface 'wan' has link connectivity
Tue Nov  9 21:06:29 2021 daemon.notice netifd: Interface 'wan' is setting up now
Tue Nov  9 21:06:29 2021 daemon.err insmod: module is already loaded - slhc
Tue Nov  9 21:06:29 2021 daemon.err insmod: module is already loaded - ppp_generic
Tue Nov  9 21:06:29 2021 daemon.err insmod: module is already loaded - pppox
Tue Nov  9 21:06:29 2021 daemon.err insmod: module is already loaded - pppoe
Tue Nov  9 21:06:29 2021 daemon.info pppd[15776]: Plugin rp-pppoe.so loaded.
Tue Nov  9 21:06:29 2021 daemon.info pppd[15776]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.8
Tue Nov  9 21:06:29 2021 daemon.notice pppd[15776]: pppd 2.4.8 started by root, uid 0
Tue Nov  9 21:06:44 2021 daemon.warn pppd[15776]: Timeout waiting for PADO packets
Tue Nov  9 21:06:44 2021 daemon.err pppd[15776]: Unable to complete PPPoE Discovery
Tue Nov  9 21:06:44 2021 daemon.info pppd[15776]: Exit.
Tue Nov  9 21:06:44 2021 daemon.notice netifd: Interface 'wan' is now down
Tue Nov  9 21:06:44 2021 kern.info kernel: [ 2695.371180] mt7530 mdio-bus:1f wan: Link is Down
Tue Nov  9 21:06:44 2021 daemon.notice netifd: Interface 'wan6' is disabled
Tue Nov  9 21:06:44 2021 daemon.notice netifd: Interface 'wan' is disabled
Tue Nov  9 21:06:44 2021 kern.info kernel: [ 2695.381900] mt7530 mdio-bus:1f wan: configuring for phy/gmii link mode
Tue Nov  9 21:06:44 2021 kern.info kernel: [ 2695.388943] 8021q: adding VLAN 0 to HW filter on device wan
Tue Nov  9 21:06:44 2021 daemon.notice netifd: Interface 'wan6' is enabled
Tue Nov  9 21:06:44 2021 daemon.notice netifd: Interface 'wan' is enabled
Tue Nov  9 21:06:44 2021 daemon.notice netifd: Interface 'wan' is setting up now
Tue Nov  9 21:06:44 2021 daemon.notice netifd: 8021q 'wan.201' link is down
Tue Nov  9 21:06:44 2021 daemon.notice netifd: Interface 'wan' has link connectivity loss
Tue Nov  9 21:06:44 2021 daemon.notice netifd: Network device 'wan' link is down
Tue Nov  9 21:06:44 2021 daemon.notice netifd: Interface 'wan6' has link connectivity loss
Tue Nov  9 21:06:45 2021 daemon.notice netifd: Interface 'wan' is now down
Tue Nov  9 21:06:45 2021 daemon.notice netifd: Interface 'wan6' is disabled
Tue Nov  9 21:06:45 2021 daemon.notice netifd: Interface 'wan' is disabled
Tue Nov  9 21:06:45 2021 kern.info kernel: [ 2695.571102] mt7530 mdio-bus:1f wan: configuring for phy/gmii link mode
Tue Nov  9 21:06:45 2021 kern.info kernel: [ 2695.579839] 8021q: adding VLAN 0 to HW filter on device wan
Tue Nov  9 21:06:45 2021 daemon.notice netifd: Interface 'wan6' is enabled
Tue Nov  9 21:06:45 2021 daemon.notice netifd: Interface 'wan' is enabled
Tue Nov  9 21:06:48 2021 kern.info kernel: [ 2698.638602] mt7530 mdio-bus:1f wan: Link is Up - 1Gbps/Full - flow control rx
Tue Nov  9 21:06:48 2021 kern.info kernel: [ 2698.645787] IPv6: ADDRCONF(NETDEV_CHANGE): wan: link becomes ready
Tue Nov  9 21:06:48 2021 daemon.notice netifd: Network device 'wan' link is up
Tue Nov  9 21:06:48 2021 daemon.notice netifd: Interface 'wan6' has link connectivity
Tue Nov  9 21:06:48 2021 daemon.notice netifd: 8021q 'wan.201' link is up
Tue Nov  9 21:06:48 2021 daemon.notice netifd: Interface 'wan' has link connectivity
Tue Nov  9 21:06:48 2021 daemon.notice netifd: Interface 'wan' is setting up now
Tue Nov  9 21:06:48 2021 daemon.err insmod: module is already loaded - slhc
Tue Nov  9 21:06:48 2021 daemon.err insmod: module is already loaded - ppp_generic
Tue Nov  9 21:06:48 2021 daemon.err insmod: module is already loaded - pppox
Tue Nov  9 21:06:48 2021 daemon.err insmod: module is already loaded - pppoe
Tue Nov  9 21:06:48 2021 daemon.info pppd[16243]: Plugin rp-pppoe.so loaded.
Tue Nov  9 21:06:48 2021 daemon.info pppd[16243]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.8
Tue Nov  9 21:06:48 2021 daemon.notice pppd[16243]: pppd 2.4.8 started by root, uid 0
Tue Nov  9 21:06:51 2021 daemon.notice netifd: Network device 'wan' link is down
Tue Nov  9 21:06:51 2021 daemon.notice netifd: Interface 'wan6' has link connectivity loss
Tue Nov  9 21:06:51 2021 daemon.notice netifd: 8021q 'wan.201' link is down
Tue Nov  9 21:06:51 2021 daemon.notice netifd: Interface 'wan' has link connectivity loss
Tue Nov  9 21:06:51 2021 kern.info kernel: [ 2701.710351] mt7530 mdio-bus:1f wan: Link is Down
Tue Nov  9 21:06:51 2021 daemon.err pppd[16243]: select (waitForPADO): Interrupted system call
Tue Nov  9 21:06:51 2021 daemon.warn pppd[16243]: Timeout waiting for PADO packets
Tue Nov  9 21:06:51 2021 daemon.err pppd[16243]: Unable to complete PPPoE Discovery
Tue Nov  9 21:06:51 2021 daemon.info pppd[16243]: Exit.
Tue Nov  9 21:06:51 2021 daemon.notice netifd: Interface 'wan' is now down
Tue Nov  9 21:06:51 2021 daemon.notice netifd: Interface 'wan6' is disabled
Tue Nov  9 21:06:51 2021 daemon.notice netifd: Interface 'wan' is disabled
Tue Nov  9 21:06:51 2021 kern.info kernel: [ 2701.852213] mt7530 mdio-bus:1f wan: configuring for phy/gmii link mode
Tue Nov  9 21:06:51 2021 kern.info kernel: [ 2701.860151] 8021q: adding VLAN 0 to HW filter on device wan
Tue Nov  9 21:06:51 2021 daemon.notice netifd: Interface 'wan6' is enabled
Tue Nov  9 21:06:51 2021 daemon.notice netifd: Interface 'wan' is enabled
Tue Nov  9 21:06:57 2021 kern.info kernel: [ 2708.014604] mt7530 mdio-bus:1f wan: Link is Up - 1Gbps/Full - flow control rx
Tue Nov  9 21:06:57 2021 kern.info kernel: [ 2708.021803] IPv6: ADDRCONF(NETDEV_CHANGE): wan: link becomes ready
Tue Nov  9 21:06:57 2021 daemon.notice netifd: Network device 'wan' link is up
Tue Nov  9 21:06:57 2021 daemon.notice netifd: Interface 'wan6' has link connectivity
Tue Nov  9 21:06:57 2021 daemon.notice netifd: 8021q 'wan.201' link is up
Tue Nov  9 21:06:57 2021 daemon.notice netifd: Interface 'wan' has link connectivity
Tue Nov  9 21:06:57 2021 daemon.notice netifd: Interface 'wan' is setting up now
Tue Nov  9 21:06:57 2021 daemon.err insmod: module is already loaded - slhc
Tue Nov  9 21:06:57 2021 daemon.err insmod: module is already loaded - ppp_generic
Tue Nov  9 21:06:57 2021 daemon.err insmod: module is already loaded - pppox
Tue Nov  9 21:06:57 2021 daemon.err insmod: module is already loaded - pppoe
Tue Nov  9 21:06:57 2021 daemon.info pppd[16510]: Plugin rp-pppoe.so loaded.
Tue Nov  9 21:06:57 2021 daemon.info pppd[16510]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.8
Tue Nov  9 21:06:57 2021 daemon.notice pppd[16510]: pppd 2.4.8 started by root, uid 0
Tue Nov  9 21:07:12 2021 daemon.warn pppd[16510]: Timeout waiting for PADO packets
Tue Nov  9 21:07:12 2021 daemon.err pppd[16510]: Unable to complete PPPoE Discovery
Tue Nov  9 21:07:12 2021 daemon.info pppd[16510]: Exit.
Tue Nov  9 21:07:12 2021 daemon.notice netifd: Interface 'wan' is now down
Tue Nov  9 21:07:12 2021 kern.info kernel: [ 2723.347376] mt7530 mdio-bus:1f wan: Link is Down
Tue Nov  9 21:07:12 2021 daemon.notice netifd: Interface 'wan6' is disabled
Tue Nov  9 21:07:12 2021 daemon.notice netifd: Interface 'wan' is disabled
Tue Nov  9 21:07:12 2021 kern.info kernel: [ 2723.359868] mt7530 mdio-bus:1f wan: configuring for phy/gmii link mode
Tue Nov  9 21:07:12 2021 kern.info kernel: [ 2723.366933] 8021q: adding VLAN 0 to HW filter on device wan
Tue Nov  9 21:07:12 2021 daemon.notice netifd: Interface 'wan6' is enabled
Tue Nov  9 21:07:12 2021 daemon.notice netifd: Interface 'wan' is enabled
Tue Nov  9 21:07:12 2021 daemon.notice netifd: Interface 'wan' is setting up now
Tue Nov  9 21:07:12 2021 daemon.notice netifd: 8021q 'wan.201' link is down
Tue Nov  9 21:07:12 2021 daemon.notice netifd: Interface 'wan' has link connectivity loss
Tue Nov  9 21:07:12 2021 daemon.notice netifd: Network device 'wan' link is down
Tue Nov  9 21:07:12 2021 daemon.notice netifd: Interface 'wan6' has link connectivity loss
Tue Nov  9 21:07:13 2021 daemon.notice netifd: Interface 'wan' is now down
Tue Nov  9 21:07:13 2021 daemon.notice netifd: Interface 'wan6' is disabled
Tue Nov  9 21:07:13 2021 daemon.notice netifd: Interface 'wan' is disabled
Tue Nov  9 21:07:13 2021 kern.info kernel: [ 2723.539083] mt7530 mdio-bus:1f wan: configuring for phy/gmii link mode
Tue Nov  9 21:07:13 2021 kern.info kernel: [ 2723.546300] 8021q: adding VLAN 0 to HW filter on device wan
Tue Nov  9 21:07:13 2021 daemon.notice netifd: Interface 'wan6' is enabled
Tue Nov  9 21:07:13 2021 daemon.notice netifd: Interface 'wan' is enabled
Tue Nov  9 21:07:17 2021 kern.info kernel: [ 2727.630698] mt7530 mdio-bus:1f wan: Link is Up - 1Gbps/Full - flow control rx
Tue Nov  9 21:07:17 2021 kern.info kernel: [ 2727.637958] IPv6: ADDRCONF(NETDEV_CHANGE): wan: link becomes ready
Tue Nov  9 21:07:17 2021 daemon.notice netifd: Network device 'wan' link is up
Tue Nov  9 21:07:17 2021 daemon.notice netifd: Interface 'wan6' has link connectivity
Tue Nov  9 21:07:17 2021 daemon.notice netifd: 8021q 'wan.201' link is up
Tue Nov  9 21:07:17 2021 daemon.notice netifd: Interface 'wan' has link connectivity
Tue Nov  9 21:07:17 2021 daemon.notice netifd: Interface 'wan' is setting up now
Tue Nov  9 21:07:17 2021 daemon.err insmod: module is already loaded - slhc
Tue Nov  9 21:07:17 2021 daemon.err insmod: module is already loaded - ppp_generic
Tue Nov  9 21:07:17 2021 daemon.err insmod: module is already loaded - pppox
Tue Nov  9 21:07:17 2021 daemon.err insmod: module is already loaded - pppoe
Tue Nov  9 21:07:17 2021 daemon.info pppd[16978]: Plugin rp-pppoe.so loaded.
Tue Nov  9 21:07:17 2021 daemon.info pppd[16978]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.8
Tue Nov  9 21:07:17 2021 daemon.notice pppd[16978]: pppd 2.4.8 started by root, uid 0
Tue Nov  9 21:07:32 2021 daemon.warn pppd[16978]: Timeout waiting for PADO packets
Tue Nov  9 21:07:32 2021 daemon.err pppd[16978]: Unable to complete PPPoE Discovery
Tue Nov  9 21:07:32 2021 daemon.info pppd[16978]: Exit.
Tue Nov  9 21:07:32 2021 daemon.notice netifd: Interface 'wan' is now down
Tue Nov  9 21:07:32 2021 kern.info kernel: [ 2742.987292] mt7530 mdio-bus:1f wan: Link is Down
Tue Nov  9 21:07:32 2021 daemon.notice netifd: Interface 'wan6' is disabled
Tue Nov  9 21:07:32 2021 daemon.notice netifd: Interface 'wan' is disabled
Tue Nov  9 21:07:32 2021 kern.info kernel: [ 2742.998179] mt7530 mdio-bus:1f wan: configuring for phy/gmii link mode
Tue Nov  9 21:07:32 2021 kern.info kernel: [ 2743.005223] 8021q: adding VLAN 0 to HW filter on device wan
Tue Nov  9 21:07:32 2021 daemon.notice netifd: Interface 'wan6' is enabled
Tue Nov  9 21:07:32 2021 daemon.notice netifd: Interface 'wan' is enabled
Tue Nov  9 21:07:32 2021 daemon.notice netifd: Interface 'wan' is setting up now
Tue Nov  9 21:07:32 2021 daemon.notice netifd: 8021q 'wan.201' link is down
Tue Nov  9 21:07:32 2021 daemon.notice netifd: Interface 'wan' has link connectivity loss
Tue Nov  9 21:07:32 2021 daemon.notice netifd: Network device 'wan' link is down
Tue Nov  9 21:07:32 2021 daemon.notice netifd: Interface 'wan6' has link connectivity loss
Tue Nov  9 21:07:32 2021 daemon.notice netifd: Interface 'wan' is now down
Tue Nov  9 21:07:32 2021 daemon.notice netifd: Interface 'wan6' is disabled
Tue Nov  9 21:07:32 2021 daemon.notice netifd: Interface 'wan' is disabled
Tue Nov  9 21:07:32 2021 kern.info kernel: [ 2743.188233] mt7530 mdio-bus:1f wan: configuring for phy/gmii link mode
Tue Nov  9 21:07:32 2021 kern.info kernel: [ 2743.196180] 8021q: adding VLAN 0 to HW filter on device wan
Tue Nov  9 21:07:32 2021 daemon.notice netifd: Interface 'wan6' is enabled
Tue Nov  9 21:07:32 2021 daemon.notice netifd: Interface 'wan' is enabled
Tue Nov  9 21:07:35 2021 kern.info kernel: [ 2746.254596] mt7530 mdio-bus:1f wan: Link is Up - 1Gbps/Full - flow control rx
Tue Nov  9 21:07:35 2021 kern.info kernel: [ 2746.261780] IPv6: ADDRCONF(NETDEV_CHANGE): wan: link becomes ready
Tue Nov  9 21:07:35 2021 daemon.notice netifd: Network device 'wan' link is up
Tue Nov  9 21:07:35 2021 daemon.notice netifd: Interface 'wan6' has link connectivity
Tue Nov  9 21:07:35 2021 daemon.notice netifd: 8021q 'wan.201' link is up
Tue Nov  9 21:07:35 2021 daemon.notice netifd: Interface 'wan' has link connectivity
Tue Nov  9 21:07:35 2021 daemon.notice netifd: Interface 'wan' is setting up now
Tue Nov  9 21:07:35 2021 daemon.err insmod: module is already loaded - slhc
Tue Nov  9 21:07:35 2021 daemon.err insmod: module is already loaded - ppp_generic
Tue Nov  9 21:07:35 2021 daemon.err insmod: module is already loaded - pppox
Tue Nov  9 21:07:35 2021 daemon.err insmod: module is already loaded - pppoe
Tue Nov  9 21:07:35 2021 daemon.info pppd[17418]: Plugin rp-pppoe.so loaded.
Tue Nov  9 21:07:35 2021 daemon.info pppd[17418]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.8
Tue Nov  9 21:07:35 2021 daemon.notice pppd[17418]: pppd 2.4.8 started by root, uid 0
Tue Nov  9 21:07:51 2021 daemon.warn pppd[17418]: Timeout waiting for PADO packets
Tue Nov  9 21:07:51 2021 daemon.err pppd[17418]: Unable to complete PPPoE Discovery
Tue Nov  9 21:07:51 2021 daemon.info pppd[17418]: Exit.
Tue Nov  9 21:07:51 2021 daemon.notice netifd: Interface 'wan' is now down
Tue Nov  9 21:07:51 2021 kern.info kernel: [ 2761.598893] mt7530 mdio-bus:1f wan: Link is Down
Tue Nov  9 21:07:51 2021 daemon.notice netifd: Interface 'wan6' is disabled
Tue Nov  9 21:07:51 2021 daemon.notice netifd: Interface 'wan' is disabled
Tue Nov  9 21:07:51 2021 kern.info kernel: [ 2761.609123] mt7530 mdio-bus:1f wan: configuring for phy/gmii link mode
Tue Nov  9 21:07:51 2021 kern.info kernel: [ 2761.616162] 8021q: adding VLAN 0 to HW filter on device wan
Tue Nov  9 21:07:51 2021 daemon.notice netifd: Interface 'wan6' is enabled
Tue Nov  9 21:07:51 2021 daemon.notice netifd: Interface 'wan' is enabled
Tue Nov  9 21:07:51 2021 daemon.notice netifd: Interface 'wan' is setting up now
Tue Nov  9 21:07:51 2021 daemon.notice netifd: 8021q 'wan.201' link is down
Tue Nov  9 21:07:51 2021 daemon.notice netifd: Interface 'wan' has link connectivity loss
Tue Nov  9 21:07:51 2021 daemon.notice netifd: Network device 'wan' link is down
Tue Nov  9 21:07:51 2021 daemon.notice netifd: Interface 'wan6' has link connectivity loss
Tue Nov  9 21:07:51 2021 daemon.notice netifd: Interface 'wan' is now down
Tue Nov  9 21:07:51 2021 daemon.notice netifd: Interface 'wan6' is disabled
Tue Nov  9 21:07:51 2021 daemon.notice netifd: Interface 'wan' is disabled
Tue Nov  9 21:07:51 2021 kern.info kernel: [ 2761.787354] mt7530 mdio-bus:1f wan: configuring for phy/gmii link mode
Tue Nov  9 21:07:51 2021 kern.info kernel: [ 2761.795156] 8021q: adding VLAN 0 to HW filter on device wan
Tue Nov  9 21:07:51 2021 daemon.notice netifd: Interface 'wan6' is enabled
Tue Nov  9 21:07:51 2021 daemon.notice netifd: Interface 'wan' is enabled
Tue Nov  9 21:07:55 2021 kern.info kernel: [ 2765.902593] mt7530 mdio-bus:1f wan: Link is Up - 1Gbps/Full - flow control rx
Tue Nov  9 21:07:55 2021 kern.info kernel: [ 2765.909775] IPv6: ADDRCONF(NETDEV_CHANGE): wan: link becomes ready
Tue Nov  9 21:07:55 2021 daemon.notice netifd: Network device 'wan' link is up
Tue Nov  9 21:07:55 2021 daemon.notice netifd: Interface 'wan6' has link connectivity
Tue Nov  9 21:07:55 2021 daemon.notice netifd: 8021q 'wan.201' link is up
Tue Nov  9 21:07:55 2021 daemon.notice netifd: Interface 'wan' has link connectivity
Tue Nov  9 21:07:55 2021 daemon.notice netifd: Interface 'wan' is setting up now
Tue Nov  9 21:07:55 2021 daemon.err insmod: module is already loaded - slhc
Tue Nov  9 21:07:55 2021 daemon.err insmod: module is already loaded - ppp_generic
Tue Nov  9 21:07:55 2021 daemon.err insmod: module is already loaded - pppox
Tue Nov  9 21:07:55 2021 daemon.err insmod: module is already loaded - pppoe
Tue Nov  9 21:07:55 2021 daemon.info pppd[17888]: Plugin rp-pppoe.so loaded.
Tue Nov  9 21:07:55 2021 daemon.info pppd[17888]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.8
Tue Nov  9 21:07:55 2021 daemon.notice pppd[17888]: pppd 2.4.8 started by root, uid 0

I'm not sure what to make of this line
kern.info kernel: [ 2636.624015] 8021q: adding VLAN 0 to HW filter on device wan

Again, is the VLAN set wrong somehow?

However I think the actual problem is here.
Tue Nov 9 21:06:24 2021 daemon.warn pppd[15357]: Timeout waiting for PADO packets
Tue Nov 9 21:06:24 2021 daemon.err pppd[15357]: Unable to complete PPPoE Discovery

From what I can make out, that's usually caused by lack of communication with the ISP, but I can't figure out WHY.

Here's /etc/config/network. This is the one with the VLAN set up, but like I said, I've tried without it as well.

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.1'

config interface 'wan'
        option type 'bridge'
        option proto 'pppoe'
        option password 'REDACTED'
        option ipv6 'auto'
        option username 'REDACTED'
        option device 'wan.201'

config interface 'wan6'
        option device 'wan'
        option type 'bridge'
        option proto 'none'
        option auto '0'

config interface 'guest'
        option proto 'static'
        option device 'wlan0-1'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option type 'bridge'

config device
        option type '8021q'
        option ifname 'wan'
        option vid '201'
        option name 'wan.201'

Like I said, I'm not 100% sure the VLAN is set up right. Normally I'm used to associating VLANs with ports, but it seems like it works a little different here. That being said, I've tried it both with and without the VLAN, and I get that same discovery error either way. But whether that's the cause or not, I absolutely cannot get this thing to pass traffic. I've tried everything I know to try. Any ideas?

I would suggest you try a different model of router (non-openwrt) to confirm transparent bridging is working.

I'm not familiar with your ISP or modem, but are you sure you need to configure vlan 201 on the openwrt WAN interface is only other thought?

I'll see if I have a spare non-OpenWRT and report back. I'm not entirely sure if I need the VLAN or not, but yes, I tried it as just a straight PPPoE with no VLAN and got the same result.

Unfortunately I don't seem to have any spare non-OpenWRT hardware at the moment. As a last resort I may end up buying something, but I'd prefer to explore all other options first before I spend money. Just for the avoidance of doubt, here's a config and log excerpt WITHOUT any VLAN options enabled.

EDIT: Messed up the formatting.

/etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.1'

config interface 'wan'
        option device 'wan'
        option type 'bridge'
        option proto 'pppoe'
        option password 'REDACTED'
        option ipv6 'auto'
        option username 'REDACTED'

config interface 'wan6'
        option device 'wan'
        option type 'bridge'
        option proto 'none'
        option auto '0'

config interface 'guest'
        option proto 'static'
        option device 'wlan0-1'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option type 'bridge'

log

Tue Nov  9 20:23:55 2021 daemon.notice netifd: Network device 'wan' link is down
Tue Nov  9 20:23:55 2021 daemon.notice netifd: Interface 'wan' has link connectivity loss
Tue Nov  9 20:23:55 2021 daemon.notice netifd: Interface 'wan6' has link connectivity loss
Tue Nov  9 20:23:55 2021 daemon.notice netifd: Interface 'wan' is now down
Tue Nov  9 20:23:55 2021 daemon.notice netifd: Interface 'wan' is disabled
Tue Nov  9 20:23:55 2021 daemon.notice netifd: Interface 'wan6' is disabled
Tue Nov  9 20:23:55 2021 kern.info kernel: [  502.354116] mt7530 mdio-bus:1f wan: configuring for phy/gmii link mode
Tue Nov  9 20:23:55 2021 kern.info kernel: [  502.361181] 8021q: adding VLAN 0 to HW filter on device wan
Tue Nov  9 20:23:55 2021 daemon.notice netifd: Interface 'wan' is enabled
Tue Nov  9 20:23:55 2021 daemon.notice netifd: Interface 'wan6' is enabled
Tue Nov  9 20:24:00 2021 kern.info kernel: [  506.446479] mt7530 mdio-bus:1f wan: Link is Up - 1Gbps/Full - flow control rx
Tue Nov  9 20:24:00 2021 kern.info kernel: [  506.453888] IPv6: ADDRCONF(NETDEV_CHANGE): wan: link becomes ready
Tue Nov  9 20:24:00 2021 daemon.notice netifd: Network device 'wan' link is up
Tue Nov  9 20:24:00 2021 daemon.notice netifd: Interface 'wan' has link connectivity
Tue Nov  9 20:24:00 2021 daemon.notice netifd: Interface 'wan' is setting up now
Tue Nov  9 20:24:00 2021 daemon.notice netifd: Interface 'wan6' has link connectivity
Tue Nov  9 20:24:00 2021 daemon.err insmod: module is already loaded - slhc
Tue Nov  9 20:24:00 2021 daemon.err insmod: module is already loaded - ppp_generic
Tue Nov  9 20:24:00 2021 daemon.err insmod: module is already loaded - pppox
Tue Nov  9 20:24:00 2021 daemon.err insmod: module is already loaded - pppoe
Tue Nov  9 20:24:00 2021 daemon.info pppd[6990]: Plugin rp-pppoe.so loaded.
Tue Nov  9 20:24:00 2021 daemon.info pppd[6990]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.8
Tue Nov  9 20:24:00 2021 daemon.notice pppd[6990]: pppd 2.4.8 started by root, uid 0
Tue Nov  9 20:24:15 2021 daemon.warn pppd[6990]: Timeout waiting for PADO packets
Tue Nov  9 20:24:15 2021 daemon.err pppd[6990]: Unable to complete PPPoE Discovery
Tue Nov  9 20:24:15 2021 daemon.info pppd[6990]: Exit.
Tue Nov  9 20:24:15 2021 daemon.notice netifd: Interface 'wan' is now down
Tue Nov  9 20:24:15 2021 kern.info kernel: [  521.781339] mt7530 mdio-bus:1f wan: Link is Down
Tue Nov  9 20:24:15 2021 daemon.notice netifd: Interface 'wan' is disabled
Tue Nov  9 20:24:15 2021 daemon.notice netifd: Interface 'wan6' is disabled
Tue Nov  9 20:24:15 2021 kern.info kernel: [  521.792832] mt7530 mdio-bus:1f wan: configuring for phy/gmii link mode
Tue Nov  9 20:24:15 2021 kern.info kernel: [  521.800021] 8021q: adding VLAN 0 to HW filter on device wan
Tue Nov  9 20:24:15 2021 daemon.notice netifd: Interface 'wan' is enabled
Tue Nov  9 20:24:15 2021 daemon.notice netifd: Interface 'wan' is setting up now
Tue Nov  9 20:24:15 2021 daemon.notice netifd: Interface 'wan6' is enabled
Tue Nov  9 20:24:15 2021 daemon.notice netifd: Network device 'wan' link is down
Tue Nov  9 20:24:15 2021 daemon.notice netifd: Interface 'wan' has link connectivity loss
Tue Nov  9 20:24:15 2021 daemon.notice netifd: Interface 'wan6' has link connectivity loss
Tue Nov  9 20:24:15 2021 daemon.notice netifd: Interface 'wan' is now down
Tue Nov  9 20:24:15 2021 daemon.notice netifd: Interface 'wan' is disabled
Tue Nov  9 20:24:15 2021 daemon.notice netifd: Interface 'wan6' is disabled
Tue Nov  9 20:24:15 2021 kern.info kernel: [  521.902591] mt7530 mdio-bus:1f wan: configuring for phy/gmii link mode
Tue Nov  9 20:24:15 2021 kern.info kernel: [  521.909589] 8021q: adding VLAN 0 to HW filter on device wan
Tue Nov  9 20:24:15 2021 daemon.notice netifd: Interface 'wan' is enabled
Tue Nov  9 20:24:15 2021 daemon.notice netifd: Interface 'wan6' is enabled
Tue Nov  9 20:24:20 2021 kern.info kernel: [  527.022285] mt7530 mdio-bus:1f wan: Link is Up - 1Gbps/Full - flow control rx
Tue Nov  9 20:24:20 2021 kern.info kernel: [  527.029473] IPv6: ADDRCONF(NETDEV_CHANGE): wan: link becomes ready
Tue Nov  9 20:24:20 2021 daemon.notice netifd: Network device 'wan' link is up
Tue Nov  9 20:24:20 2021 daemon.notice netifd: Interface 'wan' has link connectivity
Tue Nov  9 20:24:20 2021 daemon.notice netifd: Interface 'wan' is setting up now
Tue Nov  9 20:24:20 2021 daemon.notice netifd: Interface 'wan6' has link connectivity
Tue Nov  9 20:24:20 2021 daemon.err insmod: module is already loaded - slhc
Tue Nov  9 20:24:20 2021 daemon.err insmod: module is already loaded - ppp_generic
Tue Nov  9 20:24:20 2021 daemon.err insmod: module is already loaded - pppox
Tue Nov  9 20:24:20 2021 daemon.err insmod: module is already loaded - pppoe
Tue Nov  9 20:24:20 2021 daemon.info pppd[7208]: Plugin rp-pppoe.so loaded.
Tue Nov  9 20:24:20 2021 daemon.info pppd[7208]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.8
Tue Nov  9 20:24:20 2021 daemon.notice pppd[7208]: pppd 2.4.8 started by root, uid 0
Tue Nov  9 20:24:35 2021 daemon.warn pppd[7208]: Timeout waiting for PADO packets
Tue Nov  9 20:24:35 2021 daemon.err pppd[7208]: Unable to complete PPPoE Discovery
Tue Nov  9 20:24:35 2021 daemon.info pppd[7208]: Exit.
Tue Nov  9 20:24:35 2021 daemon.notice netifd: Interface 'wan' is now down
Tue Nov  9 20:24:35 2021 kern.info kernel: [  542.325696] mt7530 mdio-bus:1f wan: Link is Down
Tue Nov  9 20:24:35 2021 daemon.notice netifd: Interface 'wan' is disabled
Tue Nov  9 20:24:35 2021 daemon.notice netifd: Interface 'wan6' is disabled
Tue Nov  9 20:24:35 2021 kern.info kernel: [  542.337187] mt7530 mdio-bus:1f wan: configuring for phy/gmii link mode
Tue Nov  9 20:24:35 2021 kern.info kernel: [  542.345572] 8021q: adding VLAN 0 to HW filter on device wan
Tue Nov  9 20:24:35 2021 daemon.notice netifd: Interface 'wan' is enabled
Tue Nov  9 20:24:35 2021 daemon.notice netifd: Interface 'wan' is setting up now
Tue Nov  9 20:24:35 2021 daemon.notice netifd: Interface 'wan6' is enabled
Tue Nov  9 20:24:35 2021 daemon.notice netifd: Network device 'wan' link is down
Tue Nov  9 20:24:35 2021 daemon.notice netifd: Interface 'wan' has link connectivity loss
Tue Nov  9 20:24:35 2021 daemon.notice netifd: Interface 'wan6' has link connectivity loss
Tue Nov  9 20:24:36 2021 daemon.notice netifd: Interface 'wan' is now down
Tue Nov  9 20:24:36 2021 daemon.notice netifd: Interface 'wan' is disabled
Tue Nov  9 20:24:36 2021 daemon.notice netifd: Interface 'wan6' is disabled
Tue Nov  9 20:24:36 2021 kern.info kernel: [  542.450252] mt7530 mdio-bus:1f wan: configuring for phy/gmii link mode
Tue Nov  9 20:24:36 2021 kern.info kernel: [  542.457291] 8021q: adding VLAN 0 to HW filter on device wan
Tue Nov  9 20:24:36 2021 daemon.notice netifd: Interface 'wan' is enabled
Tue Nov  9 20:24:36 2021 daemon.notice netifd: Interface 'wan6' is enabled
Tue Nov  9 20:24:40 2021 kern.info kernel: [  546.542830] mt7530 mdio-bus:1f wan: Link is Up - 1Gbps/Full - flow control rx
Tue Nov  9 20:24:40 2021 kern.info kernel: [  546.550115] IPv6: ADDRCONF(NETDEV_CHANGE): wan: link becomes ready
Tue Nov  9 20:24:40 2021 daemon.notice netifd: Network device 'wan' link is up
Tue Nov  9 20:24:40 2021 daemon.notice netifd: Interface 'wan' has link connectivity
Tue Nov  9 20:24:40 2021 daemon.notice netifd: Interface 'wan' is setting up now
Tue Nov  9 20:24:40 2021 daemon.notice netifd: Interface 'wan6' has link connectivity
Tue Nov  9 20:24:40 2021 daemon.err insmod: module is already loaded - slhc
Tue Nov  9 20:24:40 2021 daemon.err insmod: module is already loaded - ppp_generic
Tue Nov  9 20:24:40 2021 daemon.err insmod: module is already loaded - pppox
Tue Nov  9 20:24:40 2021 daemon.err insmod: module is already loaded - pppoe
Tue Nov  9 20:24:40 2021 daemon.info pppd[7415]: Plugin rp-pppoe.so loaded.
Tue Nov  9 20:24:40 2021 daemon.info pppd[7415]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.8
Tue Nov  9 20:24:40 2021 daemon.notice pppd[7415]: pppd 2.4.8 started by root, uid 0
Tue Nov  9 20:24:55 2021 daemon.warn pppd[7415]: Timeout waiting for PADO packets
Tue Nov  9 20:24:55 2021 daemon.err pppd[7415]: Unable to complete PPPoE Discovery
Tue Nov  9 20:24:55 2021 daemon.info pppd[7415]: Exit.
Tue Nov  9 20:24:55 2021 daemon.notice netifd: Interface 'wan' is now down
Tue Nov  9 20:24:55 2021 kern.info kernel: [  561.857345] mt7530 mdio-bus:1f wan: Link is Down
Tue Nov  9 20:24:55 2021 daemon.notice netifd: Interface 'wan' is disabled
Tue Nov  9 20:24:55 2021 daemon.notice netifd: Interface 'wan6' is disabled
Tue Nov  9 20:24:55 2021 kern.info kernel: [  561.868663] mt7530 mdio-bus:1f wan: configuring for phy/gmii link mode
Tue Nov  9 20:24:55 2021 kern.info kernel: [  561.877057] 8021q: adding VLAN 0 to HW filter on device wan
Tue Nov  9 20:24:55 2021 daemon.notice netifd: Interface 'wan' is enabled
Tue Nov  9 20:24:55 2021 daemon.notice netifd: Interface 'wan' is setting up now
Tue Nov  9 20:24:55 2021 daemon.notice netifd: Interface 'wan6' is enabled
Tue Nov  9 20:24:55 2021 daemon.notice netifd: Network device 'wan' link is down
Tue Nov  9 20:24:55 2021 daemon.notice netifd: Interface 'wan' has link connectivity loss
Tue Nov  9 20:24:55 2021 daemon.notice netifd: Interface 'wan6' has link connectivity loss
Tue Nov  9 20:24:55 2021 daemon.notice netifd: Interface 'wan' is now down
Tue Nov  9 20:24:55 2021 daemon.notice netifd: Interface 'wan' is disabled
Tue Nov  9 20:24:55 2021 daemon.notice netifd: Interface 'wan6' is disabled
Tue Nov  9 20:24:55 2021 kern.info kernel: [  561.980323] mt7530 mdio-bus:1f wan: configuring for phy/gmii link mode
Tue Nov  9 20:24:55 2021 kern.info kernel: [  561.987455] 8021q: adding VLAN 0 to HW filter on device wan
Tue Nov  9 20:24:55 2021 daemon.notice netifd: Interface 'wan' is enabled
Tue Nov  9 20:24:55 2021 daemon.notice netifd: Interface 'wan6' is enabled
Tue Nov  9 20:24:58 2021 kern.info kernel: [  565.070373] mt7530 mdio-bus:1f wan: Link is Up - 1Gbps/Full - flow control rx
Tue Nov  9 20:24:58 2021 kern.info kernel: [  565.077559] IPv6: ADDRCONF(NETDEV_CHANGE): wan: link becomes ready
Tue Nov  9 20:24:58 2021 daemon.notice netifd: Network device 'wan' link is up
Tue Nov  9 20:24:58 2021 daemon.notice netifd: Interface 'wan' has link connectivity
Tue Nov  9 20:24:58 2021 daemon.notice netifd: Interface 'wan' is setting up now
Tue Nov  9 20:24:58 2021 daemon.notice netifd: Interface 'wan6' has link connectivity
Tue Nov  9 20:24:58 2021 daemon.err insmod: module is already loaded - slhc
Tue Nov  9 20:24:58 2021 daemon.err insmod: module is already loaded - ppp_generic
Tue Nov  9 20:24:58 2021 daemon.err insmod: module is already loaded - pppox
Tue Nov  9 20:24:58 2021 daemon.err insmod: module is already loaded - pppoe
Tue Nov  9 20:24:58 2021 daemon.info pppd[7594]: Plugin rp-pppoe.so loaded.
Tue Nov  9 20:24:58 2021 daemon.info pppd[7594]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.8
Tue Nov  9 20:24:58 2021 daemon.notice pppd[7594]: pppd 2.4.8 started by root, uid 0
Tue Nov  9 20:25:11 2021 daemon.notice netifd: Network device 'wan' link is down
Tue Nov  9 20:25:11 2021 daemon.notice netifd: Interface 'wan' has link connectivity loss
Tue Nov  9 20:25:11 2021 daemon.notice netifd: Interface 'wan6' has link connectivity loss
Tue Nov  9 20:25:11 2021 kern.info kernel: [  578.382123] mt7530 mdio-bus:1f wan: Link is Down
Tue Nov  9 20:25:12 2021 daemon.err pppd[7594]: select (waitForPADO): Interrupted system call
Tue Nov  9 20:25:12 2021 daemon.warn pppd[7594]: Timeout waiting for PADO packets
Tue Nov  9 20:25:12 2021 daemon.err pppd[7594]: Unable to complete PPPoE Discovery
Tue Nov  9 20:25:12 2021 daemon.info pppd[7594]: Exit.
Tue Nov  9 20:25:12 2021 daemon.notice netifd: Interface 'wan' is now down
Tue Nov  9 20:25:12 2021 daemon.notice netifd: Interface 'wan' is disabled
Tue Nov  9 20:25:12 2021 daemon.notice netifd: Interface 'wan6' is disabled
Tue Nov  9 20:25:12 2021 kern.info kernel: [  578.503926] mt7530 mdio-bus:1f wan: configuring for phy/gmii link mode
Tue Nov  9 20:25:12 2021 kern.info kernel: [  578.511024] 8021q: adding VLAN 0 to HW filter on device wan
Tue Nov  9 20:25:12 2021 daemon.notice netifd: Interface 'wan' is enabled
Tue Nov  9 20:25:12 2021 daemon.notice netifd: Interface 'wan6' is enabled
Tue Nov  9 20:25:19 2021 kern.info kernel: [  585.678273] mt7530 mdio-bus:1f wan: Link is Up - 1Gbps/Full - flow control rx
Tue Nov  9 20:25:19 2021 kern.info kernel: [  585.685458] IPv6: ADDRCONF(NETDEV_CHANGE): wan: link becomes ready
Tue Nov  9 20:25:19 2021 daemon.notice netifd: Network device 'wan' link is up
Tue Nov  9 20:25:19 2021 daemon.notice netifd: Interface 'wan' has link connectivity
Tue Nov  9 20:25:19 2021 daemon.notice netifd: Interface 'wan' is setting up now
Tue Nov  9 20:25:19 2021 daemon.notice netifd: Interface 'wan6' has link connectivity
Tue Nov  9 20:25:19 2021 daemon.err insmod: module is already loaded - slhc
Tue Nov  9 20:25:19 2021 daemon.err insmod: module is already loaded - ppp_generic
Tue Nov  9 20:25:19 2021 daemon.err insmod: module is already loaded - pppox
Tue Nov  9 20:25:19 2021 daemon.err insmod: module is already loaded - pppoe
Tue Nov  9 20:25:19 2021 daemon.info pppd[7787]: Plugin rp-pppoe.so loaded.
Tue Nov  9 20:25:19 2021 daemon.info pppd[7787]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.8
Tue Nov  9 20:25:19 2021 daemon.notice pppd[7787]: pppd 2.4.8 started by root, uid 0
Tue Nov  9 20:25:34 2021 daemon.warn pppd[7787]: Timeout waiting for PADO packets
Tue Nov  9 20:25:34 2021 daemon.err pppd[7787]: Unable to complete PPPoE Discovery
Tue Nov  9 20:25:34 2021 daemon.info pppd[7787]: Exit.
Tue Nov  9 20:25:34 2021 daemon.notice netifd: Interface 'wan' is now down
Tue Nov  9 20:25:34 2021 kern.info kernel: [  601.005943] mt7530 mdio-bus:1f wan: Link is Down
Tue Nov  9 20:25:34 2021 daemon.notice netifd: Interface 'wan' is disabled
Tue Nov  9 20:25:34 2021 daemon.notice netifd: Interface 'wan6' is disabled
Tue Nov  9 20:25:34 2021 kern.info kernel: [  601.018740] mt7530 mdio-bus:1f wan: configuring for phy/gmii link mode
Tue Nov  9 20:25:34 2021 kern.info kernel: [  601.026066] 8021q: adding VLAN 0 to HW filter on device wan
Tue Nov  9 20:25:34 2021 daemon.notice netifd: Interface 'wan' is enabled
Tue Nov  9 20:25:34 2021 daemon.notice netifd: Interface 'wan' is setting up now
Tue Nov  9 20:25:34 2021 daemon.notice netifd: Interface 'wan6' is enabled
Tue Nov  9 20:25:34 2021 daemon.notice netifd: Network device 'wan' link is down
Tue Nov  9 20:25:34 2021 daemon.notice netifd: Interface 'wan' has link connectivity loss
Tue Nov  9 20:25:34 2021 daemon.notice netifd: Interface 'wan6' has link connectivity loss
Tue Nov  9 20:25:34 2021 daemon.notice netifd: Interface 'wan' is now down
Tue Nov  9 20:25:34 2021 daemon.notice netifd: Interface 'wan' is disabled
Tue Nov  9 20:25:34 2021 daemon.notice netifd: Interface 'wan6' is disabled
Tue Nov  9 20:25:34 2021 kern.info kernel: [  601.135413] mt7530 mdio-bus:1f wan: configuring for phy/gmii link mode
Tue Nov  9 20:25:34 2021 kern.info kernel: [  601.142774] 8021q: adding VLAN 0 to HW filter on device wan
Tue Nov  9 20:25:34 2021 daemon.notice netifd: Interface 'wan' is enabled
Tue Nov  9 20:25:34 2021 daemon.notice netifd: Interface 'wan6' is enabled
Tue Nov  9 20:25:38 2021 kern.info kernel: [  605.230287] mt7530 mdio-bus:1f wan: Link is Up - 1Gbps/Full - flow control rx
Tue Nov  9 20:25:38 2021 kern.info kernel: [  605.237473] IPv6: ADDRCONF(NETDEV_CHANGE): wan: link becomes ready
Tue Nov  9 20:25:38 2021 daemon.notice netifd: Network device 'wan' link is up
Tue Nov  9 20:25:38 2021 daemon.notice netifd: Interface 'wan' has link connectivity
Tue Nov  9 20:25:38 2021 daemon.notice netifd: Interface 'wan' is setting up now
Tue Nov  9 20:25:38 2021 daemon.notice netifd: Interface 'wan6' has link connectivity
Tue Nov  9 20:25:38 2021 daemon.err insmod: module is already loaded - slhc
Tue Nov  9 20:25:38 2021 daemon.err insmod: module is already loaded - ppp_generic
Tue Nov  9 20:25:38 2021 daemon.err insmod: module is already loaded - pppox
Tue Nov  9 20:25:38 2021 daemon.err insmod: module is already loaded - pppoe
Tue Nov  9 20:25:38 2021 daemon.info pppd[8040]: Plugin rp-pppoe.so loaded.
Tue Nov  9 20:25:38 2021 daemon.info pppd[8040]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.8
Tue Nov  9 20:25:38 2021 daemon.notice pppd[8040]: pppd 2.4.8 started by root, uid 0```

Remove option type bridge from the wan interface block. If ISP does not support IPv6, remove wan6 entirely.

You can install the tcpdump package to observe any packets arriving from the modem, and whether or not they are tagged.
tcpdump -vv -e vlan -i wan

Thanks for the ideas. I tried setting up IPv6 on the ISP modem (no OpenWRT router involved) and wasn't able to get it to work, plus it's disabled by default. So I'm guessing it's not supported in my area (not surprising), and even if it is, it's not required. Turned off IPv6 everywhere I could find it in both modem and router for the transparent setup, no dice.

Turned off the bridge option on the router WAN, still doesn't work, but I AM seeing RX/TX on the interface after doing that.

Used tcpdump to check for VLAN tags and found something... weird. Running the command as given, I received no output at first, which I assume means no VLAN tag. But it looks like the port is crashing (or resetting or something) every 5-10 seconds and I don't understand what it's trying to do. I removed the -e vlan and ran it again. Current config and results below.

/etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fd79:a1b1:17a2::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipv6 '0'
        option ipaddr '192.168.1.1'
        option delegate '0'

config interface 'wan'
        option device 'wan'
        option proto 'pppoe'
        option username 'REDACTED'
        option password 'REDACTED'
        option ipv6 '0'
        option delegate '0'

config interface 'guest'
        option proto 'static'
        option device 'wlan0-1'
        option netmask '255.255.255.0'
        option type 'bridge'
        option ipaddr '192.168.2.1'
        option ipv6 '0'
        option delegate '0'

tcpdump -vv -i wan

tcpdump: listening on wan, link-type EN10MB (Ethernet), capture size 262144 bytes
21:12:39.405660 IP (tos 0xc0, ttl 1, id 0, offset 0, flags [none], proto IGMP (2), length 36, options (RA))
    192.168.0.1 > 224.0.0.1: igmp query v3
21:12:39.406033 IP6 (hlim 1, next-header Options (0) payload length: 36) fe80::8a6a:e3ff:fe84:82f9 > ip6-allnodes: HBH (rtalert: 0x0000) (padn) [icmp6 sum ok] ICMP6, multicast listener query v2 [max resp delay=10000] [gaddr :: robustness=2 qqi=125]
21:12:44.284322 IP6 (hlim 1, next-header Options (0) payload length: 96) fe80::8a6a:e3ff:fe84:82f9 > ff02::16: HBH (rtalert: 0x0000) (padn) [icmp6 sum ok] ICMP6, multicast listener report v2, 4 group record(s) [gaddr ff02::16 to_ex { }] [gaddr ff02::1:ff00:0 to_ex { }] [gaddr ff02::1:ff84:82f9 to_ex { }] [gaddr ip6-allrouters to_ex { }]
21:12:44.395589 PPPoE PADI [Service-Name] [Host-Uniq 0x4E160000]
21:12:49.399538 PPPoE PADI [Service-Name] [Host-Uniq 0x4E160000]
21:12:50.274859 IP (tos 0x0, ttl 4, id 52391, offset 0, flags [DF], proto UDP (17), length 122)
    192.168.0.1.60914 > 239.255.255.250.1900: [udp sum ok] UDP, length 94
21:12:50.376641 IP (tos 0x0, ttl 4, id 52396, offset 0, flags [DF], proto UDP (17), length 122)
    192.168.0.1.60914 > 239.255.255.250.1900: [udp sum ok] UDP, length 94
21:12:50.477529 IP (tos 0x0, ttl 4, id 52403, offset 0, flags [DF], proto UDP (17), length 160)
    192.168.0.1.60914 > 239.255.255.250.1900: [udp sum ok] UDP, length 132
21:12:50.578215 IP (tos 0x0, ttl 4, id 52405, offset 0, flags [DF], proto UDP (17), length 160)
    192.168.0.1.60914 > 239.255.255.250.1900: [udp sum ok] UDP, length 132
21:12:54.403527 PPPoE PADI [Service-Name] [Host-Uniq 0x4E160000]
21:13:03.754211 IP6 (hlim 1, next-header Options (0) payload length: 96) fe80::26a:e300:284:82f9 > ff02::16: HBH (rtalert: 0x0000) (padn) [icmp6 sum ok] ICMP6, multicast listener report v2, 4 group record(s) [gaddr ff02::1:ff00:0 to_ex { }] [gaddr ff02::1:ff84:82f9 to_ex { }] [gaddr ff05::2 to_ex { }] [gaddr ip6-allrouters to_ex { }]
21:13:03.919523 PPPoE PADI [Service-Name] [Host-Uniq 0xAD160000]
tcpdump: pcap_loop: The interface went down
12 packets captured
12 packets received by filter
0 packets dropped by kernel

It seems to run for about 5 seconds and die, with similar results each time. 192.168.0.1 is the LAN address of the ISP modem before I bridged it. No idea what anything else is, or why I'm seeing IPv6 addresses on the interface since (I think) I disabled IPv6. For comparison, I ran tcpdump on the LAN interface, and the behavior was more as expected. Traffic looked normal and it didn't crash every 5 seconds.

What the heck is going on?

Did you test the WR2100 with stock firmware with the bridge modem, prior to flashing with OpenWrt ?

No, I didn't. Would have if I'd had any idea this was going to turn into a thing, but here we are. I guess I can try to get stock back on there, but the Cudy firmware is based on OpenWRT anyway, so it might not matter.

Well, i would suggest going back to stock firmware even if it's based on openwrt. Just to be sure it's not the current firmware. You did say you saw Rx Tx activity upon removing the option option type bridge.

But ultimately i would suggest you to borrow a non openwrt router from friend if you can't buy it, just to see if it's not the router hardware itself.

You said, The router WAN port works at another location with a cable modem the cable modem uses dhcp ? no pppoe involved ?

I guess I'll try to see if I can revert to stock firmware. If I can get somebody to loan me their router, I'll try that too, I just haven't been able to so far.

Correct, the WAN port works with DHCP at a different location with a different ISP.

As far I can see (https://www.centurylink.com/home/help/internet/modems-and-routers/advanced-setup-2/wan-settings.html) Your modem work with taged bridge . So under Openwrt Router only need to be set wan config is:

config interface 'wan'
        option device 'wan'
        option proto 'pppoe'
        option username 'username@isp'
        option password 'fancypassword'
        option ipv6 '0'

config device
        option name 'wan'
        option mtu '1500'

If that doesn't work .Please revert your modem to the factory and setup it once again as bridged modem with vlan201 .

in case your WAN port on router is failing in OpenWrt You can pick any other to work as one :slight_smile:

The pppoe driver restarts the port if the server (ISP) does not respond.
Have you tried wan.210 with no option bridge yet?