Problem with tp link 1043nd v2.1 cant remove or instal new firm

hello guys so i have router with open wrt but i dont know the password i want to reinstal the open wrt or instal stock firm which is the easier way... so i tracked the ip from router with program wireshark it says the ip for router ... i write this ip to Ethernet settings and select it in Tftp and when i start the router by hold reset and power on i dont see any log in tftp so my problem is that i cant connect the router with tftp :slight_smile: what can be the problem

here is the version

This is most likely the IP your PC has, because it was unable to acquire from dhcp. Moreover LLMNR is a protocol primarily in Windows.

then what to do :slight_smile: ?

See if this helps.

1 Like

@digitaldevil, welcome to the community!

cant connect router to tftp ... i tryed with this ip 0.66

i saw all this shit cant understand it cant understand where to write this commands ...
i ask for help you guys who know this things ... i have this router i have this firmware and i need password reset or firmware stock ...which is the easier way . i need you to tell me which way to do and what programs i need to instal :slight_smile: big post for many ways doesnt help me cus i dont know what i need

  • What commands?
  • Your picture doesn't appear to be OpenWrt, so not sure if any commands would help anyway - I wanted you to try a general factory reset to default configs

  • Let us know, does this work or not?
  • Also explain what occured when you tried to follow @trendy's link?

Please explain the process you used in more detail.

Can't help much, since you didn't show us any pic of OpenWrt. We can only help you to install official OpenWrt firmware. Also, if you don't know what you need, this is going to be very difficult. Incessantly replying you don't know isn't helpful. So each time, please inform us of what you've attempted, etc.

so the reset is 1st thing i did pressed it for 10 for 15 for 30 sec nothing , in wifi networks i see it as openwrt name i saw in google that luci firmware is an openwrt or its not ? other way i tried this with changing my ethernet ip to 0.66 and downloaded stock firm for my version router and i used tftp selected ethernet browsed the foloder with firmware , i went to log in tftp to see what name firmware could need by pressing reset button and turning on router then keep pressing reset for 5 more seconds but in tftp log nothing happens and i think ip should be wrong or .. dont know why cant connect router with tftp , if i can instal official openwrt over this i could do it

LuCI is not a firmware, it's web GUI software - and on official OpenWrt it looks like this:

  • So, as you can see, your picture of LuCI is very different.
  • Perhaps you should try the stock username/password, as it doesn't seem to be OpenWrt

Is your firewall disabled on the computer?

If you can successfully TFTP, you can install OpenWrt or Stock.

1 Like

thats the problem to connect to tftp , i used stock admin admin doesnt work even tried only root for username , my firewall is off

Pause...TFTP doesn't use credentials.

What are you talking about?

cant do can successfully TFTP

  • Please use full sentences. I have no clue what your response means, especially as it would relate to my statement about flashing either firmware. I guess you meant to say: "I cannot TFTP successfully."
  • Are you having problems following the TFTP instructions?
    • If so, clearly explain, perhaps attach screenshots and/or paste the errors.
  • Also, you didn't clarify what credential issue you're having. To be clear - you do not have to enter the router's username/password in order to to TFTP new firmware to the router.
  • Do you see anything running Wireshark?

If you're using Windows, perhaps this software is better:

If you're still having difficulties, you may have to purchase a serial cable.

i understand what are the instruction for the tftp i do everything it says and nothing happnes in tftp
you said -

and i answered about that , i dont know password and username to access router settings this is my issue :slight_smile and the issue with tftp i dont know what is it i do every step

OK, gotcha. Let's address these as separate issues to end confusion.

You listed them already. And to reiterate, the default on OpenWrt is root/<blank>. If they didn't work after attempting a reset to defaults, let's just skip this.


  • What software have you installed and tried to use?
  • What Operating System is your laptop running?
  • Please explain exactly which step(s) you're having an
    issue with.

Also, I suggest using TFTPD64 (I surmise you're using Windows, because you didn't say no). I find that software to be quite simple, fool-proof and straightforward.

i use tftpd32, win 8 64bit, i dont have issues in steps i do everything but i dont see anything in log when start router with tftpd,

just tried with tftpd64 same like 32 :slight_smile: nothing happens

Pause, tftpd64 and tftpd32 are the same program...


Let me ask like this:

  • We know you're using Jounin's tftpd (either 32 or 64 bit)
  • We know you're using Windows
  • We know your firewall's turned off
  • You plugged into LAN
  • We know you set the computer to
  • You placed the factory image in the TFTPD running folder

Now please explain what you mean by "nothing happens" (please mention which step is failing in your response and give details)?

For example, please clearly state if the LED lights flashed for you.

Also if able, show the Wireshark that displays the failing TFTP request from the router.

  • Also confirm that your device's hardware version is 1.8 or greater, which is necessary to perform this
  • Lastly, if this is too much, perhaps you should ask the OEM forum on how to reset to defaults in order to regain access

nothing happens cus i saw in youtube that when you turn router with pressing reset button you should see some text in tftpd log this is when the router need some special name .bin if the name of the firmware is the same then it will start uploading the firm with % but nothing of this happens :slight_smile: logic says maybe it doesnt connected with router , the firm is not stock and i see luci v2.4 i dont know what firm is this :slight_smile: and how can be resetted to default , my tp link 1043 is v2.1