Problem with station mode

hi there
i install openwrt on 20 device i work with station wds mode

this config of my wireless main ap mode

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option txpower '26'
        option htmode 'VHT80'
        option disabled '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option wds '1'
        option mode 'ap'
        option ssid 'SW-MESH-LINK'
        option hidden '1'
        option encryption 'psk2'
        option key 'XXXXXXXXXXXXXXX'

and this config for station mode which connect with first one they connect with 5 ghz radio

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option txpower '28'
        option htmode 'VHT80'
        option disabled '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
    option wds '1'
        option mode 'sta'
        option ssid 'SW-MESH-LINK'
        option encryption 'psk2'
    option key 'swlink@112233@332211'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/qca956x_wmac'
        option htmode 'HT20'
        option disabled '0'

i get connection and the signal between these device is -76

this ping from station to ap

64 bytes from 192.168.1.12: seq=3 ttl=64 time=11.246 ms
64 bytes from 192.168.1.12: seq=4 ttl=64 time=29.120 ms
64 bytes from 192.168.1.12: seq=5 ttl=64 time=3.064 ms
64 bytes from 192.168.1.12: seq=6 ttl=64 time=123.548 ms
64 bytes from 192.168.1.12: seq=7 ttl=64 time=15.371 ms
64 bytes from 192.168.1.12: seq=8 ttl=64 time=437.198 ms
64 bytes from 192.168.1.12: seq=9 ttl=64 time=8.347 ms
64 bytes from 192.168.1.12: seq=11 ttl=64 time=67.005 ms
64 bytes from 192.168.1.12: seq=12 ttl=64 time=2.077 ms
64 bytes from 192.168.1.12: seq=13 ttl=64 time=4.691 ms
64 bytes from 192.168.1.12: seq=14 ttl=64 time=1.256 ms
64 bytes from 192.168.1.12: seq=15 ttl=64 time=2.661 ms
64 bytes from 192.168.1.12: seq=16 ttl=64 time=2.893 ms
64 bytes from 192.168.1.12: seq=17 ttl=64 time=30.442 ms
64 bytes from 192.168.1.12: seq=18 ttl=64 time=2.991 ms
64 bytes from 192.168.1.12: seq=19 ttl=64 time=4.495 ms
64 bytes from 192.168.1.12: seq=20 ttl=64 time=1.056 ms
64 bytes from 192.168.1.12: seq=21 ttl=64 time=2.682 ms
64 bytes from 192.168.1.12: seq=22 ttl=64 time=9.689 ms
64 bytes from 192.168.1.12: seq=23 ttl=64 time=14.275 ms
64 bytes from 192.168.1.12: seq=24 ttl=64 time=1.694 ms
64 bytes from 192.168.1.12: seq=25 ttl=64 time=4.414 ms
64 bytes from 192.168.1.12: seq=26 ttl=64 time=1.886 ms
64 bytes from 192.168.1.12: seq=27 ttl=64 time=1.260 ms
64 bytes from 192.168.1.12: seq=28 ttl=64 time=1.320 ms
64 bytes from 192.168.1.12: seq=29 ttl=64 time=3.514 ms
64 bytes from 192.168.1.12: seq=30 ttl=64 time=1.483 ms
64 bytes from 192.168.1.12: seq=31 ttl=64 time=3.914 ms
^C
--- 192.168.1.12 ping statistics ---
32 packets transmitted, 31 packets received, 3% packet loss
round-trip min/avg/max = 1.056/25.806/437.198 ms

i have 2 main problem :

1- in the station side the internet connection is very very slow
2- i have problem with all openwrt software its some android device didnt get internet connection but when i ping to google dns i get ping but when i open goolge search or youtube theirs no connection but when i connect with vpn connection i these device i get internet access !! :sweat::weary:

NOTE : i disable firewall , dhcp for each device

is their any help with this problem

How did you determine that from the router side?

Did you configure a WAN DNS server?

in station mode i config 2 wireless interface the first for station mode and its work with 5ghz (radio0) the second interface is ap and its work with 2.4 ghz (radio1) this for client , i connect to the second interface and i use it and i see its very slow

Did you configure a WAN DNS server?

no i didnt configure dns server i wan side

This is why you can't access sites via domain name.

can u explain what u mean by dns server for wan
i add google dns server for my main router is it ok? and this dns over dhcp server

Please show the configuration:

ip a; ip r
uci show network
uci show firewall
uci show wireless
uci show dhcp
2 Likes
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel master br-lan state UP qlen 1000
    link/ether 78:8a:20:20:63:31 brd ff:ff:ff:ff:ff:ff
5: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 78:8a:20:20:63:31 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.12/18 brd 192.168.63.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fdba:27d:8a7d::1/60 scope global
       valid_lft forever preferred_lft forever
    inet6 fe80::7a8a:20ff:fe20:6331/64 scope link
       valid_lft forever preferred_lft forever
6: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 78:8a:20:22:63:31 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::7a8a:20ff:fe22:6331/64 scope link
       valid_lft forever preferred_lft forever
7: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 78:8a:20:21:63:31 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::7a8a:20ff:fe21:6331/64 scope link
       valid_lft forever preferred_lft forever
15: wlan0.sta1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UNKNOWN qlen 1000
    link/ether 78:8a:20:22:63:31 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::7a8a:20ff:fe22:6331/64 scope link
       valid_lft forever preferred_lft forever
default via 192.168.1.1 dev br-lan
192.168.0.0/18 dev br-lan scope link  src 192.168.1.12

network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fdba:027d:8a7d::/48'
network.lan=interface
network.lan.type='bridge'
network.lan.ifname='eth0'
network.lan.proto='static'
network.lan.ipaddr='192.168.1.12'
network.lan.netmask='255.255.192.0'
network.lan.gateway='192.168.1.1'
network.lan.dns='8.8.8.8'
network.lan.ip6assign='60'

firewall.@defaults[0]=defaults
firewall.@defaults[0].syn_flood='1'
firewall.@defaults[0].input='ACCEPT'
firewall.@defaults[0].output='ACCEPT'
firewall.@defaults[0].forward='REJECT'
firewall.@zone[0]=zone
firewall.@zone[0].name='lan'
firewall.@zone[0].network='lan'
firewall.@zone[0].input='ACCEPT'
firewall.@zone[0].output='ACCEPT'
firewall.@zone[0].forward='ACCEPT'
firewall.@zone[1]=zone
firewall.@zone[1].name='wan'
firewall.@zone[1].network='wan' 'wan6'
firewall.@zone[1].input='REJECT'
firewall.@zone[1].output='ACCEPT'
firewall.@zone[1].forward='REJECT'
firewall.@zone[1].masq='1'
firewall.@zone[1].mtu_fix='1'
firewall.@forwarding[0]=forwarding
firewall.@forwarding[0].src='lan'
firewall.@forwarding[0].dest='wan'
firewall.@rule[0]=rule
firewall.@rule[0].name='Allow-DHCP-Renew'
firewall.@rule[0].src='wan'
firewall.@rule[0].proto='udp'
firewall.@rule[0].dest_port='68'
firewall.@rule[0].target='ACCEPT'
firewall.@rule[0].family='ipv4'
firewall.@rule[1]=rule
firewall.@rule[1].name='Allow-Ping'
firewall.@rule[1].src='wan'
firewall.@rule[1].proto='icmp'
firewall.@rule[1].icmp_type='echo-request'
firewall.@rule[1].family='ipv4'
firewall.@rule[1].target='ACCEPT'
firewall.@rule[2]=rule
firewall.@rule[2].name='Allow-IGMP'
firewall.@rule[2].src='wan'
firewall.@rule[2].proto='igmp'
firewall.@rule[2].family='ipv4'
firewall.@rule[2].target='ACCEPT'
firewall.@rule[3]=rule
firewall.@rule[3].name='Allow-DHCPv6'
firewall.@rule[3].src='wan'
firewall.@rule[3].proto='udp'
firewall.@rule[3].src_ip='fc00::/6'
firewall.@rule[3].dest_ip='fc00::/6'
firewall.@rule[3].dest_port='546'
firewall.@rule[3].family='ipv6'
firewall.@rule[3].target='ACCEPT'
firewall.@rule[4]=rule
firewall.@rule[4].name='Allow-MLD'
firewall.@rule[4].src='wan'
firewall.@rule[4].proto='icmp'
firewall.@rule[4].src_ip='fe80::/10'
firewall.@rule[4].icmp_type='130/0' '131/0' '132/0' '143/0'
firewall.@rule[4].family='ipv6'
firewall.@rule[4].target='ACCEPT'
firewall.@rule[5]=rule
firewall.@rule[5].name='Allow-ICMPv6-Input'
firewall.@rule[5].src='wan'
firewall.@rule[5].proto='icmp'
firewall.@rule[5].icmp_type='echo-request' 'echo-reply' 'destination-unreachable' 'packet-too-big' 'time-exceeded' 'bad-header' 'unknown-header-type' 'router-solicitation' 'neighbour-solicitation' 'router-advertisement' 'neighbour-advertisement'
firewall.@rule[5].limit='1000/sec'
firewall.@rule[5].family='ipv6'
firewall.@rule[5].target='ACCEPT'
firewall.@rule[6]=rule
firewall.@rule[6].name='Allow-ICMPv6-Forward'
firewall.@rule[6].src='wan'
firewall.@rule[6].dest='*'
firewall.@rule[6].proto='icmp'
firewall.@rule[6].icmp_type='echo-request' 'echo-reply' 'destination-unreachable' 'packet-too-big' 'time-exceeded' 'bad-header' 'unknown-header-type'
firewall.@rule[6].limit='1000/sec'
firewall.@rule[6].family='ipv6'
firewall.@rule[6].target='ACCEPT'
firewall.@rule[7]=rule
firewall.@rule[7].name='Allow-IPSec-ESP'
firewall.@rule[7].src='wan'
firewall.@rule[7].dest='lan'
firewall.@rule[7].proto='esp'
firewall.@rule[7].target='ACCEPT'
firewall.@rule[8]=rule
firewall.@rule[8].name='Allow-ISAKMP'
firewall.@rule[8].src='wan'
firewall.@rule[8].dest='lan'
firewall.@rule[8].dest_port='500'
firewall.@rule[8].proto='udp'
firewall.@rule[8].target='ACCEPT'
firewall.@include[0]=include
firewall.@include[0].path='/etc/firewall.user'

wireless.radio0=wifi-device
wireless.radio0.type='mac80211'
wireless.radio0.channel='36'
wireless.radio0.hwmode='11a'
wireless.radio0.path='pci0000:00/0000:00:00.0'
wireless.radio0.txpower='26'
wireless.radio0.htmode='VHT80'
wireless.radio0.disabled='0'
wireless.default_radio0=wifi-iface
wireless.default_radio0.device='radio0'
wireless.default_radio0.network='lan'
wireless.default_radio0.wds='1'
wireless.default_radio0.mode='ap'
wireless.default_radio0.ssid='SW-MESH-LINK'
wireless.default_radio0.hidden='1'
wireless.default_radio0.encryption='psk2'
wireless.default_radio0.key='swlink@112233@332211'
wireless.radio1=wifi-device
wireless.radio1.type='mac80211'
wireless.radio1.channel='11'
wireless.radio1.hwmode='11g'
wireless.radio1.path='platform/qca956x_wmac'
wireless.radio1.htmode='HT20'
wireless.radio1.disabled='0'
wireless.default_radio1=wifi-iface
wireless.default_radio1.device='radio1'
wireless.default_radio1.network='lan'
wireless.default_radio1.mode='ap'
wireless.default_radio1.wds='1'
wireless.default_radio1.ssid='SKYWAVE'
wireless.default_radio1.encryption='none'

dhcp.@dnsmasq[0]=dnsmasq
dhcp.@dnsmasq[0].domainneeded='1'
dhcp.@dnsmasq[0].boguspriv='1'
dhcp.@dnsmasq[0].filterwin2k='0'
dhcp.@dnsmasq[0].localise_queries='1'
dhcp.@dnsmasq[0].rebind_protection='1'
dhcp.@dnsmasq[0].rebind_localhost='1'
dhcp.@dnsmasq[0].local='/lan/'
dhcp.@dnsmasq[0].domain='lan'
dhcp.@dnsmasq[0].expandhosts='1'
dhcp.@dnsmasq[0].nonegcache='0'
dhcp.@dnsmasq[0].authoritative='1'
dhcp.@dnsmasq[0].readethers='1'
dhcp.@dnsmasq[0].leasefile='/tmp/dhcp.leases'
dhcp.@dnsmasq[0].resolvfile='/tmp/resolv.conf.auto'
dhcp.@dnsmasq[0].localservice='1'
dhcp.@dnsmasq[0].ignore='1'
dhcp.lan=dhcp
dhcp.lan.interface='lan'
dhcp.lan.start='100'
dhcp.lan.limit='150'
dhcp.lan.leasetime='12h'
dhcp.lan.dhcpv6='server'
dhcp.lan.ra='server'
dhcp.lan.ignore='1'
dhcp.wan=dhcp
dhcp.wan.interface='wan'
dhcp.wan.ignore='1'
dhcp.odhcpd=odhcpd
dhcp.odhcpd.maindhcp='0'
dhcp.odhcpd.leasefile='/tmp/hosts/odhcpd'
dhcp.odhcpd.leasetrigger='/usr/sbin/odhcpd-update'
dhcp.odhcpd.ignore='1'

this config for main ap which station device connect on it

I'm not an expert in wireless setup, but network+firewall parts look OK.
However I suspect the problem could be caused by the network topology.
Building a single L2-network above cascading WiFi doesn't sound reliable.


Further troubleshooting requires client-side diagnostics.
Something like this:

ip a; ip r
nslookup google.com
nslookup google.com 8.8.8.8
ping -qc10 8.8.8.8
ping -qc10 google.com

hi there
its solved i change distance between ap and and they work fine .

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.