Problem with setting up ipv6 and pppoe

Not sure if it's ppoe related, but... I just managed to get the ppoe credentials from my ISP and now I don't need the ISP router.
IPv4 works great and I have internet just fine, but IPv6 is not working, not even from inside my openwrt router, I can't ping www.google.com -6

I know it has to be a configuration issue, since before it was working, at least from openwrt, can someone help me here?

The interfaces page, on wan shows:
IPv4: 100.xxx.xxx.xxx/32
IPv6: fe80::xxxx:xxxx:xxxx:xxxx/128
IPv6: 2a12:xxxx:xxxx:xxxx::1/64
IPv6: dda1:xxxx:xxxx:xxxx::1/64

My network file has:
config interface 'wan'
option proto 'pppoe'
option device 'eth0.20'
option type 'bridge'
option username 'xxxxxx'
option password 'xxxxxx'
option ipv6 'auto'
option peerdns '0'
list dns '1.1.1.1'
list dns '1.0.0.1'
list dns '8.8.8.8'
list dns '8.8.4.4'
option ip6assign '64'

What happen if you ping an IPv6 address (like Google IPv6?)

PING www.google.com (2a00:1450:4003:800::2004): 56 data bytes
ping: sendto: Network unreachable

Are you pinging from the router or from a LAN device?

Don't put an ip6assign on a wan interface. That is for lan-like interfaces.

ifstatus wan and ifstatus wan_6 would be useful to see what you have from the ISP.

1 Like

The ping was from the router. I disabled ip6assign now, still same result.

ifstatus wan:

{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 1541,
        "l3_device": "pppoe-wan",
        "proto": "pppoe",
        "device": "eth0.20",
        "updated": [
                "addresses",
                "routes"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [
                {
                        "address": "100.xxx.xxx.xxx",
                        "mask": 32,
                        "ptpaddress": "10.xxx.xxx.xxx"
                }
        ],
        "ipv6-address": [
                {
                        "address": "fe80::xxxx:xxxx:xxxx:xxxx",
                        "mask": 128
                }
        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "0.0.0.0",
                        "mask": 0,
                        "nexthop": "10.xxx.xxx.xxx",
                        "source": "0.0.0.0/0"
                }
        ],
        "dns-server": [
                "1.1.1.1",
                "1.0.0.1",
                "8.8.8.8",
                "8.8.4.4"
        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [
                        "100.90.1.1",
                        "100.100.1.1"
                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {

        }
}

ifstatus wan_6:

{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": true,
        "uptime": 1675,
        "l3_device": "pppoe-wan",
        "proto": "dhcpv6",
        "device": "pppoe-wan",
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [
                {
                        "address": "2a12:xxxx:xxxx:xxxx::xxxx:xxxx",
                        "mask": 128
                }
        ],
        "ipv6-prefix": [
                {
                        "address": "2a12:xxxx:xxxx:xxxx::",
                        "mask": 56,
                        "class": "wan_6",
                        "assigned": {
                                "guest": {
                                        "address": "2a12:xxxx:xxxx:xxxx::",
                                        "mask": 62
                                },
                                "lan": {
                                        "address": "2a12:xxxx:xxxx:xxxx::",
                                        "mask": 62
                                }
                        }
                }
        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::1",
                        "metric": 512,
                        "valid": 1634,
                        "source": "2a12:xxxx:xxxx:xxxx::/56"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::1",
                        "metric": 512,
                        "valid": 1634,
                        "source": "2a12:xxxx:xxxx:xxxx::xxxx:xxxx/128"
                }
        ],
        "dns-server": [

        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [
                        "2a12:26c0:0:1::1",
                        "2a12:26c0:0:2::1"
                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {
                "zone": "wan",
                "passthru": "001700202a1226c00000000100000000000000012a1226c0000000020000000000000001",
                "zone": "wan"
        }
}

Is wan_6 member of wan firewall zone?

it wasn't, but I added now, and the problem still remains.
Also, wan_6 was created automatically, it says "Protocol: Virtual dynamic interface (DHCPv6 client)", I can't really edit it

Let's have a better look.

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; \
uci export dhcp; uci export firewall; \
nft list ruleset; \
ip -6 addr ; ip -6 ro li tab all ; ip -6 ru

Here it is:

{
        "kernel": "5.15.167",
        "hostname": "gaia-router-principal",
        "system": "ARMv8 Processor rev 3",
        "model": "Raspberry Pi 4 Model B Rev 1.2",
        "board_name": "raspberrypi,4-model-b",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.5",
                "revision": "r24106-10cc5fcd00",
                "target": "bcm27xx/bcm2711",
                "description": "OpenWrt 23.05.5 r24106-10cc5fcd00"
        }
}
package network

config interface 'loopback'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
        option device 'lo'

config globals 'globals'
        option ula_prefix 'dda1:12ea:dca4::/48'

config interface 'lan'
        option proto 'static'
        option stp '1'
        option ipaddr '192.168.11.1'
        option netmask '255.255.255.0'
        option device 'eth1.1'
        option ip6assign '62'

config interface 'wan'
        option proto 'pppoe'
        option device 'eth0.20'
        option type 'bridge'
        option username 'xxxxxxx'
        option password 'xxxxxxx'
        option ipv6 'auto'
        option peerdns '0'
        list dns '1.1.1.1'
        list dns '1.0.0.1'
        list dns '8.8.8.8'
        list dns '8.8.4.4'

config device
        option name 'eth1'

config device
        option name 'eth0'
        option acceptlocal '1'

config interface 'wwan'
        option proto 'dhcp'
        option device 'eth1.4'

config device
        option type '8021q'
        option ifname 'eth1'
        option vid '1'
        option name 'eth1.1'

config device
        option type '8021q'
        option ifname 'eth1'
        option vid '2'
        option name 'eth1.2'

config device
        option type '8021q'
        option ifname 'eth1'
        option vid '3'
        option name 'eth1.3'

config device
        option type '8021q'
        option ifname 'eth1'
        option vid '4'
        option name 'eth1.4'

config interface 'guest'
        option proto 'static'
        option device 'eth1.2'
        option ipaddr '192.168.10.1'
        option netmask '255.255.255.0'
        option ip6assign '62'

config interface 'iot'
        option proto 'static'
        option device 'eth1.3'
        option ipaddr '192.168.9.1'
        option netmask '255.255.255.0'
        option delegate '0'

config interface 'ZeroTierPAA2'
        option proto 'none'
        option device 'zt3d5embso'

config device
        option type '8021q'
        option ifname 'eth0'
        option vid '20'
        option name 'eth0.20'
        option ip6segmentrouting '1'

package dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option localservice '1'
        option ednspacket_max '1232'
        option quietdhcp '1'
        option dnssec '1'
        option cachesize '5000'
        option sequential_ip '1'
        option allservers '1'
        option nonegcache '1'
        list notinterface 'wan'
        list notinterface 'wan6'
        list notinterface 'wwan'
        option confdir '/tmp/dnsmasq.d'
        list server '/use-application-dns.net/'
        list server '/mask.icloud.com/'
        list server '/mask-h2.icloud.com/'
        list server '127.0.0.1#5054'
        list server '127.0.0.1#5053'
        option doh_backup_noresolv '-1'
        option noresolv '1'
        list doh_backup_server '/use-application-dns.net/'
        list doh_backup_server '/mask.icloud.com/'
        list doh_backup_server '/mask-h2.icloud.com/'
        list doh_backup_server '127.0.0.1#5054'
        list doh_backup_server '127.0.0.1#5053'
        list doh_server '127.0.0.1#5054'
        list doh_server '127.0.0.1#5053'

config dhcp 'lan'
        option interface 'lan'
        option dhcpv4 'server'
        option ra_management '1'
        option leasetime '30m'
        option limit '200'
        option start '60'
        option force '1'
        option preferred_lifetime '30m'
        option ra 'relay'
        option dhcpv6 'relay'
        option ndp 'relay'

config dhcp 'guest'
        option interface 'guest'
        option leasetime '30m'
        option limit '150'
        option start '100'
        option force '1'
        option preferred_lifetime '30m'

config dhcp 'iot'
        option interface 'iot'
        option leasetime '30m'
        option start '100'
        option limit '150'
        option force '1'
        option preferred_lifetime '30m'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'
        option master '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config domain
        option name 'time.nuri.net'
        option ip '192.168.11.1'

package firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'
        option drop_invalid '1'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option output 'ACCEPT'
        option masq '1'
        option mtu_fix '1'
        option forward 'DROP'
        option input 'DROP'
        list network 'wan'
        list network 'wwan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config rule
        option name 'Support-UDP-Traceroute'
        option src 'wan'
        option dest_port '33434:33689'
        option proto 'udp'
        option family 'ipv4'
        option target 'DROP'

config zone
        option name 'zerotier'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option masq '1'
        list network 'ZeroTierPAA2'

config forwarding
        option src 'zerotier'
        option dest 'lan'

config forwarding
        option src 'zerotier'
        option dest 'wan'

config forwarding
        option src 'lan'
        option dest 'zerotier'

config rule
        option name 'smb1'
        list proto 'udp'
        option src 'zerotier'
        option src_port '137-138'
        option dest 'lan'
        option dest_port '137-138'
        option target 'ACCEPT'

config rule
        option name 'smb2'
        list proto 'tcp'
        option src 'zerotier'
        option src_port '139'
        option dest 'lan'
        option dest_port '139'
        option target 'ACCEPT'

config rule
        option name 'smb3'
        list proto 'tcp'
        option src 'zerotier'
        option src_port '445'
        option dest 'lan'
        option dest_port '445'
        option target 'ACCEPT'

config zone
        option name 'guest'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        list network 'guest'

config forwarding
        option src 'guest'
        option dest 'wan'

config zone
        option name 'iot'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        list network 'iot'

config forwarding
        option src 'iot'
        option dest 'wan'

config rule
        option name 'guest dns'
        option src 'guest'
        option dest_port '53'
        option target 'ACCEPT'

config rule
        option name 'guest dhcp'
        option src 'guest'
        option dest_port '67'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'iot dhcp'
        option src 'iot'
        option dest_port '67'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'iot dns'
        option src 'iot'
        option dest_port '53'
        option target 'ACCEPT'

config rule
        option name 'guest dhcpv6'
        option family 'ipv6'
        option src 'guest'
        option dest_port '546-547'
        option target 'ACCEPT'

config rule
        option name 'iot dhcpv6'
        option family 'ipv6'
        option src 'iot'
        option dest_port '546-547'
        option target 'ACCEPT'

config rule
        option target 'ACCEPT'
        list proto 'tcp'
        option name 'ssh acesso fora'
        option src 'wan'
        option dest_port '44001'

config rule
        option src 'guest'
        option name 'Allow-guest-ICMP6'
        option family 'ipv6'
        option limit '1000/sec'
        option target 'ACCEPT'
        option proto 'icmp'
        list icmp_type 'destination-unreachable'
        list icmp_type 'echo-reply'
        list icmp_type 'echo-request'
        list icmp_type 'fragmentation-needed'
        list icmp_type 'neighbour-advertisement'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'port-unreachable'
        list icmp_type 'protocol-unreachable'
        list icmp_type 'router-solicitation'
        list icmp_type 'time-exceeded'
        option limit_burst '100'

config rule
        option src 'iot'
        option name 'Allow-iot-ICMP6'
        option family 'ipv6'
        option limit '1000/sec'
        option target 'ACCEPT'
        option proto 'icmp'
        list icmp_type 'destination-unreachable'
        list icmp_type 'echo-reply'
        list icmp_type 'echo-request'
        list icmp_type 'fragmentation-needed'
        list icmp_type 'neighbour-advertisement'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'port-unreachable'
        list icmp_type 'protocol-unreachable'
        list icmp_type 'router-solicitation'
        list icmp_type 'time-exceeded'
        option limit_burst '100'

config rule
        option name 'block cameras 1'
        option src 'lan'
        list src_ip '192.168.11.30'
        list src_ip '192.168.11.31'
        list src_ip '192.168.11.32'
        list src_ip '192.168.11.33'
        list src_ip '192.168.11.34'
        list src_ip '192.168.11.35'
        list src_ip '192.168.11.36'
        list src_ip '192.168.11.37'
        list src_ip '192.168.11.38'
        list src_ip '192.168.11.39'
        list src_ip '192.168.11.40'
        list src_ip '192.168.11.41'
        list src_ip '192.168.11.42'
        list src_ip '192.168.11.43'
        list src_ip '192.168.11.44'
        list src_ip '192.168.11.45'
        list src_ip '192.168.11.46'
        list src_ip '192.168.11.47'
        list src_ip '192.168.11.48'
        list src_ip '192.168.11.49'
        list src_ip '192.168.11.50'
        list src_ip '192.168.11.51'
        list src_ip '192.168.11.52'
        list src_ip '192.168.11.53'
        list src_ip '192.168.11.54'
        list src_ip '192.168.11.55'
        list src_ip '192.168.11.56'
        list src_ip '192.168.11.57'
        list src_ip '192.168.11.58'
        list src_ip '192.168.11.59'
        option dest 'wan'
        option target 'DROP'
        option dest_port '!123'

config forwarding
        option src 'lan'
        option dest 'guest'

config forwarding
        option src 'lan'
        option dest 'iot'

config rule
        option name 'block dhcp ZT'
        option src 'zerotier'
        option src_port '67-68'
        option dest_port '67-68'
        option target 'DROP'

config include 'miniupnpd'
        option type 'script'
        option path '/usr/share/miniupnpd/firewall.include'
        option family 'any'
        option reload '1'

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::dea6:32ff:fe7b:4c1b/64 scope link
       valid_lft forever preferred_lft forever
9: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::d237:45ff:fe2d:5f23/64 scope link
       valid_lft forever preferred_lft forever
11: eth0.20@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::dea6:32ff:fe7b:4c1b/64 scope link
       valid_lft forever preferred_lft forever
12: eth1.1@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2a12:26c0:3100:3e04::1/62 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 dda1:12ea:dca4:4::1/62 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::d237:45ff:fe2d:5f23/64 scope link
       valid_lft forever preferred_lft forever
13: eth1.2@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2a12:26c0:3100:3e00::1/62 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 dda1:12ea:dca4::1/62 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::d237:45ff:fe2d:5f23/64 scope link
       valid_lft forever preferred_lft forever
14: eth1.3@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::d237:45ff:fe2d:5f23/64 scope link
       valid_lft forever preferred_lft forever
15: eth1.4@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::d237:45ff:fe2d:5f23/64 scope link
       valid_lft forever preferred_lft forever
21: pppoe-wan: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 state UNKNOWN qlen 3
    inet6 2a12:26c0:31ff:ffff::6440:8ad4/128 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::accd:c540:6eab:ae07 peer fe80::1/128 scope link
       valid_lft forever preferred_lft forever
22: ztexox7zsp: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 2800 state UNKNOWN qlen 1000
    inet6 fe80::f091:76ff:fea4:b3e9/64 scope link
       valid_lft forever preferred_lft forever
23: zt3d5embso: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 2800 state UNKNOWN qlen 1000
    inet6 fde1:6566:399f:203f:d199:93db:601a:1f80/88 scope global
       valid_lft forever preferred_lft forever
    inet6 fe80::e07e:60ff:feab:68c5/64 scope link
       valid_lft forever preferred_lft forever
default from 2a12:26c0:3100:xxxx::/56 via fe80::1 dev pppoe-wan proto static metric 512 pref medium
default from 2a12:26c0:31ff:ffff::6440:xxxx via fe80::1 dev pppoe-wan proto static metric 512 pref medium
2a12:26c0:3100:3e00::/64 dev eth1.2 proto static metric 1024 pref medium
2a12:26c0:3100:3e04::/64 dev eth1.1 proto static metric 1024 pref medium
unreachable 2a12:26c0:3100:3e00::/56 dev lo proto static metric 2147483647 pref medium
dda1:12ea:dca4::/64 dev eth1.2 proto static metric 1024 pref medium
dda1:12ea:dca4:4::/64 dev eth1.1 proto static metric 1024 pref medium
unreachable dda1:12ea:dca4::/48 dev lo proto static metric 2147483647 pref medium
fde1:6566:399f:203f:d199:xxxx::/88 dev zt3d5embso proto kernel metric 256 pref medium
fe80::1 dev pppoe-wan proto kernel metric 256 pref medium
fe80::accd:c540:6eab:ae07 dev pppoe-wan proto kernel metric 256 pref medium
fe80::/64 dev eth0 proto kernel metric 256 pref medium
fe80::/64 dev eth0.20 proto kernel metric 256 pref medium
fe80::/64 dev eth1 proto kernel metric 256 pref medium
fe80::/64 dev eth1.1 proto kernel metric 256 pref medium
fe80::/64 dev eth1.2 proto kernel metric 256 pref medium
fe80::/64 dev eth1.3 proto kernel metric 256 pref medium
fe80::/64 dev eth1.4 proto kernel metric 256 pref medium
fe80::/64 dev zt3d5embso proto kernel metric 256 pref medium
fe80::/64 dev ztexox7zsp proto kernel metric 256 pref medium
local ::1 dev lo table local proto kernel metric 0 pref medium
anycast 2a12:26c0:3100:xxxx:: dev eth1.2 table local proto kernel metric 0 pref medium
local 2a12:26c0:3100:xxxx::1 dev eth1.2 table local proto kernel metric 0 pref medium
anycast 2a12:26c0:3100:xxxx:: dev eth1.1 table local proto kernel metric 0 pref medium
local 2a12:26c0:3100:xxxx::1 dev eth1.1 table local proto kernel metric 0 pref medium
local 2a12:26c0:31ff:ffff::xxxx:8ad4 dev pppoe-wan table local proto kernel metric 0 pref medium
anycast dda1:12ea:dca4:: dev eth1.2 table local proto kernel metric 0 pref medium
local dda1:12ea:dca4::1 dev eth1.2 table local proto kernel metric 0 pref medium
anycast dda1:12ea:dca4:4:: dev eth1.1 table local proto kernel metric 0 pref medium
local dda1:12ea:dca4:4::1 dev eth1.1 table local proto kernel metric 0 pref medium
anycast fde1:6566:399f:203f:d199:xxxx:: dev zt3d5embso table local proto kernel metric 0 pref medium
local fde1:6566:399f:203f:d199:93db:601a:xxxx dev zt3d5embso table local proto kernel metric 0 pref medium
anycast fe80:: dev eth0 table local proto kernel metric 0 pref medium
anycast fe80:: dev eth0.20 table local proto kernel metric 0 pref medium
anycast fe80:: dev eth1 table local proto kernel metric 0 pref medium
anycast fe80:: dev eth1.2 table local proto kernel metric 0 pref medium
anycast fe80:: dev eth1.4 table local proto kernel metric 0 pref medium
anycast fe80:: dev eth1.3 table local proto kernel metric 0 pref medium
anycast fe80:: dev eth1.1 table local proto kernel metric 0 pref medium
anycast fe80:: dev zt3d5embso table local proto kernel metric 0 pref medium
anycast fe80:: dev ztexox7zsp table local proto kernel metric 0 pref medium
local fe80::accd:c540:6eab:xxxx dev pppoe-wan table local proto kernel metric 0 pref medium
local fe80::d237:45ff:fe2d:xxxx dev eth1 table local proto kernel metric 0 pref medium
local fe80::d237:45ff:fe2d:xxxx dev eth1.2 table local proto kernel metric 0 pref medium
local fe80::d237:45ff:fe2d:xxxx dev eth1.4 table local proto kernel metric 0 pref medium
local fe80::d237:45ff:fe2d:xxxx dev eth1.3 table local proto kernel metric 0 pref medium
local fe80::d237:45ff:fe2d:xxxx dev eth1.1 table local proto kernel metric 0 pref medium
local fe80::dea6:32ff:fe7b:xxxx dev eth0 table local proto kernel metric 0 pref medium
local fe80::dea6:32ff:fe7b:xxxx dev eth0.20 table local proto kernel metric 0 pref medium
local fe80::e07e:60ff:feab:xxxx dev zt3d5embso table local proto kernel metric 0 pref medium
local fe80::f091:76ff:fea4:xxxx dev ztexox7zsp table local proto kernel metric 0 pref medium
multicast ff00::/8 dev eth0 table local proto kernel metric 256 pref medium
multicast ff00::/8 dev eth1.1 table local proto kernel metric 256 pref medium
multicast ff00::/8 dev eth0.20 table local proto kernel metric 256 pref medium
multicast ff00::/8 dev eth1.2 table local proto kernel metric 256 pref medium
multicast ff00::/8 dev eth1 table local proto kernel metric 256 pref medium
multicast ff00::/8 dev eth1.3 table local proto kernel metric 256 pref medium
multicast ff00::/8 dev eth1.4 table local proto kernel metric 256 pref medium
multicast ff00::/8 dev pppoe-wan table local proto kernel metric 256 pref medium
multicast ff00::/8 dev zt3d5embso table local proto kernel metric 256 pref medium
multicast ff00::/8 dev ztexox7zsp table local proto kernel metric 256 pref medium
0:      from all lookup local
2061:   from all fwmark 0x3d00/0x3f00 blackhole
2062:   from all fwmark 0x3e00/0x3f00 unreachable
32766:  from all lookup main
4200000000:     from 2a12:26c0:3100:3e00::1/62 iif eth1.2 unreachable
4200000000:     from 2a12:26c0:3100:3e04::1/62 iif eth1.1 unreachable

Are you using mwan3 or pbr by any chance?

mwan3, but... planning to use, already installed, not actively using it.
I want to have a fallback connection using 4G. but first I want to make this work without it.

You have not configured it properly and it is blackholing your traffic.
service mwa3 stop; service mwan3 disable; reboot and try again.

you were right... now I can successfully ping ipv6 addresses from the router. Apparently I still don't have ipv6 in the lan clients, but I'll poke around in the settings a bit more

Remove the master.

Make them server or hybrid.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.