Problem with rtl8821ae driver

I had a problem with the x86_64 rtl8821ae driver.
It was not working until I copied rtl8821aefw_29.bin to /lib/firmware/rtlwifi/

It is now working but the wifi is very slow. Is there anyway to improve this?


config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:1c.0/0000:01:00.0'
	option hwmode '11g'
	option channel '7'
	option htmode 'HT40'
	option legacy_rates '1'
	option country 'GB'

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'
	option network 'lan'


[    8.094841] NET: Registered protocol family 24
[    8.134463] rtl8821ae: Using firmware rtlwifi/rtl8821aefw_29.bin
[    8.140680] rtl8821ae: Using firmware rtlwifi/rtl8821aefw_wowlan.bin
[    8.151038] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[    8.151274] rtlwifi: rtlwifi: wireless switch is on
[    8.157003] kmodloader: done loading kernel modules from /etc/modules.d/*
[    8.771340] 8021q: adding VLAN 0 to HW filter on device eth0
[    8.778408] br-lan: port 1(eth0) entered blocking state
[    8.784135] br-lan: port 1(eth0) entered disabled state
[    8.789978] device eth0 entered promiscuous mode
[    8.796734] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[    9.040508] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[   10.667633] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   10.674832] igb 0000:02:00.0 eth0: igb: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
[   10.685210] br-lan: port 1(eth0) entered blocking state
[   10.690909] br-lan: port 1(eth0) entered forwarding state
[   10.696981] br-lan: port 2(wlan0) entered blocking state
[   10.702959] br-lan: port 2(wlan0) entered disabled state
[   10.708869] device wlan0 entered promiscuous mode
[   10.714226] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   12.282597] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   12.289667] br-lan: port 2(wlan0) entered blocking state
[   12.295505] br-lan: port 2(wlan0) entered forwarding state
[   23.388939] random: crng init done

@llcool, welcome to the community!

USB 1.x maximum signaling rate is only 12 Mbps. Does your device have any USB 2.0 ports?

No, it is on the PCI-e bus.

1 Like