Problem with openwrt/lede software: OPKG / wget returned 4

Ahh, i understand... Then you network config for your ap should look like this one:

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '10.229.28.111'
        option netmask '255.255.255.0'
        option gateway '10.229.28.1'
        option broadcast '10.229.28.255'

Subnetmask for your range is 255.255.255.0 (address range = 10.229.28.1 - 10.229.28.254, broadcast 10.229.28.255) and not 255.0.0.0 (address range = 10.0.0.1 - 10.255.255.254, broadcast 10.255.255.255)

1 Like

thx for every one help me with this problem i solved it with this config

network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdba:027d:8a7d::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.5'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'
        option dns '8.8.8.8'
        option ip6assign '60'

dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option localservice '1'
        option ignore '1'
config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ignore '1'
config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'

and disable firewall