Problem with modem in ZTE MF286R

I honestly don't remember. If it didn't allow a VOIP configuration, I probably thought my provider deliberately hid those options from the user account as they usually do. I didn't think to check if the supervisor user had access to VOIP configuration options before I flashed.

I just upgraded my ZTE MF286R to Openwrt, but I ran into the modem instability issues described here. It just hangs with no errors in the log. Is there a way to fix it ? I could provide remote VPN access to @Leo-PL if needed.

Thanks a lot for the great work

Hi do anyone issued a missing modem tab? Tried a lot of possible solutions but can't get sim card slot working

lmao you have to install the packages thats why

install these via system > software > upload package (giving drive links so you dont have to add other repos, you are free to find the packages on your own elsewhere)

Many thanks, do i still need to create an interface with NCM?

if you want to use 4g connection, then yes.

1 Like

@pcislocked If you're telling people to install my packages, at least refer them to the latest version :wink: .

In newer versions of OpenWrt, I suggest installing luci-app-sms-tool-js instead of luci-app-sms-tool.

For those interested, I recommend (my github).

1 Like

Sure, that's the ideal way but after adding your repos i got some sort of signature error some time ago i dont remember exactly, probably an issue on my side, also considering our guy is a obviously non-experienced user, i didnt want him to deal with adding repos and simply pulled a known working version from archive. these still work in the latest version.

Yes its not up to date, and its not ideal, but it works and its easy enough, which is all this guy cares about atm. its obviously your package, dont worry :slightly_smiling_face:

I can send you over one ZTE MF286C that has the same hardware spec of MF286R, if you want

I have pretty hefty backlog right now, and not sure if I can find time for it before September.
Is this the 286C (QCA) or 286C3 (Mediatek) variant? Probably can be differentiated by the PCB when looked through grill at the bottom, QCA will have matte black soldermask, Mediatek - blue.
If you'd like, let's discuss further via PM.

I have 286C and it is MT7621 (MT7621A ?) based. Is it 286C3? How can I check?

BTW, UART speed is 57600

It is, I found the internal photos on somewhere, and this has matched.

I can't find FCC anywhere on my router :slight_smile:

May be you can send any pics? What I really want is to get firmware dump. Looks like it is possible to make dts and run OpenWRT on this router...

Wish I had the device. Only thing I have is this:

Look for "internal photos".

For dumping data, it's business as usual - try to access the serial console first and gain a root shell, then use external USB port to copy over MTD devices to a flash drive.
MF286D required password, the same used for web logins and user "admin" for this, here it might be similar.