Problem with modem in ZTE MF286R

Just power-cycling the router before another attempt should be enough - some process (possibly stock FW) may have locked some pages in that partition.
If this doesn't help then you can proceed with method 3. By "deliberately wipe the kernel" I meant using flash_erase command on that MTD node.

1 Like

Until now, nobody has created a dataentry for the MF286R. Without dataentry, it will not show up in the ToH.

If someone wants to create a dataentry: (need to be logged in to the wiki in order to access this page).

1 Like

Tried that, tried flashing t-mobile poland firmware via official tools(tmobile poland firmware DOES NOT have the url exploit one way or other) and back to turkcell, that didn't help either. I'll buy a TTL cable or borrow from my dormmates within today to trying again, just to be on the safe side.

I am willing to do that. I think I will also add a few extra stuff (like specifying flash_erase, fixing some places where it says mf286a, specifying which firmwares do and dont work with certain ways etc) and probably some more that I'll discover after booting the device with OpenWrt.

Followup: It was a piece of cake to install openwrt with a TTL adapter. I needed to install luci-proto-qmi packet after installing openwrt to use LTE modem, which I did via connecting to my wifi with the wifi radio. After that, everything seems like they should work. Thanks so much again

PS: seems like wiki does not accept outsiders to add stuff appearently, so I think I am unable to do what I said I'm willing to do.

Edit: Nope. I added the configurations to the etc/config/network and rebooted the device, but now it says device is not present. On the device, LTE light is up blue and signal bars are full, so the modem is online. Not sure what's going on. Will try some more stuff.

Edit 2: /dev output if that helps. No cdc-wdm0 that I could see here.


MF286R does not use QMI. MF286A does. Use NCM protocol and point the device at /dev/ttyACM0.
I think it's another good point to highlight at the wiki - because when support for both was added, modem part of MF286R wasn't ready yet - it was added a few commits later, after patches fixing some of its woes landed at the upstream Linux repositories.

@pcislocked for wiki access, see here: Applying for OpenWrt wiki account

1 Like

NCM worked for LTE, thank you again. I tested the speeds, wifi performance, vlan and such stuff. Seems like working as expected, although wifi is a bit slow to react to changes, it does work in the end, so I am thankful for at least having the advanced options.

Also, I created the techdata page and started to work on wiki as well, can't promise it will turn out perfect but it'll be something.

Finally, is there any option to specify/lock certain LTE bands, either via LuCI or ssh?

See here: :slight_smile:

1 Like

Stock firmware was up-to-date as it gets for my provider (A1 Croatia) and yes, the instability is related to the modem - if I remove the SIM and disable the connection, there aren't any reboots. Infuriatingly, modem crashes weren't in any way connected with the load or throughput - they occurred as long as the modem is connected to a network.

I used to get crashes with the original provider's firmware, only they were less frequent (once every few days, requiring a reboot) and the ISP's forum is filled with similar reports. They've switched back to Huawei for their CPE, with a good reason I suppose.

In any case, I anyone happens to have a newer firmware for it, I'd love to try it. Otherwise, I'll just use it as an AP/mwan/adblock gateway.

By the way, how come there is no VOIP support in OpenWRT?

I don't recall the telephone ports on those series to be VoIP capable - in MF286{,A,D}, these allow making/receiving voice calls through the cellular network. And modem handles this on its own, no intervention from OpenWrt is required.

Does stock FW allow configuring SIP connection instead of just CS voice? I recall, that on MC801A it was possible, but this is much newer product.

I honestly don't remember. If it didn't allow a VOIP configuration, I probably thought my provider deliberately hid those options from the user account as they usually do. I didn't think to check if the supervisor user had access to VOIP configuration options before I flashed.

I just upgraded my ZTE MF286R to Openwrt, but I ran into the modem instability issues described here. It just hangs with no errors in the log. Is there a way to fix it ? I could provide remote VPN access to @Leo-PL if needed.

Thanks a lot for the great work

Hi do anyone issued a missing modem tab? Tried a lot of possible solutions but can't get sim card slot working

lmao you have to install the packages thats why

install these via system > software > upload package (giving drive links so you dont have to add other repos, you are free to find the packages on your own elsewhere)

Many thanks, do i still need to create an interface with NCM?

if you want to use 4g connection, then yes.

1 Like

@pcislocked If you're telling people to install my packages, at least refer them to the latest version :wink: .

In newer versions of OpenWrt, I suggest installing luci-app-sms-tool-js instead of luci-app-sms-tool.

For those interested, I recommend (my github).

1 Like

Sure, that's the ideal way but after adding your repos i got some sort of signature error some time ago i dont remember exactly, probably an issue on my side, also considering our guy is a obviously non-experienced user, i didnt want him to deal with adding repos and simply pulled a known working version from archive. these still work in the latest version.

Yes its not up to date, and its not ideal, but it works and its easy enough, which is all this guy cares about atm. its obviously your package, dont worry :slightly_smiling_face:

I can send you over one ZTE MF286C that has the same hardware spec of MF286R, if you want