Problem with MAC address translation from repeater to main router

I have 2 routers:

  • Xiaomi MI-3, Main Router, that connected to ISP, DHCP Server is here
  • Xiaomi AX5 AX1800 that placed in the center of my apartment, and works in Wireless Repeater Mode (runs on WRT)

For me is important to set static IP (override DHCP) for half of the devices. Static IP assignment based on MAC address.
The problem: MI-3 can't see real MAC addresses of devices connected to Wireless Repeater (AX5), each device has MAC of repeater.

Look like I should turn smth like mac repeating on AX5? Please help
And I can setup it only over ssh

This requires "WDS" mode between the AP and the repeater. If it has that option. Otherwise it's not possible (or requires a mesh mode).

If you're running OpenWrt on both ends then make the main router a WDS AP mode and second router has bridge between WDS client and a second AP mode wireless. There is a how to on the wiki. https://openwrt.org/docs/guide-user/network/wifi/atheroswds

1 Like

One more thing... Routers connected to each other over WiFi, there is no possibility to connect them via cable. WIll this guide work in this case?

Yes WDS is specifically for this case

previously i user router as repeater and now I have these wireless interfaces

config wifi-device 'wifi0'
        option type 'qcawificfg80211'
        option channel 'auto'
        option macaddr '9c:9d:7e:48:93:6e'
        option hwmode '11axa'
        option htmode 'HT80'
        option country 'EU'
        option disabled '0'
        option txpwr 'max'
        option ax '1'
        option txbf '3'

config wifi-iface
        option device 'wifi0'
        option ifname 'wl0'
        option network 'lan'
        option mode 'ap'
        option wpsdevicename 'XiaoMiRouter'
        option channel_block_list '36,40,44,48,52,56,60,64'
        option encryption 'mixed-psk'
        option key 'repeater_password'
        option macfilter 'disabled'
        option disabled '0'
        option ssid 'repeater_wifi'_5GHz'
        option hidden '0'

config wifi-device 'wifi1'
        option type 'qcawificfg80211'
        option channel 'auto'
        option macaddr '9c:9d:7e:48:93:6f'
        option hwmode '11axg'
        option htmode 'HT40'
        option country 'EU'
        option disabled '0'
        option txpwr 'max'
        option txbf '0'
        option ax '1'

config wifi-iface
        option device 'wifi1'
        option ifname 'wl1'
        option network 'lan'
        option mode 'ap'
        option wpsdevicename 'XiaoMiRouter'
        option intop '1'
        option ssid 'repeater_wifi'
        option encryption 'mixed-psk'
        option key 'repeater_password'
        option macfilter 'disabled'
        option disabled '0'

config wifi-iface
        option ifname 'wl12'
        option network 'lan'
        option encryption 'psk2'
        option device 'wifi0'
        option enctype 'AES'
        option scanifname 'wl0'
        option extap '1'
        option apcliband '5g'
        option key 'main_router_password'
        option ssid 'main_wifi_5GHz'
        option mode 'sta'
        option athnewind '0'
        option disabled '0'

So all I need is add option wds '1' to last interface config?
Also disable DHCP and add option type 'bridge' to lan interface in /etc/config/network

WDS needs to be enabled on both ends of the wireless link. You can't just make the client WDS without the AP also WDS.

WDS, as in mac80211's 4addr, would require OpenWrt with mac80211 based mainline drivers to run on all WDS enabled APs, but the Xiaomi AX5 (ipq60xx) is not supported by OpenWrt, yet (nor will it be anytime soon - it should be supportable, but not in the immediate future).

on the next end is MI-3 with Padavan firmware and I set this settings:

i applied all settings, but DHCP looks like doesn't work -- when i connect to repeater's WiFi -- no IP assignment and i should set IP settings manually

i see option qcawificfg80211 in device config, should it work?

damn looks like i did wrong setup

i double checked article and i see 2 sections The Access Point and The remote wireless station
is that setup for different devices, right? If yes,

access point should be MI-3 and WDS should be AX5?