Problem with ipv6 for over 24 hours

after booting, all are good, but maybe over 24 hours, all devices in wifi still get the ipv6 address, no connecting via ipv6.
at this moment, ssh to router and use curl command to visit a ipv6 address site is good, the others in wifi needs reboot router.
route table:

root@OpenWrt_AX3600:/etc/config# ip -6 route
default from 2409:8a55:60e:6cf8::/64 via fe80::e2cc:7aff:fe84:faa3 dev pppoe-wan proto static metric 512 pref medium
default from 2409:8a55:6e4:c4e0::/60 via fe80::e2cc:7aff:fe84:faa3 dev pppoe-wan proto static metric 512 pref medium
unreachable 2409:8a55:60e:6cf8::/64 dev lo proto static metric 2147483647 pref medium
2409:8a55:6e4:c4e0::/64 dev br-lan proto static metric 1024 pref medium
unreachable 2409:8a55:6e4:c4e0::/60 dev lo proto static metric 2147483647 pref medium
fe80::718d:f5f9:7583:10a9 dev pppoe-wan proto kernel metric 256 pref medium
fe80::e2cc:7aff:fe84:faa3 dev pppoe-wan proto kernel metric 256 pref medium
fe80::/64 dev br-lan proto kernel metric 256 pref medium
fe80::/64 dev wan proto kernel metric 256 pref medium
fe80::/64 dev phy1-ap0 proto kernel metric 256 pref medium
fe80::/64 dev phy2-ap0 proto kernel metric 256 pref medium
IP address	MAC address	Interface
2409:8a55:6e4:c4e0::91e	00:11:32:12:34:56	lan
2409:8a55:6e4:c4e0:211:32ff:fe12:3456	00:11:32:12:34:56	lan
2409:8a55:6e4:c4e0:14ee:ef51:4673:200b	C0:3C:59:62:61:A0	lan
2409:8a55:6e4:c4e0:5130:54bd:f3c2:2cfd	6C:97:6D:6B:33:5A	lan

routing in luci, except 2409:8a55:6e4:c4e0:211:32ff:fe12:3456 using wire, the others using wifi, and not in the table, such as my laptop get ip 2409:8a55:6e4:c4e0::ae9 and 2409:8a55:6e4:c4e0:e2b3:29a9:737e:a7ff
wireless firmware is ath11k
how to solve this, only to reboot router?

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; uci export wireless; \
uci export dhcp; uci export firewall; \
ip -6 addr ; ip -6 ro li tab all ; ip -6 ru

i'm trying to reproduce the issue, and then i will post config that you metioned

{
        "kernel": "5.15.114",
        "hostname": "OpenWrt_AX3600",
        "system": "ARMv8 Processor rev 4",
        "model": "Xiaomi AX3600",
        "board_name": "xiaomi,ax3600",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "SNAPSHOT",
                "revision": "r0-2731da5",
                "target": "ipq807x/generic",
                "description": "OpenWrt SNAPSHOT r0-2731da5"
        }
}
package network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '10.0.0.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'pppoe'
        option username 'xxx'
        option password 'xxx'
        option ipv6 'auto'
        option peerdns '0'
        list dns '127.0.0.1'

package wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'soc/20000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel '36'
        option band '5g'
        option htmode 'VHT80'
        option disabled '1'
        option country 'RU'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt_AX3600'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/c000000.wifi'
        option channel '36'
        option band '5g'
        option htmode 'HE160'
        option disabled '0'
        option country 'RU'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'LL-Fans'
        option encryption 'sae'
        option key '12345678'

config wifi-device 'radio2'
        option type 'mac80211'
        option path 'platform/soc/c000000.wifi+1'
        option channel '1'
        option band '2g'
        option htmode 'HE40'
        option disabled '0'
        option country 'RU'
        option cell_density '0'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option ssid 'Xiaomi_391F'
        option encryption 'psk-mixed'
        option key '12345678'

package dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '0'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'
        option noresolv '1'
        list server '127.0.0.1#5335'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

package firewall

config defaults
        option syn_flood '1'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option flow_offloading '1'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config rule
        option name 'Allow-qBit'
        option src 'wan'
        option dest 'lan'
        option dest_port '47880'
        option target 'ACCEPT'

config include 'miniupnpd'
        option type 'script'
        option path '/usr/share/miniupnpd/firewall.include'

config include 'qcanssecm'
        option type 'script'
        option path '/etc/firewall.d/qca-nss-ecm'
        option family 'any'
        option reload '1'

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
3: wan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::8ac3:97ff:fe15:391f/64 scope link
       valid_lft forever preferred_lft forever
16: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2409:8a55:6e6:5e70::1/60 scope global dynamic noprefixroute
       valid_lft 254970sec preferred_lft 168570sec
    inet6 fe80::8ac3:97ff:fec0:3ab3/64 scope link
       valid_lft forever preferred_lft forever
17: pppoe-wan: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 state UNKNOWN qlen 3
    inet6 2409:8a55:60e:8215:3579:36dd:c3ca:10ce/64 scope global dynamic noprefixroute
       valid_lft 259017sec preferred_lft 172617sec
    inet6 fe80::3579:36dd:c3ca:10ce peer fe80::e2cc:7aff:fe84:faa3/128 scope link
       valid_lft forever preferred_lft forever
18: phy1-ap0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::8ac3:97ff:fec0:3ab4/64 scope link
       valid_lft forever preferred_lft forever
19: phy2-ap0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::8ac3:97ff:fec0:3ab3/64 scope link
       valid_lft forever preferred_lft forever
default from 2409:8a55:60e:8215::/64 via fe80::e2cc:7aff:fe84:faa3 dev pppoe-wan proto static metric 512 pref medium
default from 2409:8a55:6e6:5e70::/60 via fe80::e2cc:7aff:fe84:faa3 dev pppoe-wan proto static metric 512 pref medium
unreachable 2409:8a55:60e:8215::/64 dev lo proto static metric 2147483647 pref medium
2409:8a55:6e6:5e70::/64 dev br-lan proto static metric 1024 pref medium
unreachable 2409:8a55:6e6:5e70::/60 dev lo proto static metric 2147483647 pref medium
fe80::3579:36dd:c3ca:10ce dev pppoe-wan proto kernel metric 256 pref medium
fe80::e2cc:7aff:fe84:faa3 dev pppoe-wan proto kernel metric 256 pref medium
fe80::/64 dev br-lan proto kernel metric 256 pref medium
fe80::/64 dev wan proto kernel metric 256 pref medium
fe80::/64 dev phy1-ap0 proto kernel metric 256 pref medium
fe80::/64 dev phy2-ap0 proto kernel metric 256 pref medium
local ::1 dev lo table local proto kernel metric 0 pref medium
anycast 2409:8a55:60e:8215:: dev pppoe-wan table local proto kernel metric 0 pref medium
local 2409:8a55:60e:8215:3579:36dd:c3ca:10ce dev pppoe-wan table local proto kernel metric 0 pref medium
anycast 2409:8a55:6e6:5e70:: dev br-lan table local proto kernel metric 0 pref medium
local 2409:8a55:6e6:5e70::1 dev br-lan table local proto kernel metric 0 pref medium
anycast fe80:: dev br-lan table local proto kernel metric 0 pref medium
anycast fe80:: dev phy1-ap0 table local proto kernel metric 0 pref medium
anycast fe80:: dev wan table local proto kernel metric 0 pref medium
anycast fe80:: dev phy2-ap0 table local proto kernel metric 0 pref medium
local fe80::3579:36dd:c3ca:10ce dev pppoe-wan table local proto kernel metric 0 pref medium
local fe80::8ac3:97ff:fe15:391f dev wan table local proto kernel metric 0 pref medium
local fe80::8ac3:97ff:fec0:3ab3 dev br-lan table local proto kernel metric 0 pref medium
local fe80::8ac3:97ff:fec0:3ab3 dev phy2-ap0 table local proto kernel metric 0 pref medium
local fe80::8ac3:97ff:fec0:3ab4 dev phy1-ap0 table local proto kernel metric 0 pref medium
multicast ff00::/8 dev pppoe-wan table local proto kernel metric 256 pref medium
multicast ff00::/8 dev br-lan table local proto kernel metric 256 pref medium
multicast ff00::/8 dev wan table local proto kernel metric 256 pref medium
multicast ff00::/8 dev phy1-ap0 table local proto kernel metric 256 pref medium
multicast ff00::/8 dev phy2-ap0 table local proto kernel metric 256 pref medium
0:      from all lookup local
32766:  from all lookup main
4200000000:     from 2409:8a55:6e6:5e70::1/60 iif br-lan unreachable

dns is a local server

Look fine to me. When the problem occurs, do the lan hosts send packets to the OpenWrt?
opkg update; opkg install tcpdump; tcpdump -i br-lan -vn ip6

looks like that is not related to routing
i've seen the log about oom killer, i suppose that is a running process take too much memory.
and now i stop that process and use for three days, that is ok.
i think the problem is related to the process which take too much memory and ath11k driver.

Ath11k memory: The ath11k driver needed for the main wireless radios uses a lot of memory when there are few stations connected and low bandwidth traffic flowing.Limitations

1 Like

Hi! Did you get more info about this problem? I suffer it with an AX3600. Usually a service network reload and wait some minutes fixes the problem for me, without needing to reboot.
Did you see something about a crash when this happens? I've not seen it, but sometimes when I detect the problem maybe has passed some hours since it started.