Problem with IGMPProxy and RE450

Hi all,

I cannot make work IPTV (Movistar TV) in my Raspberry Pi connected through TP-Link RE450 (connected directly to my ISP router works). I tried several configurations, but the one I think it should be right is:
/etc/config/igmpproxy:
config igmpproxy
option quickleave 1

config phyint wwan
option network wwan
option direction upstream
list altnet 172.0.0.0/8
list altnet 192.168.1.0/24

config phyint lan
option network lan
option direction downstream

in /etc/config/network I added in 'lan':
option igmp_snooping '1'

in /etc/config/firewall I added:
config rule
option src wwan
option proto igmp
option target ACCEPT

config rule
option name 'Allow-IGMP-MovistarTV'
option src 'wwan'
option proto 'udp'
option dest 'lan'
option dest_ip '224.0.0.0/4'
option target 'ACCEPT'
option family 'ipv4'

In /etc/sysctl.conf I added:
net.ipv4.conf.all.force_igmp_version=2
(is the version I saw my ISP router is using)

In /sys/devices/virtual/net/br-lan/bridge/multicast_snooping I saw that it is already written a "0".

I also tried with:
route add -net 224.0.0.0 netmask 224.0.0.0 wlan0

But it does not work. Any idea? I'm forgetting something?

I'm using LEDE 17.01.4.

I stopped the igmpproxy and execute:
igmpproxy -vdd /var/etc/igmpproxy.conf
and I got traces like:
"The IGMP message was from myself. Ignoring."
"ignoring IGMP message: received on the upstream interface"

Thank you very much in advance.

Hi again,

I've run tcpdump to see what messages are traveling in the TP-LINK RE450 configured as repeater.
From the raspberry pi to the RE450 I can see (interface wlan0-1):
IP 192.168.1.59 > 239.0.0.185: igmp v2 report 239.0.0.185
This message also goes from the RE450 to my ISP router through interface wlan0
Inmediately, in interface wlan0 I can se a lot of messages:
172.23.60.42.42966 > 239.0.0.185:8208: UPD, lenght 1344
but they are not shown in interface wlan0-1 (RE450 to raspberry pi).
It seems a route problem but I tried to add different static routes but it didn't work.
Can anybody help me?