Problem with getting USB Adapter Alfa Networks AWUS036NHA

I need help in debugging my Alfa Networks AWUS036NHA. All seems configured right but SSID does not appear and the blue LED does not shine on the device.

The problem I want so solve is the WLAN performance of my LInksys WRT1900ACS is terrible. It does not reach far enough. This is a known problem.
I have to solutions: Discard openwrt and use OEM Original with "beam forming". OpenWRT does not support this, right?
Or plug in a USB WLAN Adapter with more reach like the one I had in my drawer.

First LUCI would not want to configure it. I updated to 22.02 and now configuration via LUCI does work.

LUCI UI says all is well, but I cannot connect and LED is out.
in /etc/config/wireless:

config wifi-device 'radio2'
        option type 'mac80211'
        option path 'platform/soc/soc:internal-regs/f10f8000.usb3/usb2/2-1/2-1:1.0'
        option country 'DE'
        option cell_density '1'
        option htmode 'HT40'
        option hwmode '11g'
        option channel 'auto'

config wifi-iface 'wifinet2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option ssid 'Magrathea2'
        option encryption 'psk2'
        option key 'XXXXXXX'
        option wmm '0'

root@OpenWrt:/etc/config# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux 5.10.146 ehci_hcd EHCI Host Controller
Bus 002 Device 002: ID 0cf3:9271 ATHEROS UB91C
Bus 002 Device 001: ID 1d6b:0002 Linux 5.10.146 xhci-hcd xHCI Host Controller
Bus 003 Device 001: ID 1d6b:0003 Linux 5.10.146 xhci-hcd xHCI Host Controller

In wifi status:

       "radio2": {
                "up": true,
                "pending": false,
                "autostart": true,
                "disabled": false,
                "retry_setup_failed": false,
                "config": {
                        "path": "platform/soc/soc:internal-regs/f10f8000.usb3/usb2/2-1/2-1:1.0",
                        "country": "DE",
                        "cell_density": 1,
                        "htmode": "HT40",
                        "hwmode": "11g",
                        "channel": "auto"
                "interfaces": [
                                "section": "wifinet2",
                                "ifname": "wlan2",
                                "config": {
                                        "mode": "ap",
                                        "ssid": "Magrathea2",
                                        "encryption": "psk2",
                                        "key": "XXXXXX",
                                        "wmm": false,
                                        "network": [
                                        "mode": "ap"
                                "vlans": [

                                "stations": [


How do I check with "wifi" and "iw" if the adapter is working correct? And How do I get it working?

Thanks in advance.


Update: the LED shines blue, but the SSID is not visible, I cannot connect, even if I type in SSID und secret blindly.

Do not disable WMM. WMM must be enabled for HT to work. HT40 in 2 GHz can be problematic, use HT20.

iw dev should show your AP device including a channel and SSID. If there aren't lines for channel and SSID it is not fully started. The dmesg log should also be checked for wifi related errors.

Thanks @mk24 after trying your settings and turning of auto channel and rebooting I could connect for the first time and with a better signal strength compared to the onboard Wifi.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.