Problem with getting rtl8367rb work to support ASUS RT-AC53

I got working snaphot openwrt for ASUS RT-AC53, basically with using mt7620a_asus_rt-ac5x.dtsi in my dts. It boots and able to use WIFI interface with preconfigured wifi hotspot for first boot. However no LAN ports were working and also no rtl8367rb switch was showed at all.
However after some additions to dts and patches to rtl8367b.c im able to list rtl8367rb in swconfig:

root@OpenWrt:~# swconfig list
Found: switch0 - mt7620
Found: switch1 - rtl8367rb

Also looks like switch1 ports and parameters are working too. But no new eth interface was added (only old eth0 which was even with only mt7620 switch). Also my PC also sees LAN connections from router with ETH cable now, but i cant use them:

  1. Connecting with DHCP fails
  2. Connection with static ip = 192.168.1.75, mask = 255.255.255.0, gateway = 192.168.1.1 activates without errors in NetworkManager but pinging and using 192.168.1.1 gives no route to host.

Here is my DTS file with some comments i did trying to get rtl8367rb work:

#include "mt7620a_asus_rt-ac5x.dtsi"
/*
Some gathered info

rtl8367rb port 3 = router lan1
rtl8367rb port 4 = router lan2

switch0(mt7620) has always working port:6 link:up speed:1000baseT full-duplex

rtl8367: unknown chip num:6367 ver:0020, mode:0020.
Had to add ver 0x020 to rtl8367b.c

*/
/ {
	compatible = "asus,rt-ac53", "ralink,mt7620a-soc";
	model = "Asus RT-AC53";

    rtl8367rb {
		compatible = "realtek,rtl8367b", "rtl8367b";
		realtek,extif1 = <1 0 1 1 1 1 1 1 2>;
		mii-bus = <&mdio0>;
		// No actual difference with using 6 and 7 values.
		cpu_port = <7>;
	};

};

&gsw {
	status = "okay";
	//Without this no rtl8367rb switch found at all.
	mediatek,port6-gmac;
	mediatek,ephy-base = /bits/ 8 <8>;
};

&ethernet {
	status = "okay";

	nvmem-cells = <&macaddr_factory_28>;
	nvmem-cell-names = "mac-address";

	pinctrl-names = "default";
	pinctrl-0 = <&rgmii1_pins &rgmii2_pins &mdio_pins>;

	/*
	Adding gives no difference so commented
	port@4 {
		status = "okay";

		mediatek,fixed-link = <1000 1 1 1>;
		phy-mode = "rgmii";
	};
	port@5 {
		status = "okay";

		mediatek,fixed-link = <1000 1 1 1>;
		phy-mode = "rgmii";
	};
	*/

	mdio0: mdio-bus {
		status = "okay";

	};
};
//Just taken from RT-AC51U dts with the same flatform
&pcie0 {
	wifi@0,0 {
		reg = <0x0000 0 0 0 0>;
		mediatek,mtd-eeprom = <&factory 0x8000>;
	};
};


// This model has no USB ports.
&ehci {
	status = "disabled";
};

&ohci {
	status = "disabled";
};

Also there is current state ifconfig output with my PC connected to router hotspot and router connected to my WIFI (MACs was replaced with unique variables) :

br-lan    Link encap:Ethernet  HWaddr $( ETH0_MAC )
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: $( IP_V6_1/64 ) Scope:Link
          inet6 addr: $( IP_V6_2/60 ) Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6733 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6114 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:653714 (638.3 KiB)  TX bytes:2517979 (2.4 MiB)

eth0      Link encap:Ethernet  HWaddr $( ETH0_MAC )  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:89 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:15431 (15.0 KiB)
          Interrupt:5 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:632 errors:0 dropped:0 overruns:0 frame:0
          TX packets:632 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:50911 (49.7 KiB)  TX bytes:50911 (49.7 KiB)

wlan0     Link encap:Ethernet  HWaddr $( ETH0_MAC + 4 ) 
          inet6 addr: $( IP_V6_1/64) Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6736 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5754 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:748336 (730.7 KiB)  TX bytes:2676524 (2.5 MiB)

wlan1     Link encap:Ethernet  HWaddr $( ETH0_MAC )  
          inet addr:192.168.0.X Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: $( $IP_V6_1/64) Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2840 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2091 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1270242 (1.2 MiB)  TX bytes:291499 (284.6 KiB)

There are also switches info.
$ swconfig dev switch0 show:

Global attributes:
	enable_vlan: 1
	mib: Switch MIB counters
PPE_AC_BCNT0: 0
PPE_AC_PCNT0: 0
PPE_AC_BCNT63: 0
PPE_AC_PCNT63: 0
PPE_MTR_CNT0: 0
PPE_MTR_CNT63: 0
GDM1_TX_GBCNT: 0
GDM1_TX_GPCNT: 0
GDM1_TX_SKIPCNT: 0
GDM1_TX_COLCNT: 0
GDM1_RX_GBCNT1: 0
GDM1_RX_GPCNT1: 0
GDM1_RX_OERCNT: 0
GDM1_RX_FERCNT: 0
GDM1_RX_SERCNT: 0
GDM1_RX_LERCNT: 0
GDM1_RX_CERCNT: 0
GDM1_RX_FCCNT: 0
GDM2_TX_GBCNT: 0
GDM2_TX_GPCNT: 0
GDM2_TX_SKIPCNT: 0
GDM2_TX_COLCNT: 0
GDM2_RX_GBCNT: 0
GDM2_RX_GPCNT: 0
GDM2_RX_OERCNT: 0
GDM2_RX_FERCNT: 0
GDM2_RX_SERCNT: 0
GDM2_RX_LERCNT: 3
GDM2_RX_CERCNT: 0
GDM2_RX_FCCNT: 0

	mirror_monitor_port: 0
	arl_table: address resolution table
Port 6: MAC $( ETH0_MAC )
Port 6: MAC $( MY_PC_WIFI_CARD_MAC )

Port 0:
	mib: Port 0 MIB counters
TxGPC      : 0
TxBOC      : 0
TxGOC      : 0
TxEPC      : 0
RxGPC      : 0
RxBOC      : 0
RxGOC      : 0
RxEPC1     : 0
RxEPC2     : 0

	enable_mirror_rx: 0
	enable_mirror_tx: 0
	pvid: 2
	link: port:0 link:down
Port 1:
	mib: Port 1 MIB counters
TxGPC      : 0
TxBOC      : 0
TxGOC      : 0
TxEPC      : 0
RxGPC      : 0
RxBOC      : 0
RxGOC      : 0
RxEPC1     : 0
RxEPC2     : 0

	enable_mirror_rx: 0
	enable_mirror_tx: 0
	pvid: 1
	link: port:1 link:down
Port 2:
	mib: Port 2 MIB counters
TxGPC      : 0
TxBOC      : 0
TxGOC      : 0
TxEPC      : 0
RxGPC      : 0
RxBOC      : 0
RxGOC      : 0
RxEPC1     : 0
RxEPC2     : 0

	enable_mirror_rx: 0
	enable_mirror_tx: 0
	pvid: 1
	link: port:2 link:down
Port 3:
	mib: Port 3 MIB counters
TxGPC      : 0
TxBOC      : 0
TxGOC      : 0
TxEPC      : 0
RxGPC      : 0
RxBOC      : 0
RxGOC      : 0
RxEPC1     : 0
RxEPC2     : 0

	enable_mirror_rx: 0
	enable_mirror_tx: 0
	pvid: 1
	link: port:3 link:down
Port 4:
	mib: Port 4 MIB counters
TxGPC      : 0
TxBOC      : 0
TxGOC      : 0
TxEPC      : 0
RxGPC      : 0
RxBOC      : 0
RxGOC      : 0
RxEPC1     : 0
RxEPC2     : 0

	enable_mirror_rx: 0
	enable_mirror_tx: 0
	pvid: 1
	link: port:4 link:down
Port 5:
	mib: Port 5 MIB counters
TxGPC      : 0
TxBOC      : 0
TxGOC      : 0
TxEPC      : 0
RxGPC      : 0
RxBOC      : 0
RxGOC      : 0
RxEPC1     : 0
RxEPC2     : 0

	enable_mirror_rx: 0
	enable_mirror_tx: 0
	pvid: 1
	link: port:5 link:down
Port 6:
	mib: Port 6 MIB counters
TxGPC      : 0
TxBOC      : 0
TxGOC      : 0
TxEPC      : 0
RxGPC      : 89
RxBOC      : 0
RxGOC      : 15787
RxEPC1     : 0
RxEPC2     : 89

	enable_mirror_rx: 0
	enable_mirror_tx: 0
	pvid: 1
	link: port:6 link:up speed:1000baseT full-duplex 
Port 7:
	mib: Port 7 MIB counters
TxGPC      : 0
TxBOC      : 0
TxGOC      : 0
TxEPC      : 0
RxGPC      : 0
RxBOC      : 0
RxGOC      : 0
RxEPC1     : 0
RxEPC2     : 0

	enable_mirror_rx: 0
	enable_mirror_tx: 0
	pvid: 0
	link: port:7 link:down
VLAN 1:
	vid: 1
	ports: 1 2 3 4 5 6t 
VLAN 2:
	vid: 2
	ports: 0 6t 

$ swconfig dev switch1 show:

Global attributes:
	enable_vlan: 1
	enable_vlan4k: 0
	max_length: 1
Port 0:
	mib: Port 0 MIB counters
ifInOctets                          : 0
dot3StatsFCSErrors                  : 0
dot3StatsSymbolErrors               : 0
dot3InPauseFrames                   : 0
dot3ControlInUnknownOpcodes         : 0
etherStatsFragments                 : 0
etherStatsJabbers                   : 0
ifInUcastPkts                       : 0
etherStatsDropEvents                : 0
ifInMulticastPkts                   : 0
ifInBroadcastPkts                   : 0
inMldChecksumError                  : 0
inIgmpChecksumError                 : 0
inMldSpecificQuery                  : 0
inMldGeneralQuery                   : 0
inIgmpSpecificQuery                 : 0
inIgmpGeneralQuery                  : 0
inMldLeaves                         : 0
inIgmpLeaves                        : 0
etherStatsOctets                    : 0
etherStatsUnderSizePkts             : 0
etherOversizeStats                  : 0
etherStatsPkts64Octets              : 0
etherStatsPkts65to127Octets         : 0
etherStatsPkts128to255Octets        : 0
etherStatsPkts256to511Octets        : 0
etherStatsPkts512to1023Octets       : 0
etherStatsPkts1024to1518Octets      : 0
ifOutOctets                         : 0
dot3StatsSingleCollisionFrames      : 0
dot3StatMultipleCollisionFrames     : 0
dot3sDeferredTransmissions          : 0
dot3StatsLateCollisions             : 0
etherStatsCollisions                : 0
dot3StatsExcessiveCollisions        : 0
dot3OutPauseFrames                  : 0
ifOutDiscards                       : 0
dot1dTpPortInDiscards               : 0
ifOutUcastPkts                      : 0
ifOutMulticastPkts                  : 0
ifOutBroadcastPkts                  : 0
outOampduPkts                       : 0
inOampduPkts                        : 0
inIgmpJoinsSuccess                  : 0
inIgmpJoinsFail                     : 0
inMldJoinsSuccess                   : 0
inMldJoinsFail                      : 0
inReportSuppressionDrop             : 0
inLeaveSuppressionDrop              : 0
outIgmpReports                      : 0
outIgmpLeaves                       : 0
outIgmpGeneralQuery                 : 0
outIgmpSpecificQuery                : 0
outMldReports                       : 0
outMldLeaves                        : 0
outMldGeneralQuery                  : 0
outMldSpecificQuery                 : 0
inKnownMulticastPkts                : 0

	pvid: 1
	link: port:0 link:down
Port 1:
	mib: Port 1 MIB counters
ifInOctets                          : 0
dot3StatsFCSErrors                  : 0
dot3StatsSymbolErrors               : 0
dot3InPauseFrames                   : 0
dot3ControlInUnknownOpcodes         : 0
etherStatsFragments                 : 0
etherStatsJabbers                   : 0
ifInUcastPkts                       : 0
etherStatsDropEvents                : 0
ifInMulticastPkts                   : 0
ifInBroadcastPkts                   : 0
inMldChecksumError                  : 0
inIgmpChecksumError                 : 0
inMldSpecificQuery                  : 0
inMldGeneralQuery                   : 0
inIgmpSpecificQuery                 : 0
inIgmpGeneralQuery                  : 0
inMldLeaves                         : 0
inIgmpLeaves                        : 0
etherStatsOctets                    : 0
etherStatsUnderSizePkts             : 0
etherOversizeStats                  : 0
etherStatsPkts64Octets              : 0
etherStatsPkts65to127Octets         : 0
etherStatsPkts128to255Octets        : 0
etherStatsPkts256to511Octets        : 0
etherStatsPkts512to1023Octets       : 0
etherStatsPkts1024to1518Octets      : 0
ifOutOctets                         : 0
dot3StatsSingleCollisionFrames      : 0
dot3StatMultipleCollisionFrames     : 0
dot3sDeferredTransmissions          : 0
dot3StatsLateCollisions             : 0
etherStatsCollisions                : 0
dot3StatsExcessiveCollisions        : 0
dot3OutPauseFrames                  : 0
ifOutDiscards                       : 0
dot1dTpPortInDiscards               : 0
ifOutUcastPkts                      : 0
ifOutMulticastPkts                  : 0
ifOutBroadcastPkts                  : 0
outOampduPkts                       : 0
inOampduPkts                        : 0
inIgmpJoinsSuccess                  : 0
inIgmpJoinsFail                     : 0
inMldJoinsSuccess                   : 0
inMldJoinsFail                      : 0
inReportSuppressionDrop             : 0
inLeaveSuppressionDrop              : 0
outIgmpReports                      : 0
outIgmpLeaves                       : 0
outIgmpGeneralQuery                 : 0
outIgmpSpecificQuery                : 0
outMldReports                       : 0
outMldLeaves                        : 0
outMldGeneralQuery                  : 0
outMldSpecificQuery                 : 0
inKnownMulticastPkts                : 0

	pvid: 2
	link: port:1 link:down
Port 2:
	mib: Port 2 MIB counters
ifInOctets                          : 0
dot3StatsFCSErrors                  : 0
dot3StatsSymbolErrors               : 0
dot3InPauseFrames                   : 0
dot3ControlInUnknownOpcodes         : 0
etherStatsFragments                 : 0
etherStatsJabbers                   : 0
ifInUcastPkts                       : 0
etherStatsDropEvents                : 0
ifInMulticastPkts                   : 0
ifInBroadcastPkts                   : 0
inMldChecksumError                  : 0
inIgmpChecksumError                 : 0
inMldSpecificQuery                  : 0
inMldGeneralQuery                   : 0
inIgmpSpecificQuery                 : 0
inIgmpGeneralQuery                  : 0
inMldLeaves                         : 0
inIgmpLeaves                        : 0
etherStatsOctets                    : 0
etherStatsUnderSizePkts             : 0
etherOversizeStats                  : 0
etherStatsPkts64Octets              : 0
etherStatsPkts65to127Octets         : 0
etherStatsPkts128to255Octets        : 0
etherStatsPkts256to511Octets        : 0
etherStatsPkts512to1023Octets       : 0
etherStatsPkts1024to1518Octets      : 0
ifOutOctets                         : 0
dot3StatsSingleCollisionFrames      : 0
dot3StatMultipleCollisionFrames     : 0
dot3sDeferredTransmissions          : 0
dot3StatsLateCollisions             : 0
etherStatsCollisions                : 0
dot3StatsExcessiveCollisions        : 0
dot3OutPauseFrames                  : 0
ifOutDiscards                       : 0
dot1dTpPortInDiscards               : 0
ifOutUcastPkts                      : 0
ifOutMulticastPkts                  : 0
ifOutBroadcastPkts                  : 0
outOampduPkts                       : 0
inOampduPkts                        : 0
inIgmpJoinsSuccess                  : 0
inIgmpJoinsFail                     : 0
inMldJoinsSuccess                   : 0
inMldJoinsFail                      : 0
inReportSuppressionDrop             : 0
inLeaveSuppressionDrop              : 0
outIgmpReports                      : 0
outIgmpLeaves                       : 0
outIgmpGeneralQuery                 : 0
outIgmpSpecificQuery                : 0
outMldReports                       : 0
outMldLeaves                        : 0
outMldGeneralQuery                  : 0
outMldSpecificQuery                 : 0
inKnownMulticastPkts                : 0

	pvid: 3
	link: port:2 link:down
Port 3:
	mib: Port 3 MIB counters
ifInOctets                          : 0
dot3StatsFCSErrors                  : 0
dot3StatsSymbolErrors               : 0
dot3InPauseFrames                   : 0
dot3ControlInUnknownOpcodes         : 0
etherStatsFragments                 : 0
etherStatsJabbers                   : 0
ifInUcastPkts                       : 0
etherStatsDropEvents                : 0
ifInMulticastPkts                   : 0
ifInBroadcastPkts                   : 0
inMldChecksumError                  : 0
inIgmpChecksumError                 : 0
inMldSpecificQuery                  : 0
inMldGeneralQuery                   : 0
inIgmpSpecificQuery                 : 0
inIgmpGeneralQuery                  : 0
inMldLeaves                         : 0
inIgmpLeaves                        : 0
etherStatsOctets                    : 0
etherStatsUnderSizePkts             : 0
etherOversizeStats                  : 0
etherStatsPkts64Octets              : 0
etherStatsPkts65to127Octets         : 0
etherStatsPkts128to255Octets        : 0
etherStatsPkts256to511Octets        : 0
etherStatsPkts512to1023Octets       : 0
etherStatsPkts1024to1518Octets      : 0
ifOutOctets                         : 0
dot3StatsSingleCollisionFrames      : 0
dot3StatMultipleCollisionFrames     : 0
dot3sDeferredTransmissions          : 0
dot3StatsLateCollisions             : 0
etherStatsCollisions                : 0
dot3StatsExcessiveCollisions        : 0
dot3OutPauseFrames                  : 0
ifOutDiscards                       : 0
dot1dTpPortInDiscards               : 0
ifOutUcastPkts                      : 0
ifOutMulticastPkts                  : 0
ifOutBroadcastPkts                  : 0
outOampduPkts                       : 0
inOampduPkts                        : 0
inIgmpJoinsSuccess                  : 0
inIgmpJoinsFail                     : 0
inMldJoinsSuccess                   : 0
inMldJoinsFail                      : 0
inReportSuppressionDrop             : 0
inLeaveSuppressionDrop              : 0
outIgmpReports                      : 0
outIgmpLeaves                       : 0
outIgmpGeneralQuery                 : 0
outIgmpSpecificQuery                : 0
outMldReports                       : 0
outMldLeaves                        : 0
outMldGeneralQuery                  : 0
outMldSpecificQuery                 : 0
inKnownMulticastPkts                : 0

	pvid: 4
	link: port:3 link:down
Port 4:
	mib: Port 4 MIB counters
ifInOctets                          : 13624
dot3StatsFCSErrors                  : 0
dot3StatsSymbolErrors               : 0
dot3InPauseFrames                   : 0
dot3ControlInUnknownOpcodes         : 0
etherStatsFragments                 : 0
etherStatsJabbers                   : 0
ifInUcastPkts                       : 0
etherStatsDropEvents                : 0
ifInMulticastPkts                   : 51
ifInBroadcastPkts                   : 94
inMldChecksumError                  : 0
inIgmpChecksumError                 : 0
inMldSpecificQuery                  : 0
inMldGeneralQuery                   : 0
inIgmpSpecificQuery                 : 0
inIgmpGeneralQuery                  : 0
inMldLeaves                         : 0
inIgmpLeaves                        : 0
etherStatsOctets                    : 13624
etherStatsUnderSizePkts             : 0
etherOversizeStats                  : 0
etherStatsPkts64Octets              : 97
etherStatsPkts65to127Octets         : 15
etherStatsPkts128to255Octets        : 33
etherStatsPkts256to511Octets        : 0
etherStatsPkts512to1023Octets       : 0
etherStatsPkts1024to1518Octets      : 0
ifOutOctets                         : 0
dot3StatsSingleCollisionFrames      : 0
dot3StatMultipleCollisionFrames     : 0
dot3sDeferredTransmissions          : 0
dot3StatsLateCollisions             : 0
etherStatsCollisions                : 0
dot3StatsExcessiveCollisions        : 0
dot3OutPauseFrames                  : 0
ifOutDiscards                       : 0
dot1dTpPortInDiscards               : 145
ifOutUcastPkts                      : 0
ifOutMulticastPkts                  : 0
ifOutBroadcastPkts                  : 0
outOampduPkts                       : 0
inOampduPkts                        : 0
inIgmpJoinsSuccess                  : 7
inIgmpJoinsFail                     : 0
inMldJoinsSuccess                   : 8
inMldJoinsFail                      : 0
inReportSuppressionDrop             : 0
inLeaveSuppressionDrop              : 0
outIgmpReports                      : 0
outIgmpLeaves                       : 0
outIgmpGeneralQuery                 : 0
outIgmpSpecificQuery                : 0
outMldReports                       : 0
outMldLeaves                        : 0
outMldGeneralQuery                  : 0
outMldSpecificQuery                 : 0
inKnownMulticastPkts                : 0

	pvid: 5
	link: port:4 link:up speed:1000baseT full-duplex txflow rxflow auto
Port 5:
	mib: Port 5 MIB counters
ifInOctets                          : 0
dot3StatsFCSErrors                  : 0
dot3StatsSymbolErrors               : 0
dot3InPauseFrames                   : 0
dot3ControlInUnknownOpcodes         : 0
etherStatsFragments                 : 0
etherStatsJabbers                   : 0
ifInUcastPkts                       : 0
etherStatsDropEvents                : 0
ifInMulticastPkts                   : 0
ifInBroadcastPkts                   : 0
inMldChecksumError                  : 0
inIgmpChecksumError                 : 0
inMldSpecificQuery                  : 0
inMldGeneralQuery                   : 0
inIgmpSpecificQuery                 : 0
inIgmpGeneralQuery                  : 0
inMldLeaves                         : 0
inIgmpLeaves                        : 0
etherStatsOctets                    : 0
etherStatsUnderSizePkts             : 0
etherOversizeStats                  : 0
etherStatsPkts64Octets              : 0
etherStatsPkts65to127Octets         : 0
etherStatsPkts128to255Octets        : 0
etherStatsPkts256to511Octets        : 0
etherStatsPkts512to1023Octets       : 0
etherStatsPkts1024to1518Octets      : 0
ifOutOctets                         : 0
dot3StatsSingleCollisionFrames      : 0
dot3StatMultipleCollisionFrames     : 0
dot3sDeferredTransmissions          : 0
dot3StatsLateCollisions             : 0
etherStatsCollisions                : 0
dot3StatsExcessiveCollisions        : 0
dot3OutPauseFrames                  : 0
ifOutDiscards                       : 0
dot1dTpPortInDiscards               : 0
ifOutUcastPkts                      : 0
ifOutMulticastPkts                  : 0
ifOutBroadcastPkts                  : 0
outOampduPkts                       : 0
inOampduPkts                        : 0
inIgmpJoinsSuccess                  : 0
inIgmpJoinsFail                     : 0
inMldJoinsSuccess                   : 0
inMldJoinsFail                      : 0
inReportSuppressionDrop             : 0
inLeaveSuppressionDrop              : 0
outIgmpReports                      : 0
outIgmpLeaves                       : 0
outIgmpGeneralQuery                 : 0
outIgmpSpecificQuery                : 0
outMldReports                       : 0
outMldLeaves                        : 0
outMldGeneralQuery                  : 0
outMldSpecificQuery                 : 0
inKnownMulticastPkts                : 0

	pvid: 6
	link: port:5 link:down
Port 6:
	mib: Port 6 MIB counters
ifInOctets                          : 0
dot3StatsFCSErrors                  : 0
dot3StatsSymbolErrors               : 0
dot3InPauseFrames                   : 0
dot3ControlInUnknownOpcodes         : 0
etherStatsFragments                 : 0
etherStatsJabbers                   : 0
ifInUcastPkts                       : 0
etherStatsDropEvents                : 0
ifInMulticastPkts                   : 0
ifInBroadcastPkts                   : 0
inMldChecksumError                  : 0
inIgmpChecksumError                 : 0
inMldSpecificQuery                  : 0
inMldGeneralQuery                   : 0
inIgmpSpecificQuery                 : 0
inIgmpGeneralQuery                  : 0
inMldLeaves                         : 0
inIgmpLeaves                        : 0
etherStatsOctets                    : 0
etherStatsUnderSizePkts             : 0
etherOversizeStats                  : 0
etherStatsPkts64Octets              : 0
etherStatsPkts65to127Octets         : 0
etherStatsPkts128to255Octets        : 0
etherStatsPkts256to511Octets        : 0
etherStatsPkts512to1023Octets       : 0
etherStatsPkts1024to1518Octets      : 0
ifOutOctets                         : 0
dot3StatsSingleCollisionFrames      : 0
dot3StatMultipleCollisionFrames     : 0
dot3sDeferredTransmissions          : 0
dot3StatsLateCollisions             : 0
etherStatsCollisions                : 0
dot3StatsExcessiveCollisions        : 0
dot3OutPauseFrames                  : 0
ifOutDiscards                       : 0
dot1dTpPortInDiscards               : 0
ifOutUcastPkts                      : 0
ifOutMulticastPkts                  : 0
ifOutBroadcastPkts                  : 0
outOampduPkts                       : 0
inOampduPkts                        : 0
inIgmpJoinsSuccess                  : 0
inIgmpJoinsFail                     : 0
inMldJoinsSuccess                   : 0
inMldJoinsFail                      : 0
inReportSuppressionDrop             : 0
inLeaveSuppressionDrop              : 0
outIgmpReports                      : 0
outIgmpLeaves                       : 0
outIgmpGeneralQuery                 : 0
outIgmpSpecificQuery                : 0
outMldReports                       : 0
outMldLeaves                        : 0
outMldGeneralQuery                  : 0
outMldSpecificQuery                 : 0
inKnownMulticastPkts                : 0

	pvid: 7
	link: port:6 link:up speed:1000baseT full-duplex txflow rxflow 
Port 7:
	mib: Port 7 MIB counters
ifInOctets                          : 0
dot3StatsFCSErrors                  : 0
dot3StatsSymbolErrors               : 0
dot3InPauseFrames                   : 0
dot3ControlInUnknownOpcodes         : 0
etherStatsFragments                 : 0
etherStatsJabbers                   : 0
ifInUcastPkts                       : 0
etherStatsDropEvents                : 0
ifInMulticastPkts                   : 0
ifInBroadcastPkts                   : 0
inMldChecksumError                  : 0
inIgmpChecksumError                 : 0
inMldSpecificQuery                  : 0
inMldGeneralQuery                   : 0
inIgmpSpecificQuery                 : 0
inIgmpGeneralQuery                  : 0
inMldLeaves                         : 0
inIgmpLeaves                        : 0
etherStatsOctets                    : 0
etherStatsUnderSizePkts             : 0
etherOversizeStats                  : 0
etherStatsPkts64Octets              : 0
etherStatsPkts65to127Octets         : 0
etherStatsPkts128to255Octets        : 0
etherStatsPkts256to511Octets        : 0
etherStatsPkts512to1023Octets       : 0
etherStatsPkts1024to1518Octets      : 0
ifOutOctets                         : 0
dot3StatsSingleCollisionFrames      : 0
dot3StatMultipleCollisionFrames     : 0
dot3sDeferredTransmissions          : 0
dot3StatsLateCollisions             : 0
etherStatsCollisions                : 0
dot3StatsExcessiveCollisions        : 0
dot3OutPauseFrames                  : 0
ifOutDiscards                       : 0
dot1dTpPortInDiscards               : 0
ifOutUcastPkts                      : 0
ifOutMulticastPkts                  : 0
ifOutBroadcastPkts                  : 0
outOampduPkts                       : 0
inOampduPkts                        : 0
inIgmpJoinsSuccess                  : 0
inIgmpJoinsFail                     : 0
inMldJoinsSuccess                   : 0
inMldJoinsFail                      : 0
inReportSuppressionDrop             : 0
inLeaveSuppressionDrop              : 0
outIgmpReports                      : 0
outIgmpLeaves                       : 0
outIgmpGeneralQuery                 : 0
outIgmpSpecificQuery                : 0
outMldReports                       : 0
outMldLeaves                        : 0
outMldGeneralQuery                  : 0
outMldSpecificQuery                 : 0
inKnownMulticastPkts                : 0

	pvid: 8
	link: port:7 link:down
VLAN 1:
	info: VLAN 1: Ports: '07', members=0081, untag=0081, fid=0
	ports: 0 7 
VLAN 2:
	info: VLAN 2: Ports: '17', members=0082, untag=0082, fid=0
	ports: 1 7 
VLAN 3:
	info: VLAN 3: Ports: '27', members=0084, untag=0084, fid=0
	ports: 2 7 
VLAN 4:
	info: VLAN 4: Ports: '37', members=0088, untag=0088, fid=0
	ports: 3 7 
VLAN 5:
	info: VLAN 5: Ports: '47', members=0090, untag=0090, fid=0
	ports: 4 7 
VLAN 6:
	info: VLAN 6: Ports: '57', members=00a0, untag=00a0, fid=0
	ports: 5 7 
VLAN 7:
	info: VLAN 7: Ports: '67', members=00c0, untag=00c0, fid=0
	ports: 6 7 
VLAN 8:
	info: VLAN 8: Ports: '01234567', members=00ff, untag=00ff, fid=0
	ports: 0 1 2 3 4 5 6 7 

Patch i did for rtl8367b.c:

@@ -1541,6 +1541,7 @@ static int rtl8367b_detect(struct rtl8366_smi *smi)
        }
 
        switch (chip_ver) {
+    case 0x0020:
        case 0x1000:
                chip_name = "8367RB";
                break;

I also added mac handle to 02_network:

@@ -285,6 +289,7 @@ ramips_setup_macs()
                label_mac=$(mtd_get_mac_binary factory 0x4)
                ;;
        asus,rt-ac51u|\
+       asus,rt-ac53|\
        asus,rt-ac54u)
                lan_mac=$(mtd_get_mac_binary factory 0x22)
                ;;

Im not experienced in openwrt porting and will appreciate any help. Looks like im not so far from adding support for it.

Try extented port 2

		realtek,extif2 = <1 0 1 1 1 1 1 1 2>;

Tried extented port 2: switch1 changed some its info. Still cant connect with LAN ports (however switch1 port3 still shows cable connection to LAN1 as link:up) and no changes in network interfaces.

root@OpenWrt:~# swconfig dev switch1 show
Global attributes:
	enable_vlan: 1
	enable_vlan4k: 0
	max_length: 1
Port 0:
	mib: Port 0 MIB counters
ifInOctets                          : 0
dot3StatsFCSErrors                  : 0
dot3StatsSymbolErrors               : 0
dot3InPauseFrames                   : 0
dot3ControlInUnknownOpcodes         : 0
etherStatsFragments                 : 0
etherStatsJabbers                   : 0
ifInUcastPkts                       : 0
etherStatsDropEvents                : 0
ifInMulticastPkts                   : 0
ifInBroadcastPkts                   : 0
inMldChecksumError                  : 0
inIgmpChecksumError                 : 0
inMldSpecificQuery                  : 0
inMldGeneralQuery                   : 0
inIgmpSpecificQuery                 : 0
inIgmpGeneralQuery                  : 0
inMldLeaves                         : 0
inIgmpLeaves                        : 0
etherStatsOctets                    : 0
etherStatsUnderSizePkts             : 0
etherOversizeStats                  : 0
etherStatsPkts64Octets              : 0
etherStatsPkts65to127Octets         : 0
etherStatsPkts128to255Octets        : 0
etherStatsPkts256to511Octets        : 0
etherStatsPkts512to1023Octets       : 0
etherStatsPkts1024to1518Octets      : 0
ifOutOctets                         : 0
dot3StatsSingleCollisionFrames      : 0
dot3StatMultipleCollisionFrames     : 0
dot3sDeferredTransmissions          : 0
dot3StatsLateCollisions             : 0
etherStatsCollisions                : 0
dot3StatsExcessiveCollisions        : 0
dot3OutPauseFrames                  : 0
ifOutDiscards                       : 0
dot1dTpPortInDiscards               : 0
ifOutUcastPkts                      : 0
ifOutMulticastPkts                  : 0
ifOutBroadcastPkts                  : 0
outOampduPkts                       : 0
inOampduPkts                        : 0
inIgmpJoinsSuccess                  : 0
inIgmpJoinsFail                     : 0
inMldJoinsSuccess                   : 0
inMldJoinsFail                      : 0
inReportSuppressionDrop             : 0
inLeaveSuppressionDrop              : 0
outIgmpReports                      : 0
outIgmpLeaves                       : 0
outIgmpGeneralQuery                 : 0
outIgmpSpecificQuery                : 0
outMldReports                       : 0
outMldLeaves                        : 0
outMldGeneralQuery                  : 0
outMldSpecificQuery                 : 0
inKnownMulticastPkts                : 0

	pvid: 1
	link: port:0 link:down
Port 1:
	mib: Port 1 MIB counters
ifInOctets                          : 0
dot3StatsFCSErrors                  : 0
dot3StatsSymbolErrors               : 0
dot3InPauseFrames                   : 0
dot3ControlInUnknownOpcodes         : 0
etherStatsFragments                 : 0
etherStatsJabbers                   : 0
ifInUcastPkts                       : 0
etherStatsDropEvents                : 0
ifInMulticastPkts                   : 0
ifInBroadcastPkts                   : 0
inMldChecksumError                  : 0
inIgmpChecksumError                 : 0
inMldSpecificQuery                  : 0
inMldGeneralQuery                   : 0
inIgmpSpecificQuery                 : 0
inIgmpGeneralQuery                  : 0
inMldLeaves                         : 0
inIgmpLeaves                        : 0
etherStatsOctets                    : 0
etherStatsUnderSizePkts             : 0
etherOversizeStats                  : 0
etherStatsPkts64Octets              : 0
etherStatsPkts65to127Octets         : 0
etherStatsPkts128to255Octets        : 0
etherStatsPkts256to511Octets        : 0
etherStatsPkts512to1023Octets       : 0
etherStatsPkts1024to1518Octets      : 0
ifOutOctets                         : 0
dot3StatsSingleCollisionFrames      : 0
dot3StatMultipleCollisionFrames     : 0
dot3sDeferredTransmissions          : 0
dot3StatsLateCollisions             : 0
etherStatsCollisions                : 0
dot3StatsExcessiveCollisions        : 0
dot3OutPauseFrames                  : 0
ifOutDiscards                       : 0
dot1dTpPortInDiscards               : 0
ifOutUcastPkts                      : 0
ifOutMulticastPkts                  : 0
ifOutBroadcastPkts                  : 0
outOampduPkts                       : 0
inOampduPkts                        : 0
inIgmpJoinsSuccess                  : 0
inIgmpJoinsFail                     : 0
inMldJoinsSuccess                   : 0
inMldJoinsFail                      : 0
inReportSuppressionDrop             : 0
inLeaveSuppressionDrop              : 0
outIgmpReports                      : 0
outIgmpLeaves                       : 0
outIgmpGeneralQuery                 : 0
outIgmpSpecificQuery                : 0
outMldReports                       : 0
outMldLeaves                        : 0
outMldGeneralQuery                  : 0
outMldSpecificQuery                 : 0
inKnownMulticastPkts                : 0

	pvid: 1
	link: port:1 link:down
Port 2:
	mib: Port 2 MIB counters
ifInOctets                          : 0
dot3StatsFCSErrors                  : 0
dot3StatsSymbolErrors               : 0
dot3InPauseFrames                   : 0
dot3ControlInUnknownOpcodes         : 0
etherStatsFragments                 : 0
etherStatsJabbers                   : 0
ifInUcastPkts                       : 0
etherStatsDropEvents                : 0
ifInMulticastPkts                   : 0
ifInBroadcastPkts                   : 0
inMldChecksumError                  : 0
inIgmpChecksumError                 : 0
inMldSpecificQuery                  : 0
inMldGeneralQuery                   : 0
inIgmpSpecificQuery                 : 0
inIgmpGeneralQuery                  : 0
inMldLeaves                         : 0
inIgmpLeaves                        : 0
etherStatsOctets                    : 0
etherStatsUnderSizePkts             : 0
etherOversizeStats                  : 0
etherStatsPkts64Octets              : 0
etherStatsPkts65to127Octets         : 0
etherStatsPkts128to255Octets        : 0
etherStatsPkts256to511Octets        : 0
etherStatsPkts512to1023Octets       : 0
etherStatsPkts1024to1518Octets      : 0
ifOutOctets                         : 0
dot3StatsSingleCollisionFrames      : 0
dot3StatMultipleCollisionFrames     : 0
dot3sDeferredTransmissions          : 0
dot3StatsLateCollisions             : 0
etherStatsCollisions                : 0
dot3StatsExcessiveCollisions        : 0
dot3OutPauseFrames                  : 0
ifOutDiscards                       : 0
dot1dTpPortInDiscards               : 0
ifOutUcastPkts                      : 0
ifOutMulticastPkts                  : 0
ifOutBroadcastPkts                  : 0
outOampduPkts                       : 0
inOampduPkts                        : 0
inIgmpJoinsSuccess                  : 0
inIgmpJoinsFail                     : 0
inMldJoinsSuccess                   : 0
inMldJoinsFail                      : 0
inReportSuppressionDrop             : 0
inLeaveSuppressionDrop              : 0
outIgmpReports                      : 0
outIgmpLeaves                       : 0
outIgmpGeneralQuery                 : 0
outIgmpSpecificQuery                : 0
outMldReports                       : 0
outMldLeaves                        : 0
outMldGeneralQuery                  : 0
outMldSpecificQuery                 : 0
inKnownMulticastPkts                : 0

	pvid: 1
	link: port:2 link:down
Port 3:
	mib: Port 3 MIB counters
ifInOctets                          : 3622
dot3StatsFCSErrors                  : 0
dot3StatsSymbolErrors               : 0
dot3InPauseFrames                   : 0
dot3ControlInUnknownOpcodes         : 0
etherStatsFragments                 : 0
etherStatsJabbers                   : 0
ifInUcastPkts                       : 0
etherStatsDropEvents                : 0
ifInMulticastPkts                   : 17
ifInBroadcastPkts                   : 4
inMldChecksumError                  : 0
inIgmpChecksumError                 : 0
inMldSpecificQuery                  : 0
inMldGeneralQuery                   : 0
inIgmpSpecificQuery                 : 0
inIgmpGeneralQuery                  : 0
inMldLeaves                         : 0
inIgmpLeaves                        : 0
etherStatsOctets                    : 3622
etherStatsUnderSizePkts             : 0
etherOversizeStats                  : 0
etherStatsPkts64Octets              : 0
etherStatsPkts65to127Octets         : 8
etherStatsPkts128to255Octets        : 9
etherStatsPkts256to511Octets        : 4
etherStatsPkts512to1023Octets       : 0
etherStatsPkts1024to1518Octets      : 0
ifOutOctets                         : 0
dot3StatsSingleCollisionFrames      : 0
dot3StatMultipleCollisionFrames     : 0
dot3sDeferredTransmissions          : 0
dot3StatsLateCollisions             : 0
etherStatsCollisions                : 0
dot3StatsExcessiveCollisions        : 0
dot3OutPauseFrames                  : 0
ifOutDiscards                       : 0
dot1dTpPortInDiscards               : 21
ifOutUcastPkts                      : 0
ifOutMulticastPkts                  : 0
ifOutBroadcastPkts                  : 0
outOampduPkts                       : 0
inOampduPkts                        : 0
inIgmpJoinsSuccess                  : 0
inIgmpJoinsFail                     : 0
inMldJoinsSuccess                   : 6
inMldJoinsFail                      : 0
inReportSuppressionDrop             : 0
inLeaveSuppressionDrop              : 0
outIgmpReports                      : 0
outIgmpLeaves                       : 0
outIgmpGeneralQuery                 : 0
outIgmpSpecificQuery                : 0
outMldReports                       : 0
outMldLeaves                        : 0
outMldGeneralQuery                  : 0
outMldSpecificQuery                 : 0
inKnownMulticastPkts                : 0

	pvid: 1
	link: port:3 link:up speed:1000baseT full-duplex txflow rxflow auto
Port 4:
	mib: Port 4 MIB counters
ifInOctets                          : 6277
dot3StatsFCSErrors                  : 0
dot3StatsSymbolErrors               : 0
dot3InPauseFrames                   : 0
dot3ControlInUnknownOpcodes         : 0
etherStatsFragments                 : 0
etherStatsJabbers                   : 0
ifInUcastPkts                       : 0
etherStatsDropEvents                : 0
ifInMulticastPkts                   : 30
ifInBroadcastPkts                   : 20
inMldChecksumError                  : 0
inIgmpChecksumError                 : 0
inMldSpecificQuery                  : 0
inMldGeneralQuery                   : 0
inIgmpSpecificQuery                 : 0
inIgmpGeneralQuery                  : 0
inMldLeaves                         : 0
inIgmpLeaves                        : 0
etherStatsOctets                    : 6277
etherStatsUnderSizePkts             : 0
etherOversizeStats                  : 0
etherStatsPkts64Octets              : 18
etherStatsPkts65to127Octets         : 12
etherStatsPkts128to255Octets        : 16
etherStatsPkts256to511Octets        : 4
etherStatsPkts512to1023Octets       : 0
etherStatsPkts1024to1518Octets      : 0
ifOutOctets                         : 0
dot3StatsSingleCollisionFrames      : 0
dot3StatMultipleCollisionFrames     : 0
dot3sDeferredTransmissions          : 0
dot3StatsLateCollisions             : 0
etherStatsCollisions                : 0
dot3StatsExcessiveCollisions        : 0
dot3OutPauseFrames                  : 0
ifOutDiscards                       : 0
dot1dTpPortInDiscards               : 50
ifOutUcastPkts                      : 0
ifOutMulticastPkts                  : 0
ifOutBroadcastPkts                  : 0
outOampduPkts                       : 0
inOampduPkts                        : 0
inIgmpJoinsSuccess                  : 4
inIgmpJoinsFail                     : 0
inMldJoinsSuccess                   : 7
inMldJoinsFail                      : 0
inReportSuppressionDrop             : 0
inLeaveSuppressionDrop              : 0
outIgmpReports                      : 0
outIgmpLeaves                       : 0
outIgmpGeneralQuery                 : 0
outIgmpSpecificQuery                : 0
outMldReports                       : 0
outMldLeaves                        : 0
outMldGeneralQuery                  : 0
outMldSpecificQuery                 : 0
inKnownMulticastPkts                : 0

	pvid: 1
	link: port:4 link:down
Port 5:
	mib: Port 5 MIB counters
ifInOctets                          : 0
dot3StatsFCSErrors                  : 0
dot3StatsSymbolErrors               : 0
dot3InPauseFrames                   : 0
dot3ControlInUnknownOpcodes         : 0
etherStatsFragments                 : 0
etherStatsJabbers                   : 0
ifInUcastPkts                       : 0
etherStatsDropEvents                : 0
ifInMulticastPkts                   : 0
ifInBroadcastPkts                   : 0
inMldChecksumError                  : 0
inIgmpChecksumError                 : 0
inMldSpecificQuery                  : 0
inMldGeneralQuery                   : 0
inIgmpSpecificQuery                 : 0
inIgmpGeneralQuery                  : 0
inMldLeaves                         : 0
inIgmpLeaves                        : 0
etherStatsOctets                    : 0
etherStatsUnderSizePkts             : 0
etherOversizeStats                  : 0
etherStatsPkts64Octets              : 0
etherStatsPkts65to127Octets         : 0
etherStatsPkts128to255Octets        : 0
etherStatsPkts256to511Octets        : 0
etherStatsPkts512to1023Octets       : 0
etherStatsPkts1024to1518Octets      : 0
ifOutOctets                         : 0
dot3StatsSingleCollisionFrames      : 0
dot3StatMultipleCollisionFrames     : 0
dot3sDeferredTransmissions          : 0
dot3StatsLateCollisions             : 0
etherStatsCollisions                : 0
dot3StatsExcessiveCollisions        : 0
dot3OutPauseFrames                  : 0
ifOutDiscards                       : 0
dot1dTpPortInDiscards               : 0
ifOutUcastPkts                      : 0
ifOutMulticastPkts                  : 0
ifOutBroadcastPkts                  : 0
outOampduPkts                       : 0
inOampduPkts                        : 0
inIgmpJoinsSuccess                  : 0
inIgmpJoinsFail                     : 0
inMldJoinsSuccess                   : 0
inMldJoinsFail                      : 0
inReportSuppressionDrop             : 0
inLeaveSuppressionDrop              : 0
outIgmpReports                      : 0
outIgmpLeaves                       : 0
outIgmpGeneralQuery                 : 0
outIgmpSpecificQuery                : 0
outMldReports                       : 0
outMldLeaves                        : 0
outMldGeneralQuery                  : 0
outMldSpecificQuery                 : 0
inKnownMulticastPkts                : 0

	pvid: 1
	link: port:5 link:down
Port 6:
	mib: Port 6 MIB counters
ifInOctets                          : 0
dot3StatsFCSErrors                  : 0
dot3StatsSymbolErrors               : 0
dot3InPauseFrames                   : 0
dot3ControlInUnknownOpcodes         : 0
etherStatsFragments                 : 0
etherStatsJabbers                   : 0
ifInUcastPkts                       : 0
etherStatsDropEvents                : 0
ifInMulticastPkts                   : 0
ifInBroadcastPkts                   : 0
inMldChecksumError                  : 0
inIgmpChecksumError                 : 0
inMldSpecificQuery                  : 0
inMldGeneralQuery                   : 0
inIgmpSpecificQuery                 : 0
inIgmpGeneralQuery                  : 0
inMldLeaves                         : 0
inIgmpLeaves                        : 0
etherStatsOctets                    : 0
etherStatsUnderSizePkts             : 0
etherOversizeStats                  : 0
etherStatsPkts64Octets              : 0
etherStatsPkts65to127Octets         : 0
etherStatsPkts128to255Octets        : 0
etherStatsPkts256to511Octets        : 0
etherStatsPkts512to1023Octets       : 0
etherStatsPkts1024to1518Octets      : 0
ifOutOctets                         : 0
dot3StatsSingleCollisionFrames      : 0
dot3StatMultipleCollisionFrames     : 0
dot3sDeferredTransmissions          : 0
dot3StatsLateCollisions             : 0
etherStatsCollisions                : 0
dot3StatsExcessiveCollisions        : 0
dot3OutPauseFrames                  : 0
ifOutDiscards                       : 0
dot1dTpPortInDiscards               : 0
ifOutUcastPkts                      : 0
ifOutMulticastPkts                  : 0
ifOutBroadcastPkts                  : 0
outOampduPkts                       : 0
inOampduPkts                        : 0
inIgmpJoinsSuccess                  : 0
inIgmpJoinsFail                     : 0
inMldJoinsSuccess                   : 0
inMldJoinsFail                      : 0
inReportSuppressionDrop             : 0
inLeaveSuppressionDrop              : 0
outIgmpReports                      : 0
outIgmpLeaves                       : 0
outIgmpGeneralQuery                 : 0
outIgmpSpecificQuery                : 0
outMldReports                       : 0
outMldLeaves                        : 0
outMldGeneralQuery                  : 0
outMldSpecificQuery                 : 0
inKnownMulticastPkts                : 0

	pvid: 1
	link: port:6 link:down
Port 7:
	mib: Port 7 MIB counters
ifInOctets                          : 0
dot3StatsFCSErrors                  : 0
dot3StatsSymbolErrors               : 0
dot3InPauseFrames                   : 0
dot3ControlInUnknownOpcodes         : 0
etherStatsFragments                 : 0
etherStatsJabbers                   : 0
ifInUcastPkts                       : 0
etherStatsDropEvents                : 0
ifInMulticastPkts                   : 0
ifInBroadcastPkts                   : 0
inMldChecksumError                  : 0
inIgmpChecksumError                 : 0
inMldSpecificQuery                  : 0
inMldGeneralQuery                   : 0
inIgmpSpecificQuery                 : 0
inIgmpGeneralQuery                  : 0
inMldLeaves                         : 0
inIgmpLeaves                        : 0
etherStatsOctets                    : 0
etherStatsUnderSizePkts             : 0
etherOversizeStats                  : 0
etherStatsPkts64Octets              : 0
etherStatsPkts65to127Octets         : 0
etherStatsPkts128to255Octets        : 0
etherStatsPkts256to511Octets        : 0
etherStatsPkts512to1023Octets       : 0
etherStatsPkts1024to1518Octets      : 0
ifOutOctets                         : 0
dot3StatsSingleCollisionFrames      : 0
dot3StatMultipleCollisionFrames     : 0
dot3sDeferredTransmissions          : 0
dot3StatsLateCollisions             : 0
etherStatsCollisions                : 0
dot3StatsExcessiveCollisions        : 0
dot3OutPauseFrames                  : 0
ifOutDiscards                       : 0
dot1dTpPortInDiscards               : 0
ifOutUcastPkts                      : 0
ifOutMulticastPkts                  : 0
ifOutBroadcastPkts                  : 0
outOampduPkts                       : 0
inOampduPkts                        : 0
inIgmpJoinsSuccess                  : 0
inIgmpJoinsFail                     : 0
inMldJoinsSuccess                   : 0
inMldJoinsFail                      : 0
inReportSuppressionDrop             : 0
inLeaveSuppressionDrop              : 0
outIgmpReports                      : 0
outIgmpLeaves                       : 0
outIgmpGeneralQuery                 : 0
outIgmpSpecificQuery                : 0
outMldReports                       : 0
outMldLeaves                        : 0
outMldGeneralQuery                  : 0
outMldSpecificQuery                 : 0
inKnownMulticastPkts                : 0

	pvid: 1
	link: port:7 link:up speed:1000baseT full-duplex txflow rxflow 
VLAN 1:
	info: VLAN 1: Ports: '12346t', members=005e, untag=001e, fid=0
	ports: 1 2 3 4 6t 

dmesg output (too much characters when editing post to add there):

[    0.000000] Linux version 5.10.90 ($USER@$HOST) (mipsel-openwrt-linux-musl-gcc (OpenWrt GCC 11.2.0 r18504-4d1f133561) 11.2.0, GNU ld (GNU Binutils) 2.37) #0 Sun Jan 9 11:15:18 2022
[    0.000000] Board has DDR2
[    0.000000] Analog PMU set to hw control
[    0.000000] Digital PMU set to hw control
[    0.000000] SoC Type: MediaTek MT7620A ver:2 eco:6
[    0.000000] printk: bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019650 (MIPS 24KEc)
[    0.000000] MIPS: machine is Asus RT-AC53
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] On node 0 totalpages: 16384
[    0.000000]   Normal zone: 144 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 16384 pages, LIFO batch:3
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0 
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 16240
[    0.000000] Kernel command line: console=ttyS0,57600 rootfstype=squashfs,jffs2
[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes, linear)
[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes, linear)
[    0.000000] Writing ErrCtl register=000407f0
[    0.000000] Readback ErrCtl register=000407f0
[    0.000000] mem auto-init: stack:off, heap alloc:off, heap free:off
[    0.000000] Memory: 56408K/65536K available (5233K kernel code, 610K rwdata, 1108K rodata, 1232K init, 209K bss, 9128K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS: 256
[    0.000000] random: get_random_bytes called from start_kernel+0x3b8/0x5a8 with crng_init=0
[    0.000000] CPU Clock: 580MHz
[    0.000000] clocksource: systick: mask: 0xffff max_cycles: 0xffff, max_idle_ns: 583261500 ns
[    0.000000] systick: enable autosleep mode
[    0.000000] systick: running - mult: 214748, shift: 32
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 6590553264 ns
[    0.000012] sched_clock: 32 bits at 290MHz, resolution 3ns, wraps every 7405115902ns
[    0.007582] Calibrating delay loop... 383.38 BogoMIPS (lpj=1916928)
[    0.073396] pid_max: default: 32768 minimum: 301
[    0.078091] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.085117] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.094929] dyndbg: Ignore empty _ddebug table in a CONFIG_DYNAMIC_DEBUG_CORE build
[    0.107323] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.116869] futex hash table entries: 256 (order: -1, 3072 bytes, linear)
[    0.123525] pinctrl core: initialized pinctrl subsystem
[    0.129190] NET: Registered protocol family 16
[    0.403588] PCI host bridge /pcie@10140000 ranges:
[    0.408208]  MEM 0x0000000020000000..0x000000002fffffff
[    0.413236]   IO 0x0000000010160000..0x000000001016ffff
[    0.465890] rt2880_gpio 10000600.gpio: registering 24 gpios
[    0.471374] rt2880_gpio 10000600.gpio: registering 24 irq handlers
[    0.477351] gpio-10 (enable-leds): hogged as output/low
[    0.482736] rt2880_gpio 10000688.gpio: registering 1 gpios
[    0.488031] rt2880_gpio 10000688.gpio: registering 1 irq handlers
[    0.495717] PCI host bridge to bus 0000:00
[    0.499644] pci_bus 0000:00: root bus resource [mem 0x20000000-0x2fffffff]
[    0.506351] pci_bus 0000:00: root bus resource [io  0x10160000-0x1016ffff]
[    0.512952] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0]
[    0.519533] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    0.527255] pci 0000:00:00.0: [1814:0801] type 01 class 0x060400
[    0.533043] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x7fffffff]
[    0.539090] pci 0000:00:00.0: reg 0x14: [mem 0x20200000-0x2020ffff]
[    0.545269] pci 0000:00:00.0: supports D1
[    0.549085] pci 0000:00:00.0: PME# supported from D0 D1 D3hot
[    0.557137] pci 0000:01:00.0: [14c3:7650] type 00 class 0x028000
[    0.562928] pci 0000:01:00.0: reg 0x10: [mem 0x00000000-0x000fffff]
[    0.569161] pci 0000:01:00.0: PME# supported from D0 D3hot D3cold
[    0.575478] pci 0000:01:00.1: [14c3:8650] type 00 class 0x0d1100
[    0.581307] pci 0000:01:00.1: reg 0x10: [mem 0x00000000-0x000fffff]
[    0.587460] pci 0000:01:00.1: supports D1
[    0.591283] pci 0000:01:00.1: PME# supported from D0 D1 D3hot D3cold
[    0.599318] pci_bus 0000:01: busn_res: [bus 01-ff] end is updated to 01
[    0.605698] pci_bus 0000:00: busn_res: [bus 00-ff] end is updated to 01
[    0.612109] pci 0000:00:00.0: BAR 0: no space for [mem size 0x80000000]
[    0.618487] pci 0000:00:00.0: BAR 0: failed to assign [mem size 0x80000000]
[    0.625226] pci 0000:00:00.0: BAR 8: assigned [mem 0x20000000-0x201fffff]
[    0.631806] pci 0000:00:00.0: BAR 1: assigned [mem 0x20200000-0x2020ffff]
[    0.638385] pci 0000:01:00.0: BAR 0: assigned [mem 0x20000000-0x200fffff]
[    0.644965] pci 0000:01:00.1: BAR 0: assigned [mem 0x20100000-0x201fffff]
[    0.651533] pci 0000:00:00.0: PCI bridge to [bus 01]
[    0.656344] pci 0000:00:00.0:   bridge window [mem 0x20000000-0x201fffff]
[    0.671870] clocksource: Switched to clocksource systick
[    0.678447] NET: Registered protocol family 2
[    0.682894] IP idents hash table entries: 2048 (order: 2, 16384 bytes, linear)
[    0.690599] tcp_listen_portaddr_hash hash table entries: 512 (order: 0, 4096 bytes, linear)
[    0.698773] TCP established hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.706170] TCP bind hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.712988] TCP: Hash tables configured (established 1024 bind 1024)
[    0.719288] UDP hash table entries: 256 (order: 0, 4096 bytes, linear)
[    0.725629] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes, linear)
[    0.732656] NET: Registered protocol family 1
[    0.736902] PCI: CLS 0 bytes, default 32
[    0.745886] rt-timer 10000100.timer: maximum frequency is 1220Hz
[    0.754653] workingset: timestamp_bits=14 max_order=14 bucket_order=0
[    0.766468] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.772122] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.785167] Serial: 8250/16550 driver, 2 ports, IRQ sharing disabled
[    0.792482] printk: console [ttyS0] disabled
[    0.796665] 10000c00.uartlite: ttyS0 at MMIO 0x10000c00 (irq = 20, base_baud = 2500000) is a Palmchip BK-3103
[    0.806327] printk: console [ttyS0] enabled
[    0.822766] printk: bootconsole [early0] disabled
[    0.852002] spi spi0.0: force spi mode3
[    0.861110] spi-nor spi0.0: gd25q64 (8192 Kbytes)
[    0.870616] 4 fixed-partitions partitions found on MTD device spi0.0
[    0.883258] Creating 4 MTD partitions on "spi0.0":
[    0.892795] 0x000000000000-0x000000030000 : "u-boot"
[    0.904901] 0x000000030000-0x000000040000 : "u-boot-env"
[    0.916700] 0x000000040000-0x000000050000 : "factory"
[    0.929855] 0x000000050000-0x000001000000 : "firmware"
[    0.940151] mtd: partition "firmware" extends beyond the end of device "spi0.0" -- size truncated to 0x7b0000
[    0.961294] 2 uimage-fw partitions found on MTD device firmware
[    0.973092] Creating 2 MTD partitions on "firmware":
[    0.982970] 0x000000000000-0x0000002119f1 : "kernel"
[    0.992837] mtd: partition "kernel" doesn't end on an erase/write block -- force read-only
[    1.012308] 0x0000002119f1-0x0000007b0000 : "rootfs"
[    1.022275] mtd: partition "rootfs" doesn't start on an erase/write block boundary -- force read-only
[    1.042676] mtd: device 5 (rootfs) set to be root filesystem
[    1.054130] 1 squashfs-split partitions found on MTD device rootfs
[    1.066462] 0x000000538000-0x0000007b0000 : "rootfs_data"
[    1.083879] libphy: Fixed MDIO Bus: probed
[    1.110400] gsw: ephy base address: 8
[    1.119085] gsw: setting port4 to ephy mode
[    1.128632] libphy: mdio: probed
[    1.135363] mtk_soc_eth 10100000.ethernet: loaded mt7620 driver
[    1.147898] mtk_soc_eth 10100000.ethernet eth0: mediatek frame engine at 0xb0100000, irq 5
[    1.165035] rt2880_wdt 10000120.watchdog: Initialized
[    1.176361] NET: Registered protocol family 10
[    1.190860] Segment Routing with IPv6
[    1.198292] NET: Registered protocol family 17
[    1.207276] 8021q: 802.1Q VLAN Support v1.8
[    1.226770] VFS: Mounted root (squashfs filesystem) readonly on device 31:5.
[    1.247796] Freeing unused kernel memory: 1232K
[    1.256838] This architecture does not have kernel memory protection.
[    1.269653] Run /sbin/init as init process
[    1.277791]   with arguments:
[    1.277798]     /sbin/init
[    1.277803]   with environment:
[    1.277809]     HOME=/
[    1.277815]     TERM=linux
[    2.158807] init: Console is alive
[    2.166175] init: - watchdog -
[    2.467066] random: fast init done
[    3.482548] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    3.682474] rtl8367b rtl8367rb: using MDIO bus 'mdio'
[    3.693528] rtl8367b rtl8367rb: RTL8367RB chip found
[    4.722796] libphy: rtl8367rb: probed
[    4.735803] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    4.754017] init: - preinit -
[    6.153078] random: jshn: uninitialized urandom read (4 bytes read)
[    6.313829] random: jshn: uninitialized urandom read (4 bytes read)
[    6.349531] random: jshn: uninitialized urandom read (4 bytes read)
[    6.502823] 8021q: adding VLAN 0 to HW filter on device eth0
[    7.211931] jffs2_scan_eraseblock(): End of filesystem marker found at 0x2000
[    7.226416] jffs2_build_filesystem(): unlocking the mtd device... 
[    7.226466] done.
[    7.242583] jffs2_build_filesystem(): erasing all blocks after the end marker... 
[   37.431333] done.
[   37.450088] jffs2: notice: (381) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[   37.482881] mount_root: overlay filesystem has not been fully initialized yet
[   37.503519] mount_root: switching to jffs2 overlay
[   37.518701] overlayfs: upper fs does not support tmpfile.
[   38.443791] urandom-seed: Seed file not found (/etc/urandom.seed)
[   38.748236] procd: - early -
[   38.754413] procd: - watchdog -
[   38.939247] procd: - watchdog -
[   38.947592] procd: - ubus -
[   39.074846] urandom_read: 4 callbacks suppressed
[   39.074857] random: ubusd: uninitialized urandom read (4 bytes read)
[   39.100199] random: ubusd: uninitialized urandom read (4 bytes read)
[   39.113604] random: ubusd: uninitialized urandom read (4 bytes read)
[   39.130663] procd: - init -
[   40.929627] kmodloader: loading kernel modules from /etc/modules.d/*
[   41.640442] urngd: jent-rng init failed, err: 2
[   41.691118] Loading modules backported from Linux version v5.15.8-0-g43e577d7a2cb
[   41.706073] Backport generated by backports.git v5.15.8-1-0-g83f664bb
[   41.759598] xt_time: kernel timezone is -0000
[   41.969158] PPP generic driver version 2.4.2
[   41.981245] NET: Registered protocol family 24
[   42.027054] mt76x0e 0000:01:00.0: card - bus=0x1, slot = 0x0 irq=4
[   42.039737] mt76x0e 0000:01:00.0: ASIC revision: 76100002
[   42.052728] mt76x0e 0000:01:00.0: Firmware Version: 0.1.00
[   42.094316] mt76x0e 0000:01:00.0: EEPROM ver:01 fae:00
[   42.107230] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   42.251709] rt2800_wmac 10180000.wmac: loaded eeprom from mtd device "factory"
[   42.266170] ieee80211 phy1: rt2x00_set_rt: Info - RT chipset 6352, rev 0500 detected
[   42.281603] ieee80211 phy1: rt2x00_set_rf: Info - RF chipset 7620 detected
[   42.295528] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
[   42.323632] kmodloader: done loading kernel modules from /etc/modules.d/*
[   53.350108] random: crng init done
[   66.370315] 8021q: adding VLAN 0 to HW filter on device eth0
[   66.387683] br-lan: port 1(eth0) entered blocking state
[   66.398161] br-lan: port 1(eth0) entered disabled state
[   66.408973] device eth0 entered promiscuous mode
[   66.479791] br-lan: port 1(eth0) entered blocking state
[   66.490258] br-lan: port 1(eth0) entered forwarding state
[   67.414142] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   70.259278] ieee80211 phy1: rt2800_rf_self_txdc_cal: Info - RF Tx self calibration start
[   70.275957] ieee80211 phy1: rt2800_rf_self_txdc_cal: Info - RF Tx self calibration end
[   73.505518] ieee80211 phy1: rt2800_loft_iq_calibration: Info - LOFT Calibration Done!
[   73.524623] ieee80211 phy1: rt2800_read_fft_accumulation: Info - I = -36,  Q = 26, power = 7b4
[   73.542197] ieee80211 phy1: rt2800_read_fft_accumulation: Info - I = 27,  Q = 11, power = 352
[   73.559604] ieee80211 phy1: rt2800_read_fft_accumulation: Info - I = 16,  Q = 29, power = 449
[   73.577009] ieee80211 phy1: rt2800_read_fft_accumulation: Info - I = -3,  Q = 31, power = 3ca
[   73.594415] ieee80211 phy1: rt2800_read_fft_accumulation: Info - I = -39,  Q = 0, power = 5f1
[   73.611820] ieee80211 phy1: rt2800_read_fft_accumulation: Info - I = 19,  Q = -1, power = 16a
[   73.629231] ieee80211 phy1: rt2800_read_fft_accumulation: Info - I = 11,  Q = -13, power = 122
[   73.646809] ieee80211 phy1: rt2800_read_fft_accumulation: Info - I = -8,  Q = -18, power = 184
[   73.664389] ieee80211 phy1: rt2800_read_fft_accumulation: Info - I = -21,  Q = -20, power = 349
[   73.682139] ieee80211 phy1: rt2800_read_fft_accumulation: Info - I = 9,  Q = -24, power = 291
[   73.699096] ieee80211 phy1: rt2800_iq_search: Info - IQCalibration Start!
[   73.726440] ieee80211 phy1: rt2800_iq_search: Info - IQCalibration Done! CH = 0, (gain= 1, phase=3c)
[   73.745068] ieee80211 phy1: rt2800_read_fft_accumulation: Info - I = -8,  Q = -57, power = cf1
[   73.762647] ieee80211 phy1: rt2800_read_fft_accumulation: Info - I = -11,  Q = -2, power = 7d
[   73.780054] ieee80211 phy1: rt2800_read_fft_accumulation: Info - I = -13,  Q = 78, power = 186d
[   73.797804] ieee80211 phy1: rt2800_read_fft_accumulation: Info - I = 49,  Q = 3, power = 96a
[   73.815040] ieee80211 phy1: rt2800_read_fft_accumulation: Info - I = -49,  Q = 56, power = 15a1
[   73.832790] ieee80211 phy1: rt2800_read_fft_accumulation: Info - I = 44,  Q = -47, power = 1031
[   73.850544] ieee80211 phy1: rt2800_read_fft_accumulation: Info - I = -63,  Q = 17, power = 10a2
[   73.868305] ieee80211 phy1: rt2800_read_fft_accumulation: Info - I = -23,  Q = 60, power = 1021
[   73.886059] ieee80211 phy1: rt2800_read_fft_accumulation: Info - I = 96,  Q = -24, power = 2640
[   73.903823] ieee80211 phy1: rt2800_read_fft_accumulation: Info - I = -16,  Q = -63, power = 1081
[   73.921758] ieee80211 phy1: rt2800_read_fft_accumulation: Info - I = 87,  Q = 125, power = 5a9a
[   73.939510] ieee80211 phy1: rt2800_read_fft_accumulation: Info - I = 66,  Q = 61, power = 1f8d
[   73.956636] ieee80211 phy1: rt2800_iq_search: Info - IQCalibration Start!
[   73.984425] ieee80211 phy1: rt2800_iq_search: Info - IQCalibration Done! CH = 1, (gain= 0, phase=3e)
[   74.002616] ieee80211 phy1: rt2800_loft_iq_calibration: Info - TX IQ Calibration Done!
[   74.036610] ieee80211 phy1: rt2800_rxiq_calibration: Info - RXIQ G_imb=0, Ph_rx=-5
[   74.061878] ieee80211 phy1: rt2800_rxiq_calibration: Info - RXIQ G_imb=-2, Ph_rx=2
[   74.079933] ieee80211 phy1: rt2800_config_channel: Warning - Using incomplete support for external PA
[   74.541657] br-lan: port 2(wlan0) entered blocking state
[   74.552400] br-lan: port 2(wlan0) entered disabled state
[   74.563438] device wlan0 entered promiscuous mode
[   74.573020] br-lan: port 2(wlan0) entered blocking state
[   74.583619] br-lan: port 2(wlan0) entered forwarding state
[   74.827164] ieee80211 phy1: rt2800_config_channel: Warning - Using incomplete support for external PA
[   74.969881] ieee80211 phy1: rt2800_config_channel: Warning - Using incomplete support for external PA
[   75.101042] br-lan: port 2(wlan0) entered disabled state
[   75.115374] ieee80211 phy1: rt2800_config_channel: Warning - Using incomplete support for external PA
[   75.145343] ieee80211 phy1: rt2800_config_channel: Warning - Using incomplete support for external PA
[   75.175247] ieee80211 phy1: rt2800_config_channel: Warning - Using incomplete support for external PA
[   75.199395] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   75.212356] br-lan: port 2(wlan0) entered blocking state
[   75.222963] br-lan: port 2(wlan0) entered forwarding state
[   75.324717] ieee80211 phy1: rt2800_config_channel: Warning - Using incomplete support for external PA
[   75.446283] ieee80211 phy1: rt2800_config_channel: Warning - Using incomplete support for external PA
[   75.485807] ieee80211 phy1: rt2800_config_channel: Warning - Using incomplete support for external PA
[   75.515937] ieee80211 phy1: rt2800_config_channel: Warning - Using incomplete support for external PA

Did you look around in the original Asus source code?
I was doing this for two repeaters and found all essential info in the sources, also some more info in the oldest source available in one case.

Just for info read this topic. Chipset rt3352 is very similar to mt7620a in case of external switch.
I'll try to answer your question.

BTW it looks like your device have rtl8367sb switch which use another init procedure. (see PR 4327).

1 Like

With patches to rtl8366_smi.{c,h}, rtl8367b.c and using compatible = "realtek,rtl8367c"; in dts from this link i can now see some new ETH interfaces in ifconfig:

root@OpenWrt:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr $( ETH0_MAC )  
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: $( IP_V6_1/64 ) Scope:Linkk
          inet6 addr: $( IP_V6_2/60 ) Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4298 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4104 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:421116 (411.2 KiB)  TX bytes:2454072 (2.3 MiB)

eth0      Link encap:Ethernet  HWaddr $( ETH0_MAC )    
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:315 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:67485 (65.9 KiB)
          Interrupt:5 

eth0.1    Link encap:Ethernet  HWaddr $( ETH0_MAC + 4 )    
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:70 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:11337 (11.0 KiB)

eth0.2    Link encap:Ethernet  HWaddr $( ETH0_MAC )   
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:154 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:40065 (39.1 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:249 errors:0 dropped:0 overruns:0 frame:0
          TX packets:249 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:21593 (21.0 KiB)  TX bytes:21593 (21.0 KiB)

wlan0     Link encap:Ethernet  HWaddr B0:6E:BF:49:D7:F4  
          inet6 addr: $( IP_V6_1/64) Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4302 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3404 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:481714 (470.4 KiB)  TX bytes:2557813 (2.4 MiB)

wlan1     Link encap:Ethernet  HWaddr B0:6E:BF:49:D7:F0  
          inet addr:192.168.0.X  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: $( IP_V6_1/64) Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2798 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2608 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2063124 (1.9 MiB)  TX bytes:361440 (352.9 KiB)

However i still cant connect to router LAN ports. I cant exactly understand if it still some hardware or network configuration problem. If it can help, there is current /etc/config/network:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix ' $( IP_V6_3/48 )'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'
	list ports 'eth0.1'
	list ports 'eth0.2'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'eth0.2'
	option proto 'dhcp'

config interface 'wan6'
	option device 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '0'

config switch
	option name 'switch1'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch1'
	option vlan '1'
	option ports '1 2 3 4 6t'

config switch_vlan
	option device 'switch1'
	option vlan '2'
	option ports '0 6t'

config interface 'wwan'
	option proto 'dhcp'

UPD:
I can also actually access switches section in LuCI now.

Something wrong with switch connection.
If we assume that port 5 of internal mt7620 switch is connected to port7 of rtl8367s (the most possible configuration) than no link between switches. I.e. no link on port5 and extif2 (port 7 of rtl8367s or cpu port).
Pay attention - port7. So this:

config switch_vlan
	option device 'switch1'
	option vlan '1'
	option ports '1 2 3 4 6t'

config switch_vlan
	option device 'switch1'
	option vlan '2'
	option ports '0 6t'

is incorrect. Change to 7
For port5 of mt7620 link check port@5 settings as example.
For port7 of rtl8367s check realtek,extif2:

	rtl8367s {
		compatible = "realtek,rtl8367c";
		cpu_port = <7>;
		realtek,extif2 = <1 0 1 1 1 1 1 1 2>;
		mii-bus = <&mdio0>;
		phy-id = <29>;
	};

BTW content of network file and output of commands

swconfig dev switch0 show
swconfig dev switch1 show

is more informative than pictures.

After a long break I tried your suggestion with port 7 but nothing worked. However I actually got switch working with such changes:

rtl8367s {
		compatible = "realtek,rtl8367c";
		mii-bus = <&mdio0>;
		cpu_port = <6>;
		realtek,extif1 = <1 0 1 1 1 1 1 1 2>;
};

and network config:

asus,rt-ac53)
		ucidef_add_switch "switch0" \
			"5:lan" "6@eth0"
		ucidef_add_switch "switch1" \
			"3:lan:1" "4:lan:2" "0:wan" "6t@eth0"
		ucidef_add_switch_attr "switch0" "enable" "false"
		;;

Now both LAN ports work without problem. As i understand the connection between switches is: port 5 of mt7620 switch is connected to port6 of rtl8367s. If im wrong please correct me. Also as i understand
rtl8367s switch patches still not merged to openwrt so i cant add support to RT-AC53.

If anyone interested in this model which works pretty stable on openwrt for me now, I have public repo with its support:

1 Like

Nice, however in my case the following chip_ver value is 0x0070, where you have 0x0020:

@@ -1541,6 +1541,7 @@ static int rtl8367b_detect(struct rtl8366_smi *smi)
        }
 
        switch (chip_ver) {
+    case 0x0020:
        case 0x1000:
                chip_name = "8367RB";
                break;

Looks like there are more different versions around and hard to tell what are these exactly, that's why I stopped my work on this device before.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.