Problem with flashing OpenWrt Fritzbox 4040

I have problems to get a ftp connection to the FB 4040.
I followed the installation instruction on the OpenWrt side for FB4040.
But I always get the message "connection refused"
Tried also an other Lan port.
Any idea, what I can anything else?
Thx.

Never did that myself, but the FTP for flashing is only enabled during a certain time frame during boot, while the bootloader is active. How often did you try different points in time?

1 Like

Try putting an unmanaged switch in between as well, if you have/can get one.

1 Like

Got the same problem. Has AVM possibly made any changes in OS 7.10 or the recovery tool?
I had OpenWRT up and running. Then I bricked it and found it easier just to do a recovery with the AVM tool and reinstall OpnWRT.
But since them Iā€˜m unable to hit the timeslot to connect via ftp. First time it was the moment after the ping was replied during boot. But now, whatever I try - no success... Same on a second box I bought on ebay to set up it for my parents place.

Thank you!

Found a trick.
You need a Windows computer. From AVMs website ownload a recovery tool NOT intended for the 4040 model.
Start the recovery process as described in the running app. It will not install the wrong firmware but will stop. But it won't close the connection to the 4040. So you can just kick in.

1 Like

Great idea, thx. Will try.

1 Like

Just wanted to tell you that this worked flawlessly! I couldn't get any connection using Linux or Windows but this worked on the first try - thanks!

1 Like