Problem with Dumb AP

Hi Mates,
I come to you because I'm struggling with configuring my router as Dumb AP. I have followed the instruction, and everything seems working fine except pinging wireless devices. Ping seems not arriving from router to any wireless device and also form wireless to any other wireless. Pinging from wireless to wired devices works.

So in more details, I've got souch devices:
AP (OpenWRT) - 192.168.1.2
MBP - 192.168.1.24 - wireless
PC - 192.168.1.18 - wirelses
RPI - 192.168.1.19 - wired

Pings:
AP -> MBP - not working
PC -> MBP - not working
MBP -> PC - not working
AP -> PC - not working
RPI -> MBP - not working
RPI -> PC - not working

MBP -> RPI - working
PC -> RPI - working
RPI -> AP working
AP -> RPI working
MBP -> AP - working
PC -> AP - rorking

My configs:

OpenWrt 19.07.2 r10947-65030d81f3
firewall, dnsmasq and odhcpd - disabled

/etc/config/network
config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd71:5e9c:1b5e::/48'

config interface 'lan'
	option ifname 'eth1.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.2'
	option gateway '192.168.1.1'
	option broadcast '192.168.1.0'
	list dns '1.1.1.1'
	list dns '1.0.0.1'
	list dns '8.8.8.8'
	list dns '8.8.4.4'
	option type 'bridge'

config switch
	option name 'switch0'
	option reset '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '6t 4 3 2 1'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t 5'
	option vid '2'
/etc/config/wireless 

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option legacy_rates '1'
	option country 'PL'
	option channel '100'
	option htmode 'VHT80'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option ssid 'Nighthawk-5G'
	option encryption 'psk2'
	option key '****'
	option network 'lan'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
	option htmode 'HT20'
	option country 'US'
	option legacy_rates '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option mode 'ap'
	option ssid 'Nighthawk-2G'
	option encryption 'psk2'
	option key '****'
	option network 'lan'

I'd really appreciate your help.

Perhaps you should use the canonical approach:

# ipcalc 192.168.1.2/24
Address:	192.168.1.2
Network:	192.168.1.0/24
Netmask:	255.255.255.0 = 24
Broadcast:	192.168.1.255

Or better just remove it:

uci -q delete network.lan.broadcast
uci commit network
/etc/init.d/network restart
1 Like

Here is my configuration on my r7800 AP.

Basic initial steps:

  1. Make sure you are wired to one of the LAN ports on the AP (for simplicity)
  2. Looks like you have some custom settings for broadcasting, DNS, and VLAN ID. Agree with @vgaetera above on the settings. Setting up a dumb access point is much easier than this. I’d just turn off DHCP and set a static IP. The router upstream manages everything else. You might want to restart to default settings and start fresh, adding one small thing at a time.
  3. For wireless I’d use the same country code and use “force AES” encryption for your psk2.

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd41:5884:4a02::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.2'
        option gateway '192.168.1.1'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0t'