Problem with Dumb AP mode and impossible reset modem

Modem: TP-Link TL- MR3020 / Driver: 17.01.5 / OS: Debian 9

Hi, i tried config my modem on Dumb AP mode, but i did the wrong things. I followed the official guide.

I do:

  • Select the checkbox "Ignore interface: Disable DHCP for this interface".

I don't:

  • Set an IP
  • Disable Firewall

Well, the thing no work and i tried return to defaults setting ... but now I can't access to Luci, my modem isn't recognize. And the BIG problem: I can't reset my modem, cuz I din't enable theReset Functionality of my modem, so it's impossible use the reset button.

Question: How to recovery my modem?

Try find it on network thru ipv6

Thanks, but i use Debian.

It was a link with generic instruction for various OS, buy anyway

https://manpages.debian.org/stretch/iproute2/ip.8.en.html

$ ip neighbour

well, i type ip neighbour and show me a list of ports (?):

192.168.0.22 dev wlp3s0 lladdr 50:85:69:8e:68:0f STALE
192.168.0.254 dev wlp3s0 FAILED
192.168.0.36 dev wlp3s0 FAILED
192.168.0.3 dev wlp3s0 lladdr 74:54:7d:e4:78:39 REACHABLE

Really the code show more entries, various STALE that don't work, and only REACHABLE that is my other modem.

Any chance you can test with an Ethernet cable connected directly between your PC and the modem

Configure static IP in the same subnet and try to ping the modem.

Excuse me @vgaetera but I'm newbie. How to know what is the same subnet number? and How to ping the modem?

You're going to have a very difficult time configuring your router without this knowledge.

Subnetting:

Ping:

Don't spook us like that :slight_smile:

https://en.m.wikipedia.org/wiki/Subnetwork

1 Like

Better post for a basic understanding!

:+1:

Well. I set for wire connect a static IP. I connect my latop to principal modem and my MR3020 too:

Latptop ---- cable --> Principal Modem <--cable--- MR3020

Then, i type ip neighbour command and out only info about ports of principal modem.

Latptop <----cable---> MR3020

With this scheme: Latptop <---cable---> MR3020
Command: ip neighbour
Out:

192.168.0.2 dev enp12s0 FAILED
fe80::1ad6:c7ff:fe43:365l dev enp12s0 lladdr 18:d6:c7:43:35:9c router REACHABLE

---UPDATE---
I install net-tools and use arp -a:

? (192.168.0.2) at < incomplete > on enp12s0

Ignore IPv4
Use the IPv6 address ip neighbour displays for router

fe80::1ad6:c7ff:fe43:3651

http://[fe80::1ad6:c7ff:fe43:3651]

1 Like

Nothing happens. White screen on Firefox 62

Try SSH with the same ipv6 addr

Weee! I can connect to my MR3020 modem via ssh.

But is neccesary add the name of net card, on terminal (more info):

ssh root@IPv6%net_card

ssh root@fe80::1ad6:c7ff:fe43:3651%enp12

And prompt appear and you input your password.

Now, I must rest the modem via terminal?

1 Like

You can either try to fix the configuration through UCI or just reset it:
https://openwrt.org/docs/guide-user/troubleshooting/failsafe_and_factory_reset#factory_reset

1 Like

Thank you very much @vgaetera, I've followed that guide and I've restarted my modem and PC, and now I recovery LUCI.
Regards.

1 Like