Problem with connection to WPA3 AP

Hello. I try to connect to WPA3-Personal AP from custom built OpenWrt, but don't have any success. At first I try to use 'uci' to set a configuration. After I call 'wifi' command. But doesn't some success. Only WPA2 works ('psk2' encryption), but not 'sae'.
I use this to set the config:

uci set wireless.@wifi-iface[1].ssid='NXPDemo' &&
uci set wireless.@wifi-iface[1].encryption='sae' &&
uci set wireless.@wifi-iface[1].key='1234567890' &&
uci set wireless.@wifi-iface[1].disabled='0'

Then I call 'wifi' command, but link doesn't up.
What I missed? I installed wpad_basic_openssl to be ensure that CONFIG_SAE=y, but still no effect. When I try use wpa_supplicant, I get 'invalid key_mgmt 'sae' '

wpa_supplicant -Dnl80211 -iwlan0 -c/etc/wp
a_supplicant.conf
Successfully initialized wpa_supplicant
Line 7: invalid key_mgmt 'SAE'
Line 7: no key_mgmt values configured.
Line 7: failed to parse key_mgmt 'SAE'.
Line 13: failed to parse network block.
Failed to read or parse configuration '/etc/wpa_supplicant.conf'.

Thanks.

Start by reducing the number of unknown variables and test an unmodified OpenWrt (release-) image for your device.

This is a custom device from our local company. So I don't have 'unmodified OpenWrt image' for this. This (def image) doesn't exists. I only know that WPA3 doesn't work now. All ok with WPA2. But I need WPA3, wifi module supports this, but the system itself cannot to set connection.
At first step I need help to figure out, why

Line 7: invalid key_mgmt 'SAE'

Seems I installed all that need for CONFIG_SAE=y. But something goes wrong. Can I check that CONFIG_SAE=y inside image using cli??

Which OpenWrt version your private fork is based on?
Wpa3 support is rather new in OpenWrt, so hopefully your fork is based on a recent OpenWrt.

We use 21.02.0 forked version. As I know WPA3 support started from 19.x.x (don't remember minor numbers). But major 21 is enough actual I think.

-basic- did not support WPA3, you need -mesh- or -full- flavour.

Thanks. I forgot -openssl package of wpad. Not it works. But for some reason now 'uci' setter fallen down and doesn't set options in etc/config/wireless anymore :grinning:

I installed them. Now SAE is parsed well. But the next errors I see trying to connect:

wlan0: WPA: Failed to select authenticated key management type
wlan0: WPA: Failed to set WPA key management and encryption suites